aboutsummaryrefslogtreecommitdiff
path: root/mail/queue-repair/Makefile
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2006-08-07 11:08:20 +0000
committerRenato Botelho <garga@FreeBSD.org>2006-08-07 11:08:20 +0000
commit7a9c82a69cc07addb59c441a7ff9328a8bc23890 (patch)
tree25614307d4c6b206c24aa36119bd3798b736809d /mail/queue-repair/Makefile
parentea816eefc7393fed9dd692cb943a0261e4af7052 (diff)
downloadports-7a9c82a69cc07addb59c441a7ff9328a8bc23890.tar.gz
ports-7a9c82a69cc07addb59c441a7ff9328a8bc23890.zip
Notes
Diffstat (limited to 'mail/queue-repair/Makefile')
-rw-r--r--mail/queue-repair/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/mail/queue-repair/Makefile b/mail/queue-repair/Makefile
index f4326d1afb62..45d15787cad4 100644
--- a/mail/queue-repair/Makefile
+++ b/mail/queue-repair/Makefile
@@ -20,7 +20,8 @@ USE_QMAIL_RUN= yes
USE_PYTHON= yes
-DOCS= BLURB CHANGELOG TODO
+PLIST_FILES= bin/queue-repair
+PORTDOCS= BLURB CHANGELOG TODO
do-build:
${REINPLACE_CMD} -e 's,^#!/usr/bin/python,#!${PYTHON_CMD},' \
@@ -33,7 +34,9 @@ do-install:
${INSTALL_SCRIPT} ${WRKSRC}/queue_repair.py ${PREFIX}/bin/queue-repair
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
+. for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+. endfor
.endif
.include <bsd.port.mk>