aboutsummaryrefslogtreecommitdiff
path: root/mail/quickml/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2010-09-03 18:02:26 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2010-09-03 18:02:26 +0000
commit7646f603020e733ef34c2cea864b2529a8cd15e2 (patch)
treeeeb4d622365de5f6e2fce666be0209f9bd2ad67e /mail/quickml/Makefile
parent6687e67fcb99c8dc64158f13f93f194df16087be (diff)
Notes
Diffstat (limited to 'mail/quickml/Makefile')
-rw-r--r--mail/quickml/Makefile15
1 files changed, 5 insertions, 10 deletions
diff --git a/mail/quickml/Makefile b/mail/quickml/Makefile
index e0baa0c54bfc..68a3a5b1bfb0 100644
--- a/mail/quickml/Makefile
+++ b/mail/quickml/Makefile
@@ -17,23 +17,21 @@ COMMENT= An easy-to-use mailing list system
OPTIONS+= ANALOG "Enable quickml-analog" on \
LIMIT "Enable Creators and Members Limitation Patch" off
-PKGINSTALL= ${WRKDIR}/pkg-install
-SUB_FILES+= pkg-install
+USERS= quickml
+GROUPS= quickml
-QUICKML_USER= quickml
-QUICKML_GROUP= quickml
+LICENSE= GPLv2
USE_AUTOTOOLS= autoconf:262
GNU_CONFIGURE= yes
USE_RUBY= yes
USE_RC_SUBR= ${PORTNAME}
-SUB_LIST+= USER=${QUICKML_USER} GROUP=${QUICKML_GROUP} RUBY=${RUBY}
CONFIGURE_ARGS+= --datadir="${PREFIX}/share/quickml"
CONFIGURE_ARGS+= --with-ruby="${RUBY}"
-CONFIGURE_ARGS+= --with-user="${QUICKML_USER}"
-CONFIGURE_ARGS+= --with-group="${QUICKML_GROUP}"
+CONFIGURE_ARGS+= --with-user="${USERS}"
+CONFIGURE_ARGS+= --with-group="${GROUPS}"
CONFIGURE_ARGS+= --with-rubydir="${RUBY_LIBDIR}"
.include <bsd.port.pre.mk>
@@ -61,9 +59,6 @@ post-patch:
${PATCH} ${PATCH_DIST_ARGS} < ${FILESDIR}/without_quickml-analog
.endif
-pre-install:
- @${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
-
post-install:
${MKDIR} ${DATADIR}
${INSTALL_DATA} ${WRKSRC}/messages.ja ${DATADIR}