aboutsummaryrefslogtreecommitdiff
path: root/mail/quickml
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2005-01-08 18:17:14 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2005-01-08 18:17:14 +0000
commitbfaee97454a218f7a0260622c444d19f8e85d06e (patch)
tree0a89f69705526874a8a701dc80f8a209faccb442 /mail/quickml
parenta51f6158b45cb49c4d8e64e64c6ed940630a4584 (diff)
downloadports-bfaee97454a218f7a0260622c444d19f8e85d06e.tar.gz
ports-bfaee97454a218f7a0260622c444d19f8e85d06e.zip
Notes
Diffstat (limited to 'mail/quickml')
-rw-r--r--mail/quickml/Makefile15
1 files changed, 14 insertions, 1 deletions
diff --git a/mail/quickml/Makefile b/mail/quickml/Makefile
index b7d4ef3fabb4..4f1776ae58fc 100644
--- a/mail/quickml/Makefile
+++ b/mail/quickml/Makefile
@@ -14,7 +14,8 @@ MASTER_SITES= http://namazu.org/%7esatoru/quickml/
MAINTAINER= yaizawa@mdbl.sfc.keio.ac.jp
COMMENT= An easy-to-use mailing list system
-OPTIONS+= ANALOG "Enable quickml-analog" on
+OPTIONS+= ANALOG "Enable quickml-analog" on \
+ LIMIT "Enable Creators and Members Limitation Patch" off
PKGINSTALL= ${WRKDIR}/pkg-install
@@ -38,13 +39,25 @@ CONFIGURE_ARGS+= --with-rubydir="${RUBY_LIBDIR}"
.include <bsd.port.pre.mk>
+.if !defined(WITHOUT_LIMIT)
+PATCH_DIST_STRIP= -p1
+.endif
+
.if !defined(WITHOUT_ANALOG)
USE_GHOSTSCRIPT_RUN= yes
RUN_DEPENDS+= gnuplot:${PORTSDIR}/math/gnuplot \
convert:${PORTSDIR}/graphics/ImageMagick
.endif
+post-fetch:
+.if !defined(WITHOUT_LIMIT)
+ @ ( cd ${DISTDIR} && ${FETCH_CMD} -o ${PORTNAME}-${PORTVERSION}-limited.patch "http://linux.matchy.net/view.xcg?c=plugin;plugin=attach_download;p=QuickMLLimited;file_name=${PORTNAME}-${PORTVERSION}-limited.patch" )
+.endif
+
post-patch:
+.if !defined(WITHOUT_LIMIT)
+ ${PATCH} ${PATCH_DIST_ARGS} < ${DISTDIR}/${PORTNAME}-${PORTVERSION}-limited.patch
+.endif
@${SED} ${FILES_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
${FILESDIR}/quickml.sh > ${WRKDIR}/quickml.sh
.if defined(WITHOUT_ANALOG)