aboutsummaryrefslogtreecommitdiff
path: root/mail/rabl_client
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2005-10-08 04:57:47 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2005-10-08 04:57:47 +0000
commitec9a17067ccd41a2af93545a997ea99a5207b16b (patch)
treeb90b5a116fb829ea3adc826d57b5f9ac40d1c061 /mail/rabl_client
parent038f64cf1b8f3b56ef263057bd75a06d8c3606ed (diff)
downloadports-ec9a17067ccd41a2af93545a997ea99a5207b16b.tar.gz
ports-ec9a17067ccd41a2af93545a997ea99a5207b16b.zip
Notes
Diffstat (limited to 'mail/rabl_client')
-rw-r--r--mail/rabl_client/Makefile53
-rw-r--r--mail/rabl_client/distinfo2
-rw-r--r--mail/rabl_client/files/patch-Makefile.in13
-rw-r--r--mail/rabl_client/pkg-descr21
-rw-r--r--mail/rabl_client/pkg-plist3
5 files changed, 92 insertions, 0 deletions
diff --git a/mail/rabl_client/Makefile b/mail/rabl_client/Makefile
new file mode 100644
index 000000000000..e5939fa11e95
--- /dev/null
+++ b/mail/rabl_client/Makefile
@@ -0,0 +1,53 @@
+# New ports collection makefile for: rabl_client
+# Date created: 2005-10-07
+# Whom: Ion-Mihai "IOnut" Tetcu <itetcu@people.tecnik93.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= rabl_client
+PORTVERSION= 1.0.0
+CATEGORIES= mail dns
+MASTER_SITES= http://www.nuclearelephant.com/projects/rabl/sources/ \
+ http://people.tecnik93.com/~itetcu/FreeBSD/ports/${PORTNAME}/sources/
+
+MAINTAINER= itetcu@people.tecnik93.com
+COMMENT= Reactive Autonomous Blackhole List client
+
+USE_LIBTOOL_VER= 15
+GNU_CONFIGURE= yes
+INSTALLS_SHLIB= yes
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS+= --prefix=${PREFIX} \
+ --localstatedir=${VAR_DIR}
+
+VAR_DIR?= /var/spool/${PORTNAME}
+
+PORTDOCS= CHANGE README RELEASE.NOTES
+
+OPTIONS= DEBUG "Enable DEBUG messages" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+= --enable-debug
+CFLAGS+= -g -DDEBUG
+STRIP_CMD= # empty
+.endif
+
+post-install:
+ ${INSTALL} -o ${SHAREOWN} -g ${SHAREGRP} -m 0640 \
+ ${WRKSRC}/${PORTNAME}.conf ${PREFIX}/etc/${PORTNAME}.conf.sample
+.if !exists(${PREFIX}/etc/${PORTNAME}.conf)
+ ${INSTALL} -o ${SHAREOWN} -g ${SHAREGRP} -m 0640 \
+ ${WRKSRC}/${PORTNAME}.conf ${PREFIX}/etc
+.endif
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for i in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/mail/rabl_client/distinfo b/mail/rabl_client/distinfo
new file mode 100644
index 000000000000..e35b9ac45fa9
--- /dev/null
+++ b/mail/rabl_client/distinfo
@@ -0,0 +1,2 @@
+MD5 (rabl_client-1.0.0.tar.gz) = 4703ead788f62f3d69427b5e0c82faa5
+SIZE (rabl_client-1.0.0.tar.gz) = 305620
diff --git a/mail/rabl_client/files/patch-Makefile.in b/mail/rabl_client/files/patch-Makefile.in
new file mode 100644
index 000000000000..2cad8a71d01c
--- /dev/null
+++ b/mail/rabl_client/files/patch-Makefile.in
@@ -0,0 +1,13 @@
+--- Makefile.in.orig Sat Oct 8 01:42:56 2005
++++ Makefile.in Sat Oct 8 01:43:27 2005
+@@ -716,10 +716,6 @@
+
+ install-exec-hook:
+ $(mkinstalldirs) $(DESTDIR)$(userdir)
+- -if test ! -f $(DESTDIR)$(sysconfdir)/rabl_client.conf; then \
+- cp rabl_client.conf $(DESTDIR)$(sysconfdir)/rabl_client.conf; \
+- chmod 640 $(DESTDIR)$(sysconfdir)/rabl_client.conf; \
+- fi
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
+ .NOEXPORT:
diff --git a/mail/rabl_client/pkg-descr b/mail/rabl_client/pkg-descr
new file mode 100644
index 000000000000..73091ee1c966
--- /dev/null
+++ b/mail/rabl_client/pkg-descr
@@ -0,0 +1,21 @@
+The RABL (pronounced "rabble") server is a statistical, machine-automated and
+up-to-the-second blackhole list server designed to monitor global network
+activity and make decisions based on network spread and infection rate -
+that is, abuse from an address which has been reported by a number of
+participating networks. This is in far contrast to how most other
+blacklists function, where fallable humans (many with political agendas) must
+process thousands of reports and make decisions - many times after the fact.
+The RABL is fully reactive to new threats and can block addresses within
+seconds of widespread infection - good to know in this world of drone PCs
+and stolen accounts. The RABL server blacklists addresses until they have
+cleared a minimum duration (an hour by default) without any additional
+reporting, making the appeals process as simple as "fix your junk". The RABL
+is designed to function via automated machine-learning spam filters, such as
+Bayesian filters. Each participating network is granted write authentication
+in the blackhole list, to prevent abuse. A client tool is also provided.
+
+The RABL client is the lookup and reporting component of the RABL. It is
+necessary for performing streaming connection lookups and writing to the RABL
+(assuming you have an account).
+
+WWW: http://www.nuclearelephant.com/projects/rabl/
diff --git a/mail/rabl_client/pkg-plist b/mail/rabl_client/pkg-plist
new file mode 100644
index 000000000000..3f3f00c97ca2
--- /dev/null
+++ b/mail/rabl_client/pkg-plist
@@ -0,0 +1,3 @@
+bin/rabl_client
+@unexec if cmp -s %D/etc/rabl_client.conf %D/etc/rabl_client.conf.sample; then rm -f %D/etc/rabl_client.conf; fi
+etc/rabl_client.conf.sample