aboutsummaryrefslogtreecommitdiff
path: root/mail/raysfilter
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2004-10-27 13:41:47 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2004-10-27 13:41:47 +0000
commit71fec364fb21c765593a7db7885e72cc2c6c6e43 (patch)
tree1870dd0d5f7ff52b2e75d59507e575d67fd80787 /mail/raysfilter
parentde95ea51df78a3327c8818732612d7dd54ae241f (diff)
downloadports-71fec364fb21c765593a7db7885e72cc2c6c6e43.tar.gz
ports-71fec364fb21c765593a7db7885e72cc2c6c6e43.zip
- update for sendmail-8.13.x
Notes
Notes: svn path=/head/; revision=120311
Diffstat (limited to 'mail/raysfilter')
-rw-r--r--mail/raysfilter/Makefile2
-rw-r--r--mail/raysfilter/files/patch-rays-filter.c17
2 files changed, 15 insertions, 4 deletions
diff --git a/mail/raysfilter/Makefile b/mail/raysfilter/Makefile
index c0822014d754..d40ece89ab14 100644
--- a/mail/raysfilter/Makefile
+++ b/mail/raysfilter/Makefile
@@ -18,7 +18,7 @@ COMMENT= A configurable filter for Sendmail
BUILD_DEPENDS= ${LOCALBASE}/lib/libmilter.a:${PORTSDIR}/mail/${SENDMAIL_PORT}
.endif
-SENDMAIL_PORT?= sendmail812
+SENDMAIL_PORT?= sendmail
CTARGETS+= rays-filter
CFLAGS+= -Wall ${PTHREAD_CFLAGS:S=""==}
LIBS+= ${PTHREAD_LIBS}
diff --git a/mail/raysfilter/files/patch-rays-filter.c b/mail/raysfilter/files/patch-rays-filter.c
index 18701f074f1e..5cb780c442c3 100644
--- a/mail/raysfilter/files/patch-rays-filter.c
+++ b/mail/raysfilter/files/patch-rays-filter.c
@@ -1,5 +1,5 @@
--- rays-filter.c.orig Thu Mar 8 13:41:20 2001
-+++ rays-filter.c Sat Jan 19 15:49:11 2002
++++ rays-filter.c Wed Oct 27 15:38:15 2004
@@ -65,8 +65,8 @@
#include <sys/types.h>
#include <unistd.h>
@@ -10,7 +10,18 @@
#include "rays-filter.h"
-@@ -326,6 +326,7 @@
+@@ -219,8 +219,10 @@
+ #ifndef TRUE
+ #define FALSE 0
+ #define TRUE 1
++#ifndef __bool_true_false_are_defined
+ typedef int bool;
+ #endif
++#endif
+
+ /* Data Structures
+ **
+@@ -326,6 +328,7 @@
syslog(LOG_INFO, "Cannot allocate memory for log file name\n");
else
{
@@ -18,7 +29,7 @@
if (mktemp(priv->mlfi_fname) == NULL)
syslog(LOG_INFO, "Cannot make name for log file\n");
else
-@@ -334,6 +335,11 @@
+@@ -334,6 +337,11 @@
if (priv->mlfi_fname == NULL)
syslog(LOG_INFO, "Cannot open log file\n");
}