aboutsummaryrefslogtreecommitdiff
path: root/mail/rbl-milter
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2003-04-07 19:09:33 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2003-04-07 19:09:33 +0000
commit47051d970cbe0c9754529e38182efb3fd85fbaad (patch)
treee241b568c798730f9c0765dd5947987ee92f6f6b /mail/rbl-milter
parent379f7c98923a976bd55e31e503732aa76f363871 (diff)
downloadports-47051d970cbe0c9754529e38182efb3fd85fbaad.tar.gz
ports-47051d970cbe0c9754529e38182efb3fd85fbaad.zip
Notes
Diffstat (limited to 'mail/rbl-milter')
-rw-r--r--mail/rbl-milter/Makefile35
-rw-r--r--mail/rbl-milter/distinfo1
-rw-r--r--mail/rbl-milter/files/patch-aa19
-rw-r--r--mail/rbl-milter/files/rbl-milter.sh.in28
-rw-r--r--mail/rbl-milter/pkg-descr14
-rw-r--r--mail/rbl-milter/pkg-message25
-rw-r--r--mail/rbl-milter/pkg-plist2
7 files changed, 124 insertions, 0 deletions
diff --git a/mail/rbl-milter/Makefile b/mail/rbl-milter/Makefile
new file mode 100644
index 000000000000..f59fd883fbad
--- /dev/null
+++ b/mail/rbl-milter/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: rbl-milter
+# Date created: 15 November 2002
+# Whom: wolpert
+#
+# $FreeBSD$
+#
+
+PORTNAME= rbl-milter
+PORTVERSION= 0.30
+CATEGORIES= mail
+MASTER_SITES= http://opensource.confusticate.com/rbl-milter/
+
+MAINTAINER= wolpert@codeheadsystems.com
+COMMENT= A milter that adds mail header warnings on mail from open-relays
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+CONFIGURE_ARGS= --with-sendmail=/usr \
+ --with-sendmail-obj=/usr/lib
+
+.if defined(NO_WERROR)
+pre-configure:
+ @${CP} ${WRKSRC}/configure ${WRKSRC}/configure.sed
+ @${SED} 's!-Werror!!' ${WRKSRC}/configure.sed >${WRKSRC}/configure
+.endif
+
+post-install:
+ @${SED} 's|%%PREFIX%%|${PREFIX}|g' \
+ ${FILESDIR}/rbl-milter.sh.in > ${WRKDIR}/rbl-milter.sh
+ ${INSTALL_SCRIPT} ${WRKDIR}/rbl-milter.sh \
+ ${PREFIX}/etc/rc.d/rbl-milter.sh
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/mail/rbl-milter/distinfo b/mail/rbl-milter/distinfo
new file mode 100644
index 000000000000..cfa0d0d4701d
--- /dev/null
+++ b/mail/rbl-milter/distinfo
@@ -0,0 +1 @@
+MD5 (rbl-milter-0.30.tar.gz) = 349a080780bbe2a79ee39b2e417c0d10
diff --git a/mail/rbl-milter/files/patch-aa b/mail/rbl-milter/files/patch-aa
new file mode 100644
index 000000000000..c2d886cf2a8d
--- /dev/null
+++ b/mail/rbl-milter/files/patch-aa
@@ -0,0 +1,19 @@
+*** configure.old Fri Nov 22 06:30:28 2002
+--- configure Fri Nov 22 06:30:25 2002
+***************
+*** 1230,1236 ****
+
+ LDFLAGS="$LDFLAGS -L$SENDMAIL_OBJ/libmilter -L$SENDMAIL_OBJ/libsm -L$SENDMAIL_OBJ/libsmutil -L$SENDMAIL_OBJ/lib";
+ CFLAGS="$CFLAGS -Wall -Werror"
+! LIBS="$LIBS -pthread -lpthread"
+
+
+ echo $ac_n "checking for socket in -lsocket""... $ac_c" 1>&6
+--- 1230,1236 ----
+
+ LDFLAGS="$LDFLAGS -L$SENDMAIL_OBJ/libmilter -L$SENDMAIL_OBJ/libsm -L$SENDMAIL_OBJ/libsmutil -L$SENDMAIL_OBJ/lib";
+ CFLAGS="$CFLAGS -Wall -Werror"
+! LIBS="$LIBS -pthread -lc_r"
+
+
+ echo $ac_n "checking for socket in -lsocket""... $ac_c" 1>&6
diff --git a/mail/rbl-milter/files/rbl-milter.sh.in b/mail/rbl-milter/files/rbl-milter.sh.in
new file mode 100644
index 000000000000..2f540d3c7f5c
--- /dev/null
+++ b/mail/rbl-milter/files/rbl-milter.sh.in
@@ -0,0 +1,28 @@
+#!/bin/sh
+
+if [ ! -f %%PREFIX%%/sbin/rbl-milter ]
+then
+ echo "rbl-milter not installed"
+ exit 0;
+fi
+
+case $1 in
+start)
+ %%PREFIX%%/sbin/rbl-milter -l -r -p local:/var/run/rbl-milter -d relays.ordb.org \
+ && echo -n " rbl-milter" \
+ || echo " rbl-milter FAILED TO START"
+ ;;
+stop)
+ killall rbl-milter && echo -n " rbl-milter"
+ ;;
+restart)
+ $0 stop
+ $0 start
+ ;;
+*)
+ echo "Usage: `basename $0` {start|stop}" >&2
+ exit 64
+ ;;
+esac
+
+exit 0
diff --git a/mail/rbl-milter/pkg-descr b/mail/rbl-milter/pkg-descr
new file mode 100644
index 000000000000..be41413cc1c7
--- /dev/null
+++ b/mail/rbl-milter/pkg-descr
@@ -0,0 +1,14 @@
+This is a simple sendmail milter which adds an X-RBL-Warning header to
+any Xemails that are received that come from an open relay as
+determined by your Xchoice of RBL checking service (i.e.
+bl.spamcop.net).
+
+This is useful if you'd rather have the mail user agent (MUA) deal with
+ Xpotential spam rather than just blocking it in case you loose
+legitimate Xmessages. Note that the X-RBL-Warning header is only set if
+the site was Xfound to be an open-relay.
+
+For more information, see the rbl-milter website at:
+ WWW: http://opensource.confusticate.com/rbl-milter/
+RBL-Milter was created by Jeremy Beker <gothmog@confusticate.com> and
+the Xport is maintained by Ned Wolpert <wolpert@codeheadsystems.com>
diff --git a/mail/rbl-milter/pkg-message b/mail/rbl-milter/pkg-message
new file mode 100644
index 000000000000..c2ee36d516d6
--- /dev/null
+++ b/mail/rbl-milter/pkg-message
@@ -0,0 +1,25 @@
+The start/stop script has been placed in $PREFIX/etc/rc.d/rbl-milter.sh
+ XRun the program now with the start command to get rbl-milter running.
+By Xdefault, it uses the relays found at relays.ordb.org but you can
+change that Xby modifying the script. It accepts multiple -d commands
+for multiple Xsite checks.
+
+Note that you will need to edit the proper sendmail.mc file in your
+/etc/mail Xdirectory so that sendmail will pass mail to rbl-milter. If
+you have not Xdone this before, do the following:
+
+ cd /etc/mail
+ cp -p freebsd.mc `hostname`.mc
+
+Add the INPUT_MAIL_FILTER line to the file:
+
+ INPUT_MAIL_FILTER(`rbl-milter',`S=local:/var/run/rbl-milter')
+
+and rebuild it
+
+ make
+ make install
+ make restart
+
+By default, the INPUT_MAIL_FILTER line will ignore the filter if
+rbl-milter Xis not running.
diff --git a/mail/rbl-milter/pkg-plist b/mail/rbl-milter/pkg-plist
new file mode 100644
index 000000000000..89d41446f33a
--- /dev/null
+++ b/mail/rbl-milter/pkg-plist
@@ -0,0 +1,2 @@
+sbin/rbl-milter
+etc/rc.d/rbl-milter.sh