aboutsummaryrefslogtreecommitdiff
path: root/mail/rblcheck
diff options
context:
space:
mode:
authorJun-ichiro itojun Hagino <itojun@FreeBSD.org>1998-11-16 16:33:37 +0000
committerJun-ichiro itojun Hagino <itojun@FreeBSD.org>1998-11-16 16:33:37 +0000
commit88edd839df3cab1445f550d7b409425183c772d5 (patch)
tree8937d3779da851cb9a052006974221a20cb02291 /mail/rblcheck
parent043c5e776998758346a994837ea764514888d659 (diff)
downloadports-88edd839df3cab1445f550d7b409425183c772d5.tar.gz
ports-88edd839df3cab1445f550d7b409425183c772d5.zip
declare "extern char *optarg".
(I can't blindly include getopt.h since older FreeBSD doesn't have one) remove BROKEN mark (could someone check this?).
Notes
Notes: svn path=/head/; revision=14570
Diffstat (limited to 'mail/rblcheck')
-rw-r--r--mail/rblcheck/Makefile4
-rw-r--r--mail/rblcheck/files/patch-aa9
2 files changed, 6 insertions, 7 deletions
diff --git a/mail/rblcheck/Makefile b/mail/rblcheck/Makefile
index b8cd9a245d52..999f64334d22 100644
--- a/mail/rblcheck/Makefile
+++ b/mail/rblcheck/Makefile
@@ -3,7 +3,7 @@
# Date created: 28 January 1998
# Whom: itojun@itojun.org
#
-# $Id: Makefile,v 1.3 1998/10/19 16:51:12 itojun Exp $
+# $Id: Makefile,v 1.4 1998/11/16 13:15:26 jseger Exp $
#
DISTNAME= rblcheck-1.4
@@ -12,8 +12,6 @@ MASTER_SITES= http://www.xnet.com/%7Eemarshal/rblcheck/
MAINTAINER= itojun@itojun.org
-BROKEN= yes
-
DOCS= BUGS CHANGES CREDITS INSTALL PLATFORMS TODO
do-install:
diff --git a/mail/rblcheck/files/patch-aa b/mail/rblcheck/files/patch-aa
index 41ee5ff34a04..387bd858cdff 100644
--- a/mail/rblcheck/files/patch-aa
+++ b/mail/rblcheck/files/patch-aa
@@ -1,5 +1,5 @@
--- rblcheck.c.orig Thu Aug 20 14:47:03 1998
-+++ rblcheck.c Sun Oct 18 00:42:57 1998
++++ rblcheck.c Tue Nov 17 01:30:36 1998
@@ -79,6 +79,7 @@
#include <sys/types.h>
#include <netinet/in.h>
@@ -71,11 +71,12 @@
{
if( *cp == '\n' || *cp == '"' ||
*cp == '\\' )
-@@ -308,23 +312,26 @@
+@@ -308,23 +312,27 @@
char **argv;
{
extern int optind;
- int a, b, c, d;
++ extern char *optarg;
+ struct hostent *ent;
+ struct in_addr a;
int quiet = 0;
@@ -102,7 +103,7 @@
{
case 'q':
/* Quiet */
-@@ -372,10 +379,20 @@
+@@ -372,10 +380,20 @@
return -1;
}
@@ -127,7 +128,7 @@
fprintf( stderr, "%s: invalid IP address\n", progname );
usage();
return -1;
-@@ -383,7 +400,7 @@
+@@ -383,7 +401,7 @@
for( ptr = rblsites; ptr != NULL; ptr = ptr->next )
{