aboutsummaryrefslogtreecommitdiff
path: root/mail/ricochet
diff options
context:
space:
mode:
authorAndrey A. Chernov <ache@FreeBSD.org>2003-09-24 12:35:44 +0000
committerAndrey A. Chernov <ache@FreeBSD.org>2003-09-24 12:35:44 +0000
commite77b729da43575c869e3db4a33439420a376ca90 (patch)
tree17a6dcc5ef656f69bfc73963dd280b499450b771 /mail/ricochet
parent575744ef5b1e03db3a5973662dd6e43133e4e643 (diff)
downloadports-e77b729da43575c869e3db4a33439420a376ca90.tar.gz
ports-e77b729da43575c869e3db4a33439420a376ca90.zip
Notes
Diffstat (limited to 'mail/ricochet')
-rw-r--r--mail/ricochet/Makefile1
-rw-r--r--mail/ricochet/files/patch-ricochet25
2 files changed, 23 insertions, 3 deletions
diff --git a/mail/ricochet/Makefile b/mail/ricochet/Makefile
index e662f482e512..e77830f4aede 100644
--- a/mail/ricochet/Makefile
+++ b/mail/ricochet/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ricochet
PORTVERSION= 0.98
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= http://vipul.net/perl/sources/spamcontrol/ricochet/
diff --git a/mail/ricochet/files/patch-ricochet b/mail/ricochet/files/patch-ricochet
index 3ae0516ebacd..917a4043ae4b 100644
--- a/mail/ricochet/files/patch-ricochet
+++ b/mail/ricochet/files/patch-ricochet
@@ -1,6 +1,25 @@
---- ricochet.orig Thu Feb 8 22:23:19 2001
-+++ ricochet Tue Jun 24 18:14:09 2003
-@@ -574,7 +607,8 @@
+--- ricochet.old Tue Jun 24 22:40:18 2003
++++ ricochet Wed Sep 24 16:33:42 2003
+@@ -566,15 +566,14 @@
+ my ( $domain ) = @_;
+ $ua = new LWP::UserAgent;
+ $ua->agent("Ricochet/0.1 " . $ua->agent);
+- my $req = new HTTP::Request POST => 'http://www.abuse.net/lookup.phtml';
+- $req->content_type('application/x-www-form-urlencoded');
+- $req->content("DOMAIN=$domain");
++ my $req = new HTTP::Request GET => "http://www.abuse.net/lookup.phtml?DOMAIN=$domain";
++ $ua->timeout(20);
+ my $res = $ua->request($req);
+
+ if ($res->is_success) {
+ my $content = $res->content;
+ return undef if $content =~ /no information for this domain/;
+- my @matches = $content =~ /(\S+\@\S+)\s*<BR>/ig;
++ my @matches = $content =~ /<tt>(\S+\@\S+)<\/tt>/g;
+ return \@matches;
+ } else {
+ return undef;
+@@ -607,7 +606,8 @@
sub initialize {
my $self = shift;