aboutsummaryrefslogtreecommitdiff
path: root/mail/roundcube-automatic_addressbook
diff options
context:
space:
mode:
authorJase Thew <jase@FreeBSD.org>2012-09-01 12:17:56 +0000
committerJase Thew <jase@FreeBSD.org>2012-09-01 12:17:56 +0000
commitc2ff523da622b37856bdd24ff2e1fde5344fe2df (patch)
tree3c02bebc5b2457a4bede64dd9533bbc44f891917 /mail/roundcube-automatic_addressbook
parent6bc87f411adecaabd0c9888884c88104b9f7fb2a (diff)
downloadports-c2ff523da622b37856bdd24ff2e1fde5344fe2df.tar.gz
ports-c2ff523da622b37856bdd24ff2e1fde5344fe2df.zip
Notes
Diffstat (limited to 'mail/roundcube-automatic_addressbook')
-rw-r--r--mail/roundcube-automatic_addressbook/Makefile39
-rw-r--r--mail/roundcube-automatic_addressbook/distinfo2
-rw-r--r--mail/roundcube-automatic_addressbook/files/pkg-message.in28
-rw-r--r--mail/roundcube-automatic_addressbook/pkg-descr5
-rw-r--r--mail/roundcube-automatic_addressbook/pkg-plist34
5 files changed, 108 insertions, 0 deletions
diff --git a/mail/roundcube-automatic_addressbook/Makefile b/mail/roundcube-automatic_addressbook/Makefile
new file mode 100644
index 000000000000..96015a6bdf12
--- /dev/null
+++ b/mail/roundcube-automatic_addressbook/Makefile
@@ -0,0 +1,39 @@
+# $FreeBSD$
+
+PORTNAME= automatic_addressbook
+PORTVERSION= 0.3.1
+CATEGORIES= mail
+MASTER_SITES= http://code.crapouillou.net/attachments/download/16/
+PKGNAMEPREFIX= roundcube-
+
+MAINTAINER= anes@anes.su
+COMMENT= Roundcube webmail automatic addressbook plugin
+
+LICENSE= GPLv3
+
+RUN_DEPENDS= roundcube>=0.8:${PORTSDIR}/mail/roundcube
+
+USE_BZIP2= yes
+NO_BUILD= yes
+
+RCDIR= ${PREFIX}/www/roundcube
+WWWDIR= ${RCDIR}/plugins/automatic_addressbook
+
+SUB_FILES= pkg-message
+SUB_LIST= RCDIR=${RCDIR} PLUGINDIR=${WWWDIR}
+
+# This target is only meant to be used by the port maintainer.
+x-generate-plist: build
+ cd ${WRKSRC}; \
+ ${FIND} . ! -type d ! -name '*.orig' | ${SORT} | \
+ ${SED} -e "s,^\.,%%WWWDIR%%," >${.CURDIR}/pkg-plist.tmp ; \
+ ${FIND} . -type d | ${SORT} -r | ${SED} \
+ -e "s,^\.$$,@dirrmtry %%WWWDIR%%," \
+ -e "s,^\.,@dirrm %%WWWDIR%%," >>${.CURDIR}/pkg-plist.tmp
+
+do-install:
+ @${MKDIR} ${WWWDIR}
+ @cd ${WRKSRC} && ${PAX} -r -w . ${WWWDIR}
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/mail/roundcube-automatic_addressbook/distinfo b/mail/roundcube-automatic_addressbook/distinfo
new file mode 100644
index 000000000000..adc3059ac660
--- /dev/null
+++ b/mail/roundcube-automatic_addressbook/distinfo
@@ -0,0 +1,2 @@
+SHA256 (automatic_addressbook-0.3.1.tar.bz2) = 0a4f43de2a9938ddbabc31ef0f47eaf70073aaf3e3f415d76f2c7f67cb5604a2
+SIZE (automatic_addressbook-0.3.1.tar.bz2) = 20630
diff --git a/mail/roundcube-automatic_addressbook/files/pkg-message.in b/mail/roundcube-automatic_addressbook/files/pkg-message.in
new file mode 100644
index 000000000000..fc44f79efe19
--- /dev/null
+++ b/mail/roundcube-automatic_addressbook/files/pkg-message.in
@@ -0,0 +1,28 @@
+---------------------------------------------------------------------
+FIRST INSTALLATION
+
+If this is a first installation of automatic addressbook plugin, you
+have to execute the relevant initialisation SQL script for your
+chosen database backend :
+
+%%PLUGINDIR%%/SQL/<dbtype>.initial.sql
+
+You will also need to copy :
+%%PLUGINDIR%%/config/config.inc.php.dist to
+%%PLUGINDIR%%/config/config.inc.php
+and edit as you need.
+
+Finally, you will need to add the plugin to your list of loadable
+plugins in %%RCDIR%%/config/main.inc.php :
+
+E.g. : $rcmail_config['plugins'] = array('automatic_addressbook');
+
+UPGRADING
+
+If you already had a previous version of automatic addressbook plugin
+installed, you should update your database schema by executing the
+relevant upgrade SQL script for your chosen database backend :
+
+%%WWWDIR%%/SQL/<dbtype>.upgrade.sql
+
+---------------------------------------------------------------------
diff --git a/mail/roundcube-automatic_addressbook/pkg-descr b/mail/roundcube-automatic_addressbook/pkg-descr
new file mode 100644
index 000000000000..dd4f83734954
--- /dev/null
+++ b/mail/roundcube-automatic_addressbook/pkg-descr
@@ -0,0 +1,5 @@
+The automatic addressbook plugin for Roundcube collects each address you
+send an email to and records it in an address book, making it available
+for later use or auto-completion.
+
+WWW: http://code.crapouillou.net/projects/roundcube-plugins
diff --git a/mail/roundcube-automatic_addressbook/pkg-plist b/mail/roundcube-automatic_addressbook/pkg-plist
new file mode 100644
index 000000000000..46af59dc4f60
--- /dev/null
+++ b/mail/roundcube-automatic_addressbook/pkg-plist
@@ -0,0 +1,34 @@
+%%WWWDIR%%/package.xml
+%%WWWDIR%%/Changelog
+%%WWWDIR%%/INSTALL
+%%WWWDIR%%/LICENSE
+%%WWWDIR%%/README
+%%WWWDIR%%/SQL/mssql.initial.sql
+%%WWWDIR%%/SQL/mssql.update.sql
+%%WWWDIR%%/SQL/mysql.initial.sql
+%%WWWDIR%%/SQL/mysql.update.sql
+%%WWWDIR%%/SQL/postgres.initial.sql
+%%WWWDIR%%/SQL/postgres.update.sql
+%%WWWDIR%%/SQL/sqlite.initial.sql
+%%WWWDIR%%/SQL/sqlite.update.sql
+%%WWWDIR%%/automatic_addressbook.php
+%%WWWDIR%%/automatic_addressbook_backend.php
+%%WWWDIR%%/config/config.inc.php.dist
+%%WWWDIR%%/localization/bg_BG.inc
+%%WWWDIR%%/localization/de_DE.inc
+%%WWWDIR%%/localization/el_GR.inc
+%%WWWDIR%%/localization/en_EN.inc
+%%WWWDIR%%/localization/en_US.inc
+%%WWWDIR%%/localization/es_ES.inc
+%%WWWDIR%%/localization/fr_FR.inc
+%%WWWDIR%%/localization/gl_ES.inc
+%%WWWDIR%%/localization/hu_HU.inc
+%%WWWDIR%%/localization/it_IT.inc
+%%WWWDIR%%/localization/nl_NL.inc
+%%WWWDIR%%/localization/ru_RU.inc
+%%WWWDIR%%/localization/vi_VN.inc
+%%WWWDIR%%/localization/zh_CN.inc
+@dirrm %%WWWDIR%%/localization
+@dirrm %%WWWDIR%%/SQL
+@dirrmtry %%WWWDIR%%/config
+@dirrmtry %%WWWDIR%%