aboutsummaryrefslogtreecommitdiff
path: root/mail/roundcube/Makefile
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2006-02-06 12:57:43 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2006-02-06 12:57:43 +0000
commitfde0db6f3201933ae0712f66ccbfdb69ac4b60e9 (patch)
treedd85b348ad1b724661fdf728c5efc4a99d54a0a3 /mail/roundcube/Makefile
parentaaa93249af9fe319214f6f081b4e25145bbcec1d (diff)
downloadports-fde0db6f3201933ae0712f66ccbfdb69ac4b60e9.tar.gz
ports-fde0db6f3201933ae0712f66ccbfdb69ac4b60e9.zip
Notes
Diffstat (limited to 'mail/roundcube/Makefile')
-rw-r--r--mail/roundcube/Makefile18
1 files changed, 14 insertions, 4 deletions
diff --git a/mail/roundcube/Makefile b/mail/roundcube/Makefile
index f9ad81182392..be231dd664fe 100644
--- a/mail/roundcube/Makefile
+++ b/mail/roundcube/Makefile
@@ -6,17 +6,16 @@
#
PORTNAME= roundcube
-PORTVERSION= 0.1
-PORTREVISION= ${SNAPSHOT}
+PORTVERSION= 0.1.${SNAPSHOT}
CATEGORIES= mail
MASTER_SITES= http://www.unixified.net/roundcube/
MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTNAME= ${PORTNAME}-${PORTVERSION}-${SNAPSHOT}
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/.${SNAPSHOT}//}-${SNAPSHOT}
MAINTAINER= flz@FreeBSD.org
COMMENT= Fully skinnable XHTML/CSS webmail written in PHP
-SNAPSHOT= 20051219
+SNAPSHOT= 20060205
WRKSRC= ${WRKDIR}/${PORTNAME}mail
NO_BUILD= yes
@@ -35,6 +34,17 @@ SCRIPTS_ENV= SHAREOWN=${SHAREOWN} SHAREGRP=${SHAREGRP} \
RCUBEROOT=${RCUBEROOT}
WANT_PHP_WEB= yes
+USE_PHP= pcre
+
+SUB_FILES= pkg-install
+SUB_LIST= RCUBEROOT=${RCUBEROOT}
+PKGDEINSTALL= ${PKGINSTALL}
+
+LOCALBASE?= /usr/local
+
+.if exists(${LOCALBASE}/etc/php.conf)
+.include "${LOCALBASE}/etc/php.conf"
+.endif
OPTIONS= MYSQL "Use MySQL backend" on \
PGSQL "Use PostgreSQL backend" off