aboutsummaryrefslogtreecommitdiff
path: root/mail/roundcube/Makefile
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2013-05-07 13:51:52 +0000
committerAlex Dupre <ale@FreeBSD.org>2013-05-07 13:51:52 +0000
commit4aa109a0dc1ba0fa59f2b015878b24dc02b54b42 (patch)
tree58855a05bcc5b2d91f5f28f23e197404fd7725ed /mail/roundcube/Makefile
parent9d1a0529337fbc8b2236839451a78defdc387337 (diff)
downloadports-4aa109a0dc1ba0fa59f2b015878b24dc02b54b42.tar.gz
ports-4aa109a0dc1ba0fa59f2b015878b24dc02b54b42.zip
Notes
Diffstat (limited to 'mail/roundcube/Makefile')
-rw-r--r--mail/roundcube/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/mail/roundcube/Makefile b/mail/roundcube/Makefile
index 111e5e12cd1e..e46cb3f544c2 100644
--- a/mail/roundcube/Makefile
+++ b/mail/roundcube/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= roundcube
-DISTVERSION= 0.8.6
+DISTVERSION= 0.9.0
PORTEPOCH= 1
CATEGORIES?= mail www
MASTER_SITES= SF/${PORTNAME}mail/${PORTNAME}mail/${DISTVERSION:U}
@@ -23,8 +23,8 @@ SCRIPTS_ENV= SHAREOWN=${SHAREOWN} SHAREGRP=${SHAREGRP} \
WWWDIR=${WWWDIR}
WANT_PHP_WEB= yes
-USE_PHP= pcre mbstring session iconv dom xml json intl
-IGNORE_WITH_PHP=4
+USE_PHP= pcre mbstring session iconv dom xml json intl zip
+IGNORE_WITH_PHP=52
OPTIONS_DEFINE= SSL LDAP GD PSPELL NSC
OPTIONS_SINGLE= DB
@@ -33,7 +33,7 @@ OPTIONS_DEFAULT=MYSQL
MYSQL_DESC= Use MySQL backend
PGSQL_DESC= Use PostgreSQL backend
-SQLITE_DESC= Use SQLite backend (needs PHP 5.3 or below)
+SQLITE_DESC= Use SQLite backend
SSL_DESC= Enable SSL support (imaps or google spellcheck)
LDAP_DESC= Enable LDAP support (address book)
GD_DESC= Enable GD support (image conversion)
@@ -43,15 +43,15 @@ NSC_DESC= Install network spellchecker
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MMYSQL}
-USE_PHP+= mysql
+USE_PHP+= pdo_mysql
.endif
.if ${PORT_OPTIONS:MPGSQL}
-USE_PHP+= pgsql
+USE_PHP+= pdo_pgsql
.endif
.if ${PORT_OPTIONS:MSQLITE}
-USE_PHP+= sqlite
+USE_PHP+= pdo_sqlite
.endif
.if ${PORT_OPTIONS:MSSL}