aboutsummaryrefslogtreecommitdiff
path: root/mail/roundcube
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2006-02-09 11:29:11 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2006-02-09 11:29:11 +0000
commit8907038a1acf42805a8deaf5d4376ef59588b1e7 (patch)
treeec4ecca0d6577e5224ac5daa8d839b126140cd1b /mail/roundcube
parentfed5ed01f94a69225b62b32d904259535f6f700f (diff)
downloadports-8907038a1acf42805a8deaf5d4376ef59588b1e7.tar.gz
ports-8907038a1acf42805a8deaf5d4376ef59588b1e7.zip
Notes
Diffstat (limited to 'mail/roundcube')
-rw-r--r--mail/roundcube/Makefile2
-rw-r--r--mail/roundcube/files/pkg-install.in (renamed from mail/roundcube/pkg-install)7
2 files changed, 8 insertions, 1 deletions
diff --git a/mail/roundcube/Makefile b/mail/roundcube/Makefile
index be231dd664fe..f630557b2958 100644
--- a/mail/roundcube/Makefile
+++ b/mail/roundcube/Makefile
@@ -50,7 +50,7 @@ OPTIONS= MYSQL "Use MySQL backend" on \
PGSQL "Use PostgreSQL backend" off
.if defined(PHP_VER) && ${PHP_VER} == 5
-OPTIONS+= SQLITE "Use SQLite backend" off
+OPTIONS+= SQLITE "Use SQLite backend" off
.endif
.include <bsd.port.pre.mk>
diff --git a/mail/roundcube/pkg-install b/mail/roundcube/files/pkg-install.in
index ca19fb80a3aa..a750c4ec6b02 100644
--- a/mail/roundcube/pkg-install
+++ b/mail/roundcube/files/pkg-install.in
@@ -1,5 +1,7 @@
#! /bin/sh
+RCUBEROOT=%%RCUBEROOT%%
+
case $2 in
POST-INSTALL)
@@ -10,6 +12,11 @@ POST-INSTALL)
[ -f ${i} ] || cp ${i}.dist ${i}
done
;;
+DEINSTALL)
+ for i in ${RCUBEROOT}/config/db.inc.php ${RCUBEROOT}/config/main.inc.php; do
+ if cmp -s ${i} ${i}.dist; then rm ${i}; fi
+ done
+ ;;
*)
exit 1
;;