aboutsummaryrefslogtreecommitdiff
path: root/mail/roundcube
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2009-11-04 08:56:25 +0000
committerAlex Dupre <ale@FreeBSD.org>2009-11-04 08:56:25 +0000
commit68cbca9a9a4cc9c73fd4e689f620594e41b67f77 (patch)
treec84dd7e7714f454d7836746ccf62ffa8d2efcd91 /mail/roundcube
parent8913f8eb07856d51bf2ef74a5d78a474a13f5b22 (diff)
downloadports-68cbca9a9a4cc9c73fd4e689f620594e41b67f77.tar.gz
ports-68cbca9a9a4cc9c73fd4e689f620594e41b67f77.zip
Notes
Diffstat (limited to 'mail/roundcube')
-rw-r--r--mail/roundcube/Makefile12
-rw-r--r--mail/roundcube/distinfo6
-rw-r--r--mail/roundcube/files/patch-plugins_password_drivers_sql.php11
3 files changed, 11 insertions, 18 deletions
diff --git a/mail/roundcube/Makefile b/mail/roundcube/Makefile
index acdc171845c9..ba215f250b00 100644
--- a/mail/roundcube/Makefile
+++ b/mail/roundcube/Makefile
@@ -6,12 +6,11 @@
#
PORTNAME= roundcube
-DISTVERSION= 0.3
-PORTREVISION= 1
+DISTVERSION= 0.3.1
PORTEPOCH= 1
CATEGORIES= mail www
-MASTER_SITES= SF/${PORTNAME}mail/${PORTNAME}mail/${PORTVERSION}-stable
-DISTNAME= ${PORTNAME}mail-${DISTVERSION}-stable
+MASTER_SITES= SF/${PORTNAME}mail/${PORTNAME}mail/${PORTVERSION}
+DISTNAME= ${PORTNAME}mail-${DISTVERSION}
MAINTAINER= ale@FreeBSD.org
COMMENT= Fully skinnable XHTML/CSS webmail written in PHP
@@ -103,6 +102,7 @@ post-patch:
@${REINPLACE_CMD} "s/'mail'/'${MAIL}'/g" ${WRKSRC}/index.php \
${WRKSRC}/plugins/*/*.php \
${WRKSRC}/program/include/rcmail.php \
+ ${WRKSRC}/program/js/editor.js \
${WRKSRC}/program/localization/*/labels.inc \
${WRKSRC}/program/steps/addressbook/mailto.inc
@${REINPLACE_CMD} "s/_task=mail/_task=${MAIL}/g" \
@@ -111,10 +111,14 @@ post-patch:
${WRKSRC}/program/js/app.js \
${WRKSRC}/skins/default/includes/header.html \
${WRKSRC}/skins/default/includes/taskbar.html
+ @${REINPLACE_CMD} "s/mail_footer/${MAIL}_footer/g" \
+ ${WRKSRC}/skins/default/*.css
@${REINPLACE_CMD} "s/mail_toolbar/${MAIL}_toolbar/g" \
${WRKSRC}/skins/default/*.css
@${MV} ${WRKSRC}/program/steps/mail \
${WRKSRC}/program/steps/${MAIL}
+ @${MV} ${WRKSRC}/skins/default/images/mail_footer.png \
+ ${WRKSRC}/skins/default/images/${MAIL}_footer.png
@${MV} ${WRKSRC}/skins/default/images/mail_toolbar.gif \
${WRKSRC}/skins/default/images/${MAIL}_toolbar.gif
@${MV} ${WRKSRC}/skins/default/images/mail_toolbar.png \
diff --git a/mail/roundcube/distinfo b/mail/roundcube/distinfo
index b22e2aa74ccf..b56f7616c431 100644
--- a/mail/roundcube/distinfo
+++ b/mail/roundcube/distinfo
@@ -1,3 +1,3 @@
-MD5 (roundcubemail-0.3-stable.tar.gz) = 741bb3dace2e2824c0cbb3e86142be5b
-SHA256 (roundcubemail-0.3-stable.tar.gz) = 11b1618692000b82c4fde26527b2cf5c18850eb6f48c6c0004758c39308dfd04
-SIZE (roundcubemail-0.3-stable.tar.gz) = 1888994
+MD5 (roundcubemail-0.3.1.tar.gz) = 34e8e18772e7eada8769b6c5c20f7c8e
+SHA256 (roundcubemail-0.3.1.tar.gz) = 78b7160e58fc3692591e8a909464a858500768e5e7a7c076b496a7caf119ddd1
+SIZE (roundcubemail-0.3.1.tar.gz) = 1917564
diff --git a/mail/roundcube/files/patch-plugins_password_drivers_sql.php b/mail/roundcube/files/patch-plugins_password_drivers_sql.php
deleted file mode 100644
index 6083e174c449..000000000000
--- a/mail/roundcube/files/patch-plugins_password_drivers_sql.php
+++ /dev/null
@@ -1,11 +0,0 @@
---- plugins/password/drivers/sql.php.orig 2009-09-10 10:17:30.000000000 +0200
-+++ plugins/password/drivers/sql.php 2009-09-10 10:18:05.000000000 +0200
-@@ -81,7 +81,7 @@
- $user_info = explode('@', $_SESSION['username']);
- if (count($user_info) >= 2) {
- $sql = str_replace('%l', $db->quote($user_info[0], 'text'), $sql);
-- $sql = str_replace('%d', $db->quote($user_info[0], 'text'), $sql);
-+ $sql = str_replace('%d', $db->quote($user_info[1], 'text'), $sql);
- }
-
- $sql = str_replace('%u', $db->quote($_SESSION['username'],'text'), $sql);