aboutsummaryrefslogtreecommitdiff
path: root/mail/rubygem-pony
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-08-30 21:49:13 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-08-30 21:49:13 +0000
commitb19aebac9bafbd4d02fcdad83dd5c256143e6731 (patch)
treeaf8a2b8d02ab8d5e458d8f9e0b4e9d1e6e0e555a /mail/rubygem-pony
parent63e560a5d7b6f2ec431ade7a3c54052b40b42f57 (diff)
downloadports-b19aebac9bafbd4d02fcdad83dd5c256143e6731.tar.gz
ports-b19aebac9bafbd4d02fcdad83dd5c256143e6731.zip
Notes
Diffstat (limited to 'mail/rubygem-pony')
-rw-r--r--mail/rubygem-pony/Makefile22
-rw-r--r--mail/rubygem-pony/distinfo3
-rw-r--r--mail/rubygem-pony/pkg-descr12
3 files changed, 37 insertions, 0 deletions
diff --git a/mail/rubygem-pony/Makefile b/mail/rubygem-pony/Makefile
new file mode 100644
index 000000000000..8ba7ed76e177
--- /dev/null
+++ b/mail/rubygem-pony/Makefile
@@ -0,0 +1,22 @@
+# Ports collection makefile for: rubygem-pony
+# Date created: 30 Aug 2010
+# Whom: Eric Freeman <freebsdports@chillibear.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pony
+PORTVERSION= 1.0
+CATEGORIES= mail rubygems
+MASTER_SITES= RG
+
+MAINTAINER= freebsdports@chillibear.com
+COMMENT= The express way to send mail from Ruby
+
+RUN_DEPENDS= rubygem-mail>=2.0:${PORTSDIR}/mail/rubygem-mail
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/mail/rubygem-pony/distinfo b/mail/rubygem-pony/distinfo
new file mode 100644
index 000000000000..a353f01b9b2e
--- /dev/null
+++ b/mail/rubygem-pony/distinfo
@@ -0,0 +1,3 @@
+MD5 (rubygem/pony-1.0.gem) = aa8b08e5b2d14b1ca1427273043b5da7
+SHA256 (rubygem/pony-1.0.gem) = 98314dedc90e36a7e3a1a970294159fa43ba81609e80444f143206daa4e07904
+SIZE (rubygem/pony-1.0.gem) = 9216
diff --git a/mail/rubygem-pony/pkg-descr b/mail/rubygem-pony/pkg-descr
new file mode 100644
index 000000000000..e4a7a3f91e02
--- /dev/null
+++ b/mail/rubygem-pony/pkg-descr
@@ -0,0 +1,12 @@
+The express way to send mail from Ruby.
+
+Send email in one command:
+Pony.mail(:to => 'someone@example.com', :body => 'hello')
+
+Pony uses /usr/sbin/sendmail to send mail if it
+is available, otherwise it uses SMTP to localhost.
+
+Also, you may need rubygem-smtp_tls if you want to
+send via tls/ssl and are using ruby < 1.8.7
+
+WWW: http://github.com/benprew/pony