aboutsummaryrefslogtreecommitdiff
path: root/mail/sa-stats
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-04-02 16:53:24 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-04-02 16:53:24 +0000
commit2864d63f284f97796b05e6f4fb8fd261f7129c66 (patch)
tree40b86ca91eb3663b7931e39c9f78633d51fdf16f /mail/sa-stats
parent092bc8dba7d3e498caac3cdd5181c370e77f78e2 (diff)
Notes
Diffstat (limited to 'mail/sa-stats')
-rw-r--r--mail/sa-stats/Makefile35
-rw-r--r--mail/sa-stats/distinfo3
-rw-r--r--mail/sa-stats/pkg-descr22
3 files changed, 60 insertions, 0 deletions
diff --git a/mail/sa-stats/Makefile b/mail/sa-stats/Makefile
new file mode 100644
index 000000000000..b92d9e3d16d0
--- /dev/null
+++ b/mail/sa-stats/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: sa-stats
+# Date created: Tue 16 Mar 2010
+# Whom: Alexey V. Degtyarev <alexey@renatasystems.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sa-stats
+PORTVERSION= 1.0
+CATEGORIES= mail
+MASTER_SITES= http://www.rulesemporium.com/programs/ \
+ ftp://renatasystems.org/pub/FreeBSD/ports/distfiles/
+DISTNAME= ${PORTNAME}-${PORTVERSION}.txt
+EXTRACT_SUFX=
+EXTRACT_ONLY=
+
+MAINTAINER= alexey@renatasystems.org
+COMMENT= Generates top spam/ham rules fired for SpamAssassin installations
+
+RUN_DEPENDS= p5-Getopt-Long>=0:${PORTSDIR}/devel/p5-Getopt-Long
+
+USE_PERL5= yes
+
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+PLIST_FILES= bin/sa-stats
+
+post-extract:
+ ${CP} ${DISTDIR}/${DISTNAME} ${WRKSRC}
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${DISTNAME} ${PREFIX}/bin/sa-stats
+
+.include <bsd.port.mk>
diff --git a/mail/sa-stats/distinfo b/mail/sa-stats/distinfo
new file mode 100644
index 000000000000..5b4966674e81
--- /dev/null
+++ b/mail/sa-stats/distinfo
@@ -0,0 +1,3 @@
+MD5 (sa-stats-1.0.txt) = 681d592694740331254a7b41b7f04aaf
+SHA256 (sa-stats-1.0.txt) = dc66ada115a61f4dfe727305a02c518a419c6cad51278e506153a6798094d42e
+SIZE (sa-stats-1.0.txt) = 8411
diff --git a/mail/sa-stats/pkg-descr b/mail/sa-stats/pkg-descr
new file mode 100644
index 000000000000..3eea8265faf9
--- /dev/null
+++ b/mail/sa-stats/pkg-descr
@@ -0,0 +1,22 @@
+This perl script generates top spam/ham rules fired for SpamAssassin
+installations:
+
+TOP SPAM RULES FIRED
+----------------------------------------------------------------------
+RANK RULE NAME COUNT %OFMAIL %OFSPAM %OFHAM
+----------------------------------------------------------------------
+ 1 CMAE_1 30455 26.68 70.34 0.03
+ 2 BAYES_99 24478 21.98 56.54 0.89
+ 3 RAZOR2_CHECK 11910 10.61 27.52 0.29
+----------------------------------------------------------------------
+
+TOP HAM RULES FIRED
+----------------------------------------------------------------------
+RANK RULE NAME COUNT %OFMAIL %OFSPAM %OFHAM
+----------------------------------------------------------------------
+ 1 BAYES_00 44253 46.60 20.71 62.40
+ 2 ALL_TRUSTED 34534 49.42 50.61 48.70
+ 3 SPF_PASS 10880 17.43 20.82 15.35
+----------------------------------------------------------------------
+
+WWW: http://www.rulesemporium.com/programs/