aboutsummaryrefslogtreecommitdiff
path: root/mail/scmail/Makefile
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2004-02-07 06:13:24 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2004-02-07 06:13:24 +0000
commite871092015cdd6f4afa20e6671bad7650117f626 (patch)
tree2c0614ccd22ad60913608c554c666225ffbbad7a /mail/scmail/Makefile
parent79644f5967e6df33589925fd9c37027beff6f5d7 (diff)
Notes
Diffstat (limited to 'mail/scmail/Makefile')
-rw-r--r--mail/scmail/Makefile25
1 files changed, 18 insertions, 7 deletions
diff --git a/mail/scmail/Makefile b/mail/scmail/Makefile
index 64fb1ae248ac..ec33a1b58f23 100644
--- a/mail/scmail/Makefile
+++ b/mail/scmail/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= scmail
-PORTVERSION= 0.2
+PORTVERSION= 1.0
CATEGORIES= mail
MASTER_SITES= http://www.namazu.org/~satoru/scmail/
@@ -14,16 +14,27 @@ MAINTAINER= fuyuki@nigredo.org
COMMENT= A mail filter written in Scheme
BUILD_DEPENDS= gosh:${PORTSDIR}/lang/gauche
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS= ${LOCALBASE}/share/gauche/${GAUCHE_VER}/lib/dbm/gdbm.scm:${PORTSDIR}/databases/gauche-gdbm
USE_REINPLACE= yes
MAKE_ARGS= PREFIX="${PREFIX}" DATADIR="${EXAMPLESDIR}"
-post-patch:
- ${REINPLACE_CMD} -e "s|cp -p|${CP}|g" ${WRKSRC}/Makefile
+.if !defined(NOPORTDOCS)
+PORTDOCS= scbayes-ja.html scbayes.html scmail-ja.html scmail.html
+.endif
+
+.include <bsd.port.pre.mk>
-pre-install:
- ${MKDIR} `gauche-config --sitelibdir`
+.if exists(${LOCALBASE}/bin/gauche-config)
+GAUCHE_VER!= gauche-config -V
+.else
+GAUCHE_VER= none
+.endif
+
+post-patch:
+ ${REINPLACE_CMD} -E -e "s,cp -f?p,${CP},g;s,/dot.scmail,," \
+ ${WRKSRC}/Makefile
+ ${TOUCH} ${WRKSRC}/scmail/bayesian-filter.scm.in
post-install:
.if !defined(NOPORTDOCS)
@@ -31,4 +42,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>