aboutsummaryrefslogtreecommitdiff
path: root/mail/sendmail
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2004-07-17 18:51:07 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2004-07-17 18:51:07 +0000
commit70e256a9529533ec7438ff4070501869860e4e18 (patch)
tree7f5337307f6684d49c309e95065d6cdfe7c1188e /mail/sendmail
parent27fdd7c096d5b79ba3d56af5eadd8dfb371516b0 (diff)
downloadports-70e256a9529533ec7438ff4070501869860e4e18.tar.gz
ports-70e256a9529533ec7438ff4070501869860e4e18.zip
Notes
Diffstat (limited to 'mail/sendmail')
-rw-r--r--mail/sendmail/Makefile20
-rw-r--r--mail/sendmail/distinfo8
-rw-r--r--mail/sendmail/files/patch-aa43
3 files changed, 26 insertions, 45 deletions
diff --git a/mail/sendmail/Makefile b/mail/sendmail/Makefile
index 561986a8a854..e838fe57d22a 100644
--- a/mail/sendmail/Makefile
+++ b/mail/sendmail/Makefile
@@ -6,18 +6,13 @@
#
PORTNAME= sendmail
-PORTVERSION= 8.12.11
+PORTVERSION= 8.13.0
CATEGORIES= mail ipv6
MASTER_SITES= ftp://ftp.sendmail.org/pub/sendmail/ \
${MASTER_SITE_RINGSERVER:S,%SUBDIR%,net/mail/sendmail/&,}
PKGNAMESUFFIX?= ${TLS_SUFFIX}${SASL_SUFFIX}${LDAP_SUFFIX}${PKGNAMESUFFIX2}
DISTNAME= ${PORTNAME}.${PORTVERSION}
-.if defined(SENDMAIL_WITH_CONNECTION_RATE)
-PATCH_SITES= http://j-chkmail.ensmp.fr/sm/
-PATCHFILES= ratectrl.src-v2.patch ratectrl.cf.patch
-.endif
-
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Reliable, highly configurable mail transfer agent with utilities
@@ -52,7 +47,6 @@ PKGMESSAGE= ${WRKSRC}/pkg-message
# SENDMAIL_WITH_SOCKETMAP=yes
# SENDMAIL_WITH_CYRUSLOOKUP=yes
# SENDMAIL_WITH_PICKY_HELO_CHECK=yes
-# SENDMAIL_WITH_CONNECTION_RATE=yes
.if defined(SENDMAIL_WITH_SMTPS) && !defined(SENDMAIL_WITH_TLS) && !defined(WITH_TLS)
SENDMAIL_WITH_TLS=yes
@@ -197,11 +191,6 @@ do-configure:
'APPENDDEF(`conf_sendmail_ENVDEF'\'', `-DPICKY_HELO_CHECK'\'')' \
>> ${WCONF}/site.config.m4
.endif
-.if defined(SENDMAIL_WITH_CONNECTION_RATE)
- ${ECHO_CMD} \
- 'APPENDDEF(`conf_sendmail_ENVDEF'\'', `-D_FFR_CONNECTION_RATE_CONTROL'\'')' \
- >> ${WCONF}/site.config.m4
-.endif
.if defined(SENDMAIL_WITHOUT_SHMEM)
${ECHO_CMD} \
'APPENDDEF(`confENVDEF'\'', `-DSM_CONF_SHM=0'\'')' \
@@ -232,9 +221,6 @@ pre-install:
@${ECHO_CMD} `${BASENAME} ${i}` | \
${AWK} '{print "%%DOCSDIR%%/" $$1}' >>${PLIST}
.endfor
-.if defined(SENDMAIL_WITH_CONNECTION_RATE)
- @${ECHO_CMD} "share/doc/sendmail/CONNECTION_RATE_CONTROL" >>${PLIST}
-.endif
.if defined(SENDMAIL_WITH_CYRUSLOOKUP)
@${ECHO_CMD} "share/doc/sendmail/CYRUS_LOOKUP" >>${PLIST}
.endif
@@ -293,10 +279,6 @@ post-install:
@${TAR} -C ${WRKSRC}/libmilter/docs -cf - . | \
${TAR} -C ${DOCSDIR}/libmilter -xf -
.endif
-.if defined(SENDMAIL_WITH_CONNECTION_RATE)
- ${INSTALL_DATA} ${FILESDIR}/CONNECTION_RATE_CONTROL \
- ${DOCSDIR}/CONNECTION_RATE_CONTROL
-.endif
.if defined(SENDMAIL_WITH_CYRUSLOOKUP)
${INSTALL_DATA} ${FILESDIR}/CYRUS_LOOKUP ${DOCSDIR}/CYRUS_LOOKUP
.endif
diff --git a/mail/sendmail/distinfo b/mail/sendmail/distinfo
index 8d7d6cb46765..378dc97907a5 100644
--- a/mail/sendmail/distinfo
+++ b/mail/sendmail/distinfo
@@ -1,6 +1,2 @@
-MD5 (sendmail.8.12.11.tar.gz) = fafda7f8043f0c34b9aa295618aa598c
-SIZE (sendmail.8.12.11.tar.gz) = 1899112
-MD5 (ratectrl.src-v2.patch) = 19fdd5cf759ef693f8f721bcc1b85740
-SIZE (ratectrl.src-v2.patch) = 19321
-MD5 (ratectrl.cf.patch) = 5d88ba0fd3416ded5c908983308fa73a
-SIZE (ratectrl.cf.patch) = 1722
+MD5 (sendmail.8.13.0.tar.gz) = 434aad7d9d151da5dd9d059eb0085e9a
+SIZE (sendmail.8.13.0.tar.gz) = 1960715
diff --git a/mail/sendmail/files/patch-aa b/mail/sendmail/files/patch-aa
index c353c5ad932f..fabf2051d2cb 100644
--- a/mail/sendmail/files/patch-aa
+++ b/mail/sendmail/files/patch-aa
@@ -104,9 +104,9 @@ diff -ur mail.local/mail.local.8.orig mail.local/mail.local.8
getservbyname(3),
comsat(8),
diff -ur mail.local/mail.local.c.orig mail.local/mail.local.c
---- mail.local/mail.local.c.orig Thu May 10 02:58:31 2001
-+++ mail.local/mail.local.c Thu May 31 07:39:04 2001
-@@ -130,6 +132,8 @@
+--- mail.local/mail.local.c.orig Mon Nov 3 19:38:29 2003
++++ mail.local/mail.local.c Tue May 18 07:56:42 2004
+@@ -144,6 +144,8 @@
bool HoldErrs = false; /* Hold errors in ErrBuf */
bool LMTPMode = false;
bool BounceQuota = false; /* permanent error when over quota */
@@ -114,17 +114,20 @@ diff -ur mail.local/mail.local.c.orig mail.local/mail.local.c
+bool NoFsync = false;
char *HomeMailFile = NULL; /* store mail in homedir */
- void deliver __P((int, char *));
-@@ -172,7 +176,7 @@
- # endif /* LOG_MAIL */
-
- from = NULL;
+ #if HASHSPOOL
+@@ -205,9 +207,9 @@
+ exit(EX_CONFIG);
+ }
+ #if HASHSPOOL
+- while ((ch = getopt(argc, argv, "7bdD:f:h:r:lH:p:n")) != -1)
++ while ((ch = getopt(argc, argv, "7bBdD:f:h:r:lsH:p:n")) != -1)
+ #else /* HASHSPOOL */
- while ((ch = getopt(argc, argv, "7bdD:f:h:r:l")) != -1)
+ while ((ch = getopt(argc, argv, "7bBdD:f:h:r:ls")) != -1)
+ #endif /* HASHSPOOL */
{
switch(ch)
- {
-@@ -180,6 +184,10 @@
+@@ -216,6 +218,10 @@
EightBitMime = false;
break;
@@ -135,9 +138,9 @@ diff -ur mail.local/mail.local.c.orig mail.local/mail.local.c
case 'b': /* bounce mail when over quota. */
BounceQuota = true;
break;
-@@ -215,6 +223,10 @@
- LMTPMode = true;
+@@ -307,6 +313,10 @@
break;
+ #endif /* HASHSPOOL */
+ case 's':
+ NoFsync = true;
@@ -146,7 +149,7 @@ diff -ur mail.local/mail.local.c.orig mail.local/mail.local.c
case '?':
default:
usage();
-@@ -224,7 +236,8 @@
+@@ -316,7 +326,8 @@
argv += optind;
/* initialize biff structures */
@@ -156,15 +159,15 @@ diff -ur mail.local/mail.local.c.orig mail.local/mail.local.c
err = sm_mbdb_initialize(mbdbname);
if (err != EX_OK)
-@@ -1128,6 +1141,7 @@
+@@ -1239,6 +1250,7 @@
- /* Get the starting offset of the new message for biff. */
+ /* Get the starting offset of the new message */
curoff = lseek(mbfd, (off_t) 0, SEEK_END);
+ if (!NoBiff)
(void) sm_snprintf(biffmsg, sizeof(biffmsg), "%s@%lld\n",
name, (LONGLONG_T) curoff);
-@@ -1190,7 +1204,7 @@
+@@ -1301,7 +1313,7 @@
}
/* Flush to disk, don't wait for update. */
@@ -173,16 +176,16 @@ diff -ur mail.local/mail.local.c.orig mail.local/mail.local.c
{
mailerr("450 4.2.0", "%s: %s", path, sm_errstring(errno));
err3:
-@@ -1216,7 +1230,7 @@
- mailerr(errcode, "%s: %s", path, sm_errstring(errno));
- (void) truncate(path, curoff);
+@@ -1368,7 +1380,7 @@
+ /* Attempt to truncate back to pre-write size */
+ goto err3;
}
- else
+ else if (!NoBiff)
notifybiff(biffmsg);
if (setreuid(0, 0) < 0)
-@@ -1395,7 +1409,8 @@
+@@ -1547,7 +1559,8 @@
usage()
{
ExitVal = EX_USAGE;