aboutsummaryrefslogtreecommitdiff
path: root/mail/sendmail
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2013-11-16 06:38:19 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2013-11-16 06:38:19 +0000
commit554506ade49869acea312f1c580ebc6eb6a2a858 (patch)
tree473f36babae50a5bc60d407fde54053c2d89434f /mail/sendmail
parentcd76888cd6e98907906c604bd0b0c9b299bcd8f0 (diff)
downloadports-554506ade49869acea312f1c580ebc6eb6a2a858.tar.gz
ports-554506ade49869acea312f1c580ebc6eb6a2a858.zip
Notes
Diffstat (limited to 'mail/sendmail')
-rw-r--r--mail/sendmail/Makefile16
-rw-r--r--mail/sendmail/files/patch-FreeBSD4
-rw-r--r--mail/sendmail/files/sharedlibrary.m46
3 files changed, 11 insertions, 15 deletions
diff --git a/mail/sendmail/Makefile b/mail/sendmail/Makefile
index 6f96de8ec010..c8c1966f42a7 100644
--- a/mail/sendmail/Makefile
+++ b/mail/sendmail/Makefile
@@ -132,8 +132,9 @@ PLIST_SUB+= MILTER_SHARED="@comment "
.endif
.endif
-SED_SCRIPT= -e "s;\`-pthread\';\`${PTHREAD_LIBS}\';" \
- -e "s;\`-O\';\`${CFLAGS}\';"
+SED_SCRIPT= -e "s|\`-pthread\'|\`${PTHREAD_LIBS}\'|" \
+ -e "s|\`-O\'|\`${CFLAGS}\'|" \
+ -e 's|%%CC%%|${CC}|' -e 's|%%LD%%|${LD}|'
.if ! ${PORT_OPTIONS:MNIS}
SED_SCRIPT+= -e "s;-DNIS ;;"
@@ -148,17 +149,12 @@ post-patch:
@${CP} -pR ${WRKSRC}/libmilter ${WRKSRC}/libsharedmilter
${CP} ${FILESDIR}/sharedlibrary.m4 \
${WRKSRC}/devtools/M4/UNIX/sharedlibrary.m4
- @${MV} ${WRKSRC}/libsharedmilter/Makefile.m4 \
- ${WRKSRC}/libsharedmilter/Makefile.m4.sed
- @${SED} -e 's=`library=`sharedlibrary=' \
- ${WRKSRC}/libsharedmilter/Makefile.m4.sed \
- > ${WRKSRC}/libsharedmilter/Makefile.m4
+ ${REINPLACE_CMD} -e 's=`library=`sharedlibrary=' \
+ ${WRKSRC}/libsharedmilter/Makefile.m4
.endif
do-configure:
- @${MV} ${WRKSRC}/devtools/OS/FreeBSD ${WRKSRC}/devtools/OS/FreeBSD.sed
- ${SED} ${SED_SCRIPT} ${WRKSRC}/devtools/OS/FreeBSD.sed \
- > ${WRKSRC}/devtools/OS/FreeBSD
+ ${REINPLACE_CMD} ${SED_SCRIPT} ${WRKSRC}/devtools/OS/FreeBSD
${SED} -e "s=%%PREFIX%%=${PREFIX}=g" \
-e "s=%%LOCALBASE%%=${LOCALBASE}=g" \
${SITE} > ${WCONF}/site.config.m4
diff --git a/mail/sendmail/files/patch-FreeBSD b/mail/sendmail/files/patch-FreeBSD
index 2db53fc410cd..f75af45d2659 100644
--- a/mail/sendmail/files/patch-FreeBSD
+++ b/mail/sendmail/files/patch-FreeBSD
@@ -1,11 +1,11 @@
--- devtools/OS/FreeBSD.orig 2003-07-03 03:07:45.000000000 +0200
-+++ devtools/OS/FreeBSD 2011-06-24 20:24:03.000000000 +0200
++++ devtools/OS/FreeBSD 2013-11-16 07:06:27.000000000 +0100
@@ -6,7 +6,7 @@
define(`confMAPDEF', `-DNEWDB -DNIS -DMAP_REGEX')
define(`confLIBS', `-lutil')
-define(`confLD', `cc')
-+define(`confLD', `${CC}')
++define(`confCC', `%%CC%%')
define(`confMTLDOPTS', `-pthread')
define(`confMTCCOPTS', `-D_THREAD_SAFE')
define(`confLDOPTS_SO', `-shared')
diff --git a/mail/sendmail/files/sharedlibrary.m4 b/mail/sendmail/files/sharedlibrary.m4
index 379f749d8406..80241e29b298 100644
--- a/mail/sendmail/files/sharedlibrary.m4
+++ b/mail/sendmail/files/sharedlibrary.m4
@@ -1,6 +1,6 @@
divert(-1)
#
-# Copyright (c) 1999-2001 Sendmail, Inc. and its suppliers.
+# Copyright (c) 1999-2001, 2006 Sendmail, Inc. and its suppliers.
# All rights reserved.
#
# By using this file, you agree to the terms and conditions set
@@ -10,7 +10,7 @@ divert(-1)
#
# Definitions for Makefile construction for sendmail
#
-# $Id: library.m4,v 8.10 2001/02/14 04:39:38 gshapiro Exp $
+# $Id: library.m4,v 8.11 2006/09/05 22:56:53 ca Exp $
#
divert(0)dnl
include(confBUILDTOOLSDIR`/M4/'bldM4_TYPE_DIR`/links.m4')dnl
@@ -22,7 +22,7 @@ bldPUSH_CLEAN_TARGET(bldCURRENT_PRODUCT`-clean')dnl
include(confBUILDTOOLSDIR`/M4/'bldM4_TYPE_DIR`/defines.m4')
divert(bldTARGETS_SECTION)
bldCURRENT_PRODUCT.so: ${BEFORE} ${bldCURRENT_PRODUCT`OBJS'}
- ${LD} ${LDOPTS_SO} -o bldCURRENT_PRODUCT.so confSONAME bldCURRENT_PRODUCT.so.${MILTER_SOVER} ${bldCURRENT_PRODUCT`OBJS'}
+ ${LD} ${LDOPTS_SO} -o bldCURRENT_PRODUCT.so -Wl,confSONAME -Wl,bldCURRENT_PRODUCT.so.${MILTER_SOVER} ${bldCURRENT_PRODUCT`OBJS'}
ifdef(`bldLINK_SOURCES', `bldMAKE_SOURCE_LINKS(bldLINK_SOURCES)')
install-`'bldCURRENT_PRODUCT: bldCURRENT_PRODUCT.so