aboutsummaryrefslogtreecommitdiff
path: root/mail/sentinel/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-05-12 06:57:51 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-05-12 06:57:51 +0000
commit2905c1693f4a92544a6412181c820b287a1c898e (patch)
treee7502940e624a19eb6e023ac98bcbb5977403437 /mail/sentinel/Makefile
parentebc8ad155ea9b167d70d60a9ada713de7e89b1f1 (diff)
Notes
Diffstat (limited to 'mail/sentinel/Makefile')
-rw-r--r--mail/sentinel/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/mail/sentinel/Makefile b/mail/sentinel/Makefile
index f2a0cb55a27e..a25ddc3412bd 100644
--- a/mail/sentinel/Makefile
+++ b/mail/sentinel/Makefile
@@ -6,13 +6,15 @@
#
PORTNAME= sentinel
-PORTVERSION= 1.6.1b
+PORTVERSION= 1.6.4b
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= smfilter
MAINTAINER= ports@FreeBSD.org
-COMMENT= Sentinel is a sendmail milter API implementation
+COMMENT= A sendmail milter API implementation
+
+LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
USE_REINPLACE= yes
@@ -21,8 +23,10 @@ post-patch:
's|:/var|:${PREFIX}/var|g' ${WRKSRC}/sentinel.cf.SAMPLE
do-build:
- cd ${WRKSRC} && ${CC} ${CFLAGS} ${PTHREAD_CFLAGS} -o ${PORTNAME} \
- ${PORTNAME}.c -lmilter ${PTHREAD_LIBS}
+ cd ${WRKSRC} && \
+ ${CC} ${CFLAGS} -I${LOCALBASE}/include ${PTHREAD_CFLAGS} \
+ -o ${PORTNAME} ${PORTNAME}.c -L${LOCALBASE}/lib \
+ -lmilter -lpcre ${PTHREAD_LIBS}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/sentinel ${PREFIX}/sbin