aboutsummaryrefslogtreecommitdiff
path: root/mail/sentinel/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-09-21 02:26:08 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-09-21 02:26:08 +0000
commit56e5247fbfdbf5610b6629d93bef435a8f0c44ca (patch)
tree878d229a3d5b9688c4e7a76cee1372ac68e0dcde /mail/sentinel/Makefile
parent98b16dd4b38f65206c34dd2cecdb75d65c817661 (diff)
Notes
Diffstat (limited to 'mail/sentinel/Makefile')
-rw-r--r--mail/sentinel/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/mail/sentinel/Makefile b/mail/sentinel/Makefile
new file mode 100644
index 000000000000..00084413049c
--- /dev/null
+++ b/mail/sentinel/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: sentinel
+# Date created: 14 May 2002
+# Whom: Peter Hollaubek <fifteen@inext.hu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sentinel
+PORTVERSION= 1.2b
+CATEGORIES= mail
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= smfilter
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_REINPLACE= yes
+MAKEFILE= Makefile.FreeBSD
+ALL_TARGET= sentinel
+
+post-patch:
+ @${REINPLACE_CMD} -e "s,-pthread,${PTHREAD_LIBS},g" ${WRKSRC}/${MAKEFILE}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/sentinel ${PREFIX}/sbin
+ @${MKDIR} ${PREFIX}/var/sentinel
+ ${CHOWN} smmsp.smmsp ${PREFIX}/var/sentinel
+ ${INSTALL_SCRIPT} ${FILESDIR}/000.sentinel.sh ${PREFIX}/etc/rc.d
+ ${INSTALL_DATA} ${WRKSRC}/sentinel.cf.SAMPLE ${PREFIX}/etc/sentinel.cf.dist
+
+post-install:
+ @${STRIP_CMD} ${PREFIX}/sbin/sentinel
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>