aboutsummaryrefslogtreecommitdiff
path: root/mail/sentinel
diff options
context:
space:
mode:
authorAndrey A. Chernov <ache@FreeBSD.org>2003-09-07 13:09:10 +0000
committerAndrey A. Chernov <ache@FreeBSD.org>2003-09-07 13:09:10 +0000
commit4c66a8732cbc2f6ee39585c242a95bf39820ac7d (patch)
treefcb63b824e922dd7e26b6c430f7716a81bf9ac02 /mail/sentinel
parent85b89802c3a4b37f32a7bf1b00541cef04325722 (diff)
downloadports-4c66a8732cbc2f6ee39585c242a95bf39820ac7d.tar.gz
ports-4c66a8732cbc2f6ee39585c242a95bf39820ac7d.zip
Notes
Diffstat (limited to 'mail/sentinel')
-rw-r--r--mail/sentinel/Makefile3
-rw-r--r--mail/sentinel/files/000.sentinel.sh3
-rw-r--r--mail/sentinel/pkg-plist2
3 files changed, 5 insertions, 3 deletions
diff --git a/mail/sentinel/Makefile b/mail/sentinel/Makefile
index 90b1c1de259a..b89a108b4f2e 100644
--- a/mail/sentinel/Makefile
+++ b/mail/sentinel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sentinel
PORTVERSION= 1.6.5b
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= smfilter
@@ -32,7 +33,7 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/sentinel ${PREFIX}/sbin
@${MKDIR} ${PREFIX}/var/sentinel
${CHOWN} smmsp:smmsp ${PREFIX}/var/sentinel
- ${INSTALL_SCRIPT} ${FILESDIR}/000.sentinel.sh ${PREFIX}/etc/rc.d
+ ${INSTALL_DATA} ${FILESDIR}/000.sentinel.sh ${PREFIX}/etc/rc.d/000.sentinel.sh-dist
${INSTALL_DATA} ${WRKSRC}/sentinel.cf.SAMPLE ${PREFIX}/etc/sentinel.cf.dist
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
diff --git a/mail/sentinel/files/000.sentinel.sh b/mail/sentinel/files/000.sentinel.sh
index 0428f2e880f4..08df334defaf 100644
--- a/mail/sentinel/files/000.sentinel.sh
+++ b/mail/sentinel/files/000.sentinel.sh
@@ -14,7 +14,7 @@ start)
if [ -x ${PREFIX}/sbin/sentinel -a -f ${PREFIX}/etc/sentinel.cf ]
then
rm -f ${SOCKET}
- ${PREFIX}/sbin/sentinel -c ${PREFIX}/etc/sentinel.cf -p unix:${SOCKET} -d && echo -n ' sentinel'
+ LC_ALL=C ${PREFIX}/sbin/sentinel -c ${PREFIX}/etc/sentinel.cf -p unix:${SOCKET} -d && echo -n ' sentinel'
fi
;;
stop)
@@ -23,6 +23,7 @@ stop)
if [ -e ${SOCKET} ]
then
killall -KILL sentinel
+ rm -f ${SOCKET}
fi
;;
*)
diff --git a/mail/sentinel/pkg-plist b/mail/sentinel/pkg-plist
index 05b751261647..bb34c5311960 100644
--- a/mail/sentinel/pkg-plist
+++ b/mail/sentinel/pkg-plist
@@ -1,6 +1,6 @@
sbin/sentinel
etc/sentinel.cf.dist
-etc/rc.d/000.sentinel.sh
+etc/rc.d/000.sentinel.sh-dist
@exec mkdir %D/var/sentinel
@exec chown smmsp:smmsp %D/var/sentinel
@unexec rmdir %D/var/sentinel 2>/dev/null || true