aboutsummaryrefslogtreecommitdiff
path: root/mail/sentinel
diff options
context:
space:
mode:
authorAndrey A. Chernov <ache@FreeBSD.org>2003-12-20 05:11:02 +0000
committerAndrey A. Chernov <ache@FreeBSD.org>2003-12-20 05:11:02 +0000
commit5e8552276818ec5eed2f7edcc4996dd6fca95a5d (patch)
tree7c3c170f895115e0ba5c33bb96a050e6cd52a9fc /mail/sentinel
parent120579072c5a91c89bbe06ec8034c9f14541aec9 (diff)
downloadports-5e8552276818ec5eed2f7edcc4996dd6fca95a5d.tar.gz
ports-5e8552276818ec5eed2f7edcc4996dd6fca95a5d.zip
Notes
Diffstat (limited to 'mail/sentinel')
-rw-r--r--mail/sentinel/Makefile4
-rw-r--r--mail/sentinel/files/patch-aa13
2 files changed, 17 insertions, 0 deletions
diff --git a/mail/sentinel/Makefile b/mail/sentinel/Makefile
index f83e3f210e65..0048dda21a06 100644
--- a/mail/sentinel/Makefile
+++ b/mail/sentinel/Makefile
@@ -24,6 +24,10 @@ IGNORE= requires Sendmail 8.12
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+.if defined(WITHOUT_SENTINEL_DECODE_SUBJECT)
+CFLAGS+= -DDO_NOT_DECODE_SUBJECT
+.endif
+
do-build:
cd ${WRKSRC} && \
${CC} ${CFLAGS} ${PTHREAD_CFLAGS} \
diff --git a/mail/sentinel/files/patch-aa b/mail/sentinel/files/patch-aa
new file mode 100644
index 000000000000..dc3328b409b3
--- /dev/null
+++ b/mail/sentinel/files/patch-aa
@@ -0,0 +1,13 @@
+--- sentinel.c.bak Mon Oct 27 02:03:32 2003
++++ sentinel.c Sat Dec 20 07:59:32 2003
+@@ -3135,8 +3135,10 @@
+ /* check if a rule defined for this header in [headers] section */
+ for (smfhl = smfHeader_list[message->cfgNdx]; smfhl; smfhl = smfhl->next) {
+ if (!strcasecmp(smfhl->name, headerf)) {
++#ifndef DO_NOT_DECODE_SUBJECT
+ if (!strcasecmp(headerf, "Subject"))
+ headerv = smfMimeDecodeString(headerv, message->buf);
++#endif
+ if (headerv) {
+ for (smfel = smfhl->entr; smfel; smfel = smfel->next) {
+ if (!smfPatternMatch(message, headerv, smfel->event)) {