aboutsummaryrefslogtreecommitdiff
path: root/mail/sid-milter
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2005-06-11 07:29:15 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2005-06-11 07:29:15 +0000
commitd7d20d0add0d1388293f1236056a6f5540292080 (patch)
treec66292227d3ae9d8e6b3ace4c639ec78a9046ca4 /mail/sid-milter
parent2298437f46248c7286c2607b5074a1ce44dc73a8 (diff)
downloadports-d7d20d0add0d1388293f1236056a6f5540292080.tar.gz
ports-d7d20d0add0d1388293f1236056a6f5540292080.zip
Notes
Diffstat (limited to 'mail/sid-milter')
-rw-r--r--mail/sid-milter/Makefile3
-rw-r--r--mail/sid-milter/distinfo4
-rw-r--r--mail/sid-milter/files/milter-sid.sh2
-rw-r--r--mail/sid-milter/files/patch-sid-filter.c114
4 files changed, 14 insertions, 109 deletions
diff --git a/mail/sid-milter/Makefile b/mail/sid-milter/Makefile
index 5009a313c1f2..e980505153f5 100644
--- a/mail/sid-milter/Makefile
+++ b/mail/sid-milter/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= sid-milter
-PORTVERSION= 0.2.5
-PORTREVISION= 1
+PORTVERSION= 0.2.8
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= sid-milter
diff --git a/mail/sid-milter/distinfo b/mail/sid-milter/distinfo
index 3010502cdc80..20e48bed2105 100644
--- a/mail/sid-milter/distinfo
+++ b/mail/sid-milter/distinfo
@@ -1,2 +1,2 @@
-MD5 (sid-milter-0.2.5.tar.gz) = e258571b141242a77f6d567938e173dc
-SIZE (sid-milter-0.2.5.tar.gz) = 283159
+MD5 (sid-milter-0.2.8.tar.gz) = 0523c8a3e7b33deab062fa00fad7e9fd
+SIZE (sid-milter-0.2.8.tar.gz) = 286422
diff --git a/mail/sid-milter/files/milter-sid.sh b/mail/sid-milter/files/milter-sid.sh
index 5b6cc9522e34..cec14fae523a 100644
--- a/mail/sid-milter/files/milter-sid.sh
+++ b/mail/sid-milter/files/milter-sid.sh
@@ -9,8 +9,8 @@ fi
sid_filter_args="-t -r 0"
case "$1" in
start)
- cd /root
sh "${0}" wait
+ cd /var/crash
rm -f /var/run/sid-filter.pid /var/run/sid-filter
%%PREFIX%%/libexec/sid-filter -l -p local:/var/run/sid-filter \
-P /var/run/sid-filter.pid ${sid_filter_args}
diff --git a/mail/sid-milter/files/patch-sid-filter.c b/mail/sid-milter/files/patch-sid-filter.c
index cde26c1af3ff..4692a9abefbf 100644
--- a/mail/sid-milter/files/patch-sid-filter.c
+++ b/mail/sid-milter/files/patch-sid-filter.c
@@ -1,109 +1,15 @@
---- sid-filter/sid-filter.c.orig Fri Dec 3 01:06:22 2004
-+++ sid-filter/sid-filter.c Sat Dec 18 22:08:31 2004
-@@ -857,7 +857,7 @@
- if (dolog)
- {
- syslog(LOG_ERR,
-- "%s DNS reply garbled (%d %s)",
-+ "%s DNS reply garbled expand1 (%d %s)",
- sic->ctx_jobid, type, dd);
- }
-
-@@ -876,8 +876,11 @@
- if (dolog)
- {
- syslog(LOG_ERR,
-- "%s DNS reply garbled (%d %s)",
-+ "%s DNS reply garbled type1 (%d %s)",
- sic->ctx_jobid, type, dd);
-+ syslog(LOG_ERR,
-+ "rtype=%d, type=%d, class=%d, expected=%d",
-+ rtype, type, class, (int)C_IN);
- }
-
- return -1;
-@@ -905,7 +908,7 @@
- if (dolog)
- {
- syslog(LOG_ERR,
-- "%s DNS reply garbled (%d %s)",
-+ "%s DNS reply garbled expand2 (%d %s)",
- sic->ctx_jobid, type, dd);
- }
-
-@@ -918,7 +921,7 @@
- if (dolog)
- {
- syslog(LOG_ERR,
-- "%s DNS reply garbled (%d %s)",
-+ "%s DNS reply garbled cp1 (%d %s)",
- sic->ctx_jobid, type, dd);
- }
-
-@@ -932,7 +935,7 @@
- if (dolog)
- {
- syslog(LOG_ERR,
-- "%s DNS reply garbled (%d %s)",
-+ "%s DNS reply garbled type2 (%d %s)",
- sic->ctx_jobid, type, dd);
- }
-
-@@ -948,7 +951,7 @@
- if (dolog)
- {
- syslog(LOG_ERR,
-- "%s DNS reply garbled (%d %s)",
-+ "%s DNS reply garbled cp2 (%d %s)",
- sic->ctx_jobid, type, dd);
- }
+--- sid-filter/sid-filter.c.orig Wed Apr 27 00:16:26 2005
++++ sid-filter/sid-filter.c Sat Jun 11 09:22:24 2005
+@@ -1140,8 +1140,6 @@
+ }
+ break;
-@@ -961,7 +964,7 @@
- if (dolog)
- {
- syslog(LOG_ERR,
-- "%s DNS reply garbled (%d %s)",
-+ "%s DNS reply garbled cp3 (%d %s)",
- sic->ctx_jobid, type, dd);
+- default:
+- /* NOTREACHED */
}
+ }
-@@ -999,7 +1002,7 @@
- if (dolog)
- {
- syslog(LOG_ERR,
-- "%s DNS reply garbled (%d %s)",
-+ "%s DNS reply garbled mx (%d %s)",
- sic->ctx_jobid, type,
- dd);
- }
-@@ -1018,7 +1021,7 @@
- if (dolog)
- {
- syslog(LOG_ERR,
-- "%s DNS reply garbled (%d %s)",
-+ "%s DNS reply garbled mx expand (%d %s)",
- sic->ctx_jobid, type,
- dd);
- }
-@@ -1047,7 +1050,7 @@
- if (dolog)
- {
- syslog(LOG_ERR,
-- "%s DNS reply garbled (%d %s)",
-+ "%s DNS reply garbled ptr (%d %s)",
- sic->ctx_jobid, type,
- dd);
- }
-@@ -1073,7 +1076,7 @@
- /* sort MX list */
- for (n = 0; n < nmx; n++)
- {
-- if (prec[n] > prec[n + 1])
-+ if ((n + 1 < nmx) && prec[n] > prec[n + 1])
- {
- m = prec[n];
- prec[n] = prec[n + 1];
-@@ -1772,7 +1775,7 @@
+@@ -1865,7 +1863,7 @@
}
sid_msgcleanup(ctx);
@@ -112,7 +18,7 @@
}
/* construct the status header's content */
-@@ -1801,7 +1804,7 @@
+@@ -1895,7 +1893,7 @@
}
sid_msgcleanup(ctx);