aboutsummaryrefslogtreecommitdiff
path: root/mail/sieve-connect
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-06-26 08:12:57 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-06-26 08:12:57 +0000
commit5c4d327347884b68cac2895d7133b606c36ec315 (patch)
tree6b87a7a36b3cc2e84069c2fdc45a39add902c95b /mail/sieve-connect
parenta38565cc58b4cbfbb535162e1fb5dae22c60c89c (diff)
downloadports-5c4d327347884b68cac2895d7133b606c36ec315.tar.gz
ports-5c4d327347884b68cac2895d7133b606c36ec315.zip
Notes
Diffstat (limited to 'mail/sieve-connect')
-rw-r--r--mail/sieve-connect/Makefile50
-rw-r--r--mail/sieve-connect/distinfo2
-rw-r--r--mail/sieve-connect/pkg-descr20
3 files changed, 72 insertions, 0 deletions
diff --git a/mail/sieve-connect/Makefile b/mail/sieve-connect/Makefile
new file mode 100644
index 000000000000..444b1998d17a
--- /dev/null
+++ b/mail/sieve-connect/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: sieve-connect
+# Date created: Sat 14 May 2011
+# Whom: Alexey V. Degtyarev <alexey@renatasystems.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sieve-connect
+PORTVERSION= 0.81
+CATEGORIES= mail
+MASTER_SITES= http://people.spodhuis.org/phil.pennock/software/ \
+ ftp://ftp.renatasystems.org/pub/FreeBSD/ports/distfiles/
+
+MAINTAINER= alexey@renatasystems.org
+COMMENT= Command-line client for the MANAGESIEVE protocol
+
+RUN_DEPENDS= p5-Authen-SASL>=0:${PORTSDIR}/security/p5-Authen-SASL \
+ p5-IO-Socket-INET6>=0:${PORTSDIR}/net/p5-IO-Socket-INET6 \
+ p5-IO-Socket-SSL>=0:${PORTSDIR}/security/p5-IO-Socket-SSL \
+ p5-Net-DNS>=0:${PORTSDIR}/dns/p5-Net-DNS \
+ p5-ReadLine-Gnu>=0:${PORTSDIR}/devel/p5-ReadLine-Gnu \
+ p5-Term-ReadKey>=0:${PORTSDIR}/devel/p5-Term-ReadKey
+
+LICENSE= unknown
+LICENSE_NAME= Public Domain
+LICENSE_PERMS= ${_LICENSE_PERMS_DEFAULT}
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USE_BZIP2= yes
+USE_PERL5= yes
+PLIST_FILES= bin/${PORTNAME}
+
+MAN1= sieve-connect.1
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= ChangeLog README TODO
+.endif
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/sieve-connect ${PREFIX}/bin/sieve-connect
+ ${INSTALL_MAN} ${WRKSRC}/sieve-connect.1 \
+ ${MANPREFIX}/man/man1/sieve-connect.1
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for _doc in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${_doc} ${DOCSDIR}/${_doc}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/mail/sieve-connect/distinfo b/mail/sieve-connect/distinfo
new file mode 100644
index 000000000000..f8265987cf8b
--- /dev/null
+++ b/mail/sieve-connect/distinfo
@@ -0,0 +1,2 @@
+SHA256 (sieve-connect-0.81.tar.bz2) = 3f8d4b15966554e2a6d635447dc826fffd4a12503bfa46f8e47fcd03e366d831
+SIZE (sieve-connect-0.81.tar.bz2) = 30750
diff --git a/mail/sieve-connect/pkg-descr b/mail/sieve-connect/pkg-descr
new file mode 100644
index 000000000000..eafe87921479
--- /dev/null
+++ b/mail/sieve-connect/pkg-descr
@@ -0,0 +1,20 @@
+This is sieve-connect. A client for the ManageSieve protocol, as specifed in
+RFC 5804. Historically, this was MANAGESIEVE as implemented by timsieved in
+Cyrus IMAP.
+
+This is not yet fully compatible with RFC 5804, but is moving towards that from
+the timsieved baseline; some issues to be worked on are documented in the
+"TODO" file.
+
+sieve-connect speaks ManageSieve and supports TLS for connection privacy and
+also authentication if using client certificates. sieve-connect will use SASL
+authentication; SASL integrity layers are not supported, use TLS instead.
+GSSAPI-based authentication should generally work, provided that client and
+server can use a common underlaying protocol. If it doesn't work for you,
+please report the issue.
+
+sieve-connect is designed to be both a tool which can be invoked from scripts
+and also a decent interactive client. It should also be a drop-in replacement
+for "sieveshell", as supplied with Cyrus IMAP.
+
+WWW: http://people.spodhuis.org/phil.pennock/software/