aboutsummaryrefslogtreecommitdiff
path: root/mail/simscan/Makefile
diff options
context:
space:
mode:
authorFelippe de Meirelles Motta <lippe@FreeBSD.org>2009-11-21 20:18:14 +0000
committerFelippe de Meirelles Motta <lippe@FreeBSD.org>2009-11-21 20:18:14 +0000
commited4757f540613046b3fe21d4d0f31153b918790a (patch)
treea21eeff9e18cbdf66573db9b6cac76f8f86bf0e8 /mail/simscan/Makefile
parent2bca210686591baace01e1c22f806bd73f84e47b (diff)
downloadports-ed4757f540613046b3fe21d4d0f31153b918790a.tar.gz
ports-ed4757f540613046b3fe21d4d0f31153b918790a.zip
Notes
Diffstat (limited to 'mail/simscan/Makefile')
-rw-r--r--mail/simscan/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/mail/simscan/Makefile b/mail/simscan/Makefile
index c2982911cd54..7985e063281a 100644
--- a/mail/simscan/Makefile
+++ b/mail/simscan/Makefile
@@ -7,7 +7,7 @@
PORTNAME= simscan
PORTVERSION= 1.4.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= mail security
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.r/rc/}
@@ -37,7 +37,8 @@ OPTIONS= CLAMAV "Support for ClamAV Virus Scanning" on \
ATTACH "Turn On Attachment Scanning (required CLAMAV)" off \
DROPMSG "Drop Message in Case of Virus Found" off \
PASSTHRU "Pass Spam Thru, Do Not Reject (required SPAMD)" off \
- HEADERS "Add a Received Line With Versions of Scanners" off
+ HEADERS "Add a Received Line With Versions of Scanners" off \
+ DSPAM "Turn on DSPAM scanning" off
.include <bsd.port.pre.mk>
@@ -90,6 +91,11 @@ CONFIGURE_ARGS+=--enable-received=y
CONFIGURE_ARGS+=--enable-sigtool-path=${LOCALBASE}/bin/sigtool
.endif
+.if defined(WITH_DSPAM)
+CONFIGURE_ARGS+=--enable-dspam=y
+BUILD_DEPENDS+= dspam:${PORTSDIR}/mail/dspam
+.endif
+
.if defined(SPAM_HITS)
CONFIGURE_ARGS+=--enable-spam-hits=${SPAM_HITS}
.endif