aboutsummaryrefslogtreecommitdiff
path: root/mail/simscan
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2006-01-21 17:37:14 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2006-01-21 17:37:14 +0000
commit01c588a6357d8452a3e0af157e9c1250c067db2f (patch)
treefb26bf418ea8791ab4d308a7931c623124611c3c /mail/simscan
parentf484c99df79f169bf954fc4b0ed83e59279a596a (diff)
downloadports-01c588a6357d8452a3e0af157e9c1250c067db2f.tar.gz
ports-01c588a6357d8452a3e0af157e9c1250c067db2f.zip
Notes
Diffstat (limited to 'mail/simscan')
-rw-r--r--mail/simscan/Makefile18
-rw-r--r--mail/simscan/pkg-plist6
2 files changed, 11 insertions, 13 deletions
diff --git a/mail/simscan/Makefile b/mail/simscan/Makefile
index cd26374ee85f..68e2cc2773d4 100644
--- a/mail/simscan/Makefile
+++ b/mail/simscan/Makefile
@@ -7,6 +7,7 @@
PORTNAME= simscan
PORTVERSION= 1.1
+PORTREVISION= 1
CATEGORIES= mail security
MASTER_SITES= http://www.inter7.com/simscan/
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,17 +16,14 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:S/.r/rc/}
MAINTAINER= toxa@toxahost.ru
COMMENT= Fast Content/Anti-virus Scanner for qmail Written in C
-BUILD_DEPENDS= ${QMAIL_QUEUE}:${PORTSDIR}/mail/qmail
+USE_QMAIL_BUILD= yes
GNU_CONFIGURE= yes
USE_REINPLACE= yes
-# A normal qmail installation puts everything into /var/qmail/.
-# Must match your qmail installation
-QMAIL_DIR?= /var/qmail
-WORKDIR?= ${QMAIL_DIR}/${PORTNAME}
-QMAIL_QUEUE= ${QMAIL_DIR}/bin/qmail-queue
-PLIST_SUB= QMAIL_DIR=${QMAIL_DIR} \
+WORKDIR?= ${QMAIL_PREFIX}/${PORTNAME}
+QMAIL_QUEUE= ${QMAIL_PREFIX}/bin/qmail-queue
+PLIST_SUB= QMAIL_PREFIX=${QMAIL_PREFIX} \
SIMSCAN_DIR=${PORTNAME}
OPTIONS= CLAMAV "Support for ClamAV Virus Scanning" on \
@@ -41,7 +39,7 @@ OPTIONS= CLAMAV "Support for ClamAV Virus Scanning" on \
.include <bsd.port.pre.mk>
CONFIGURE_ARGS=--enable-clamavdb-path=/var/db/clamav \
- --enable-qmaildir=${QMAIL_DIR} \
+ --enable-qmaildir=${QMAIL_PREFIX} \
--enable-spamc-user=n \
--enable-workdir=${WORKDIR} \
--enable-user=nobody
@@ -109,7 +107,7 @@ PORTDOCS= AUTHORS ChangeLog README TODO
if ! ${TEST} -f ${QMAIL_QUEUE}; then \
${ECHO_MSG} "Unable to found qmail-queue binary trying '${QMAIL_QUEUE}'."; \
- ${ECHO_MSG} "Please set QMAIL_DIR to your qmail installation directory !"; \
+ ${ECHO_MSG} "Please set QMAIL_PREFIX to your qmail installation directory !"; \
exit 1; \
fi
@@ -118,7 +116,7 @@ pre-configure:
@${ECHO_MSG} "=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~="
@${ECHO_MSG} "You may also use the following build options:"
@${ECHO_MSG} ""
- @${ECHO_MSG} "QMAIL_DIR Base qmail directory. Default is /var/qmail"
+ @${ECHO_MSG} "QMAIL_PREFIX Base qmail directory. Default is /var/qmail"
@${ECHO_MSG} "WORKDIR Directory to unpack emails. Default is /var/qmail/simscan"
@${ECHO_MSG} "QMAIL_QUEUE Define full path and name of the qmail-queue program"
@${ECHO_MSG} " Incoming mail is passed to this program after being"
diff --git a/mail/simscan/pkg-plist b/mail/simscan/pkg-plist
index 38fa642f64cf..5b806f15f2f3 100644
--- a/mail/simscan/pkg-plist
+++ b/mail/simscan/pkg-plist
@@ -1,7 +1,7 @@
-@cwd %%QMAIL_DIR%%
+@cwd %%QMAIL_PREFIX%%
bin/simscanmk
bin/simscan
-@unexec rmdir %%QMAIL_DIR%%/%%SIMSCAN_DIR%% || true
+@unexec rmdir %%QMAIL_PREFIX%%/%%SIMSCAN_DIR%% || true
@unexec echo ""
-@unexec echo "If you're not updating this port, you can delete %%QMAIL_DIR%%/%%SIMSCAN_DIR%% directory"
+@unexec echo "If you're not updating this port, you can delete %%QMAIL_PREFIX%%/%%SIMSCAN_DIR%% directory"
@unexec echo ""