aboutsummaryrefslogtreecommitdiff
path: root/mail/smtp-gated
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2006-01-02 22:19:23 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2006-01-02 22:19:23 +0000
commit7f29ea0aeca6428149d41ea9ce6dd077cc0ef113 (patch)
tree2a19bc800dee1c72b3be2b789a9957907fc24665 /mail/smtp-gated
parent7439f0e6509d2a5c5755c6e7d40eb96af0524af7 (diff)
downloadports-7f29ea0aeca6428149d41ea9ce6dd077cc0ef113.tar.gz
ports-7f29ea0aeca6428149d41ea9ce6dd077cc0ef113.zip
Notes
Diffstat (limited to 'mail/smtp-gated')
-rw-r--r--mail/smtp-gated/Makefile45
-rw-r--r--mail/smtp-gated/distinfo3
-rw-r--r--mail/smtp-gated/pkg-descr9
3 files changed, 57 insertions, 0 deletions
diff --git a/mail/smtp-gated/Makefile b/mail/smtp-gated/Makefile
new file mode 100644
index 000000000000..ef95cb5236d8
--- /dev/null
+++ b/mail/smtp-gated/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: smtp-gated
+# Date created: 1 January 2006
+# Whom: msciciel
+#
+# $FreeBSD$
+#
+
+PORTNAME= smtp-gated
+PORTVERSION= 1.4.12.r9
+PORTREVISION= 0
+CATEGORIES= mail
+MASTER_SITES= http://smtp-proxy.klolik.org/
+DISTNAME= ${PORTNAME}-1.4.12-rc9
+
+MAINTAINER= msciciel@darkzone.ma.cx
+COMMENT= This software block SMTP sessions used by e-mail worms and viruses
+
+HAS_CONFIGURE= yes
+USE_AUTOTOOLS= autoheader:259
+
+OPTIONS= NAT "NAT transparent proxy code" On \
+ CHUNKING "Enable support for SMTP CHUNKING extension" Off \
+ ECONNRESET "Be quiet about Connection reset by peer message" Off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_NAT)
+CONFIGURE_ARGS+= --enable-nat
+.else
+CONFIGURE_ARGS+= --disable-nat
+.endif
+
+.if defined(WITH_CHUNKING)
+CONFIGURE_ARGS+= --enable-chunking
+.endif
+
+.if defined(WITH_ECONNRESET)
+CONFIGURE_ARGS+= --enable-silent-econnreset
+.endif
+
+PLIST_FILES= sbin/smtp-gated
+MAN5= smtp-gated.conf.5
+MAN8= smtp-gated.8
+
+.include <bsd.port.post.mk>
diff --git a/mail/smtp-gated/distinfo b/mail/smtp-gated/distinfo
new file mode 100644
index 000000000000..27d2d119f3d5
--- /dev/null
+++ b/mail/smtp-gated/distinfo
@@ -0,0 +1,3 @@
+MD5 (smtp-gated-1.4.12-rc9.tar.gz) = cdecc3174665062207a2171622aca495
+SHA256 (smtp-gated-1.4.12-rc9.tar.gz) = ab1886c9df5c4d035ec32241e1bc616cde2de046ae5a70bd35188849f2f7fa02
+SIZE (smtp-gated-1.4.12-rc9.tar.gz) = 210617
diff --git a/mail/smtp-gated/pkg-descr b/mail/smtp-gated/pkg-descr
new file mode 100644
index 000000000000..c4c2c122c11c
--- /dev/null
+++ b/mail/smtp-gated/pkg-descr
@@ -0,0 +1,9 @@
+This software block SMTP sessions used by e-mail worms and viruses on the NA(P)T
+ router. It depends on netfilter framework of Linux, or ipfw on FreeBSD.
+
+It acts like proxy, intercepting outgoing SMTP connections and scanning session
+data on-the-fly. When messages is infected, the SMTP session is terminated. It's
+to be used (mostly) by ISPs, so they can eliminate infected hosts from their net
+work, and (preferably) educate their users.
+
+WWW: http://smtp-proxy.klolik.org/