aboutsummaryrefslogtreecommitdiff
path: root/mail/smtp-gated
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-06-13 05:55:02 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-06-13 05:55:02 +0000
commit7da39d11c2a4d3613e19a4dc6a562337ba1bfacd (patch)
tree06c1fcce4e4bd9e8bdce472e8eca4f4a467896ca /mail/smtp-gated
parentc2894a8bc4d59836f188e71d0024673d696c7ec8 (diff)
downloadports-7da39d11c2a4d3613e19a4dc6a562337ba1bfacd.tar.gz
ports-7da39d11c2a4d3613e19a4dc6a562337ba1bfacd.zip
Notes
Diffstat (limited to 'mail/smtp-gated')
-rw-r--r--mail/smtp-gated/Makefile17
1 files changed, 9 insertions, 8 deletions
diff --git a/mail/smtp-gated/Makefile b/mail/smtp-gated/Makefile
index 9ad01d7df16b..0d3487f507ac 100644
--- a/mail/smtp-gated/Makefile
+++ b/mail/smtp-gated/Makefile
@@ -15,10 +15,11 @@ COMMENT= Proxy for SMTP sessions with virus and spam scan
LICENSE= GPLv2
-OPTIONS= NAT "NAT transparent proxy code" On \
- CHUNKING "Enable support for SMTP CHUNKING extension" Off \
- ECONNRESET "Be quiet about Connection reset by peer message" Off \
- PCRE "Enable support for PCRE" On
+OPTIONS_DEFINE= NAT CHUNKING ECONNRESET PCRE
+OPTIONS_DEFAULT= NAT PCRE
+NAT_DESC= NAT transparent proxy code
+CHUNKING_DESC= Enable support for SMTP CHUNKING extension
+ECONNRESET_DESC= Be quiet about Connection reset by peer message
GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= yes
@@ -32,21 +33,21 @@ PLIST_FILES= sbin/smtp-gated
.include <bsd.port.options.mk>
-.if defined(WITH_NAT)
+.if ${PORT_OPTIONS:MNAT}
CONFIGURE_ARGS+= --enable-nat
.else
CONFIGURE_ARGS+= --disable-nat
.endif
-.if defined(WITH_CHUNKING)
+.if ${PORT_OPTIONS:MCHUNKING}
CONFIGURE_ARGS+= --enable-chunking
.endif
-.if defined(WITH_ECONNRESET)
+.if ${PORT_OPTIONS:MECONNRESET}
CONFIGURE_ARGS+= --enable-silent-econnreset
.endif
-.if defined(WITH_PCRE)
+.if ${PORT_OPTIONS:MPCRE}
LIB_DEPENDS+= pcre.1:${PORTSDIR}/devel/pcre
.else
CONFIGURE_ARGS+= --disable-pcre