aboutsummaryrefslogtreecommitdiff
path: root/mail/spamass-milter/Makefile
diff options
context:
space:
mode:
authorHye-Shik Chang <perky@FreeBSD.org>2002-06-26 18:54:03 +0000
committerHye-Shik Chang <perky@FreeBSD.org>2002-06-26 18:54:03 +0000
commit46699d1d603c13d0cca46c37e3faab164dcef678 (patch)
tree29d195df9ae54869ccbca10ff50404520340d4dd /mail/spamass-milter/Makefile
parent3ecee7d612c42a213646e2cf3def939a2912e038 (diff)
Notes
Diffstat (limited to 'mail/spamass-milter/Makefile')
-rw-r--r--mail/spamass-milter/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/mail/spamass-milter/Makefile b/mail/spamass-milter/Makefile
new file mode 100644
index 000000000000..06310c44ea28
--- /dev/null
+++ b/mail/spamass-milter/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: spamass-milter
+# Date created: 29 April 2002
+# Whom: Eugene M. Kim <ab@astralblue.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= spamass-milter
+PORTVERSION= 0.1.1
+CATEGORIES= mail
+MASTER_SITES= http://freesoftware.fsf.org/download/spamass-milt/
+
+MAINTAINER= ab@astralblue.net
+
+BUILD_DEPENDS= spamc:${PORTSDIR}/mail/p5-Mail-SpamAssassin
+RUN_DEPENDS= spamc:${PORTSDIR}/mail/p5-Mail-SpamAssassin
+
+.if !exists(/usr/lib/libmilter.a)
+IGNORE= requires Sendmail 8.12; upgrade the base system
+.endif
+
+USE_AUTOMAKE= YES
+MAKE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
+ PTHREAD_LIBS="${PTHREAD_LIBS}" PORT_CFLAGS="${CFLAGS}"
+PLIST_SUB= DOCSDIR=${DOCSDIR}
+
+post-patch:
+.for f in spamass-milter.sh.dist activation.txt
+ ${SED} -e 's|/usr/local|${PREFIX}|g' \
+ ${FILESDIR}/${f} > ${WRKDIR}/${f}
+.endfor
+
+post-install:
+ ${INSTALL_DATA} ${WRKDIR}/spamass-milter.sh.dist \
+ ${PREFIX}/etc/rc.d/spamass-milter.sh.dist
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKDIR}/activation.txt ${DOCSDIR}/activation.txt
+.endif
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>