aboutsummaryrefslogtreecommitdiff
path: root/mail/spamass-milter/Makefile
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2011-03-28 03:08:45 +0000
committerWen Heping <wen@FreeBSD.org>2011-03-28 03:08:45 +0000
commitb69c89adb37234853e74d18184996feb701c2023 (patch)
tree6d864d27b5afaabe41af60cc5a8ddf77f4c01016 /mail/spamass-milter/Makefile
parent9c60a607f1f7c8711a6c60dc4ed9b94a32de2905 (diff)
downloadports-b69c89adb37234853e74d18184996feb701c2023.tar.gz
ports-b69c89adb37234853e74d18184996feb701c2023.zip
Notes
Diffstat (limited to 'mail/spamass-milter/Makefile')
-rw-r--r--mail/spamass-milter/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/mail/spamass-milter/Makefile b/mail/spamass-milter/Makefile
index f8352e671bbb..1fffd3f1088b 100644
--- a/mail/spamass-milter/Makefile
+++ b/mail/spamass-milter/Makefile
@@ -25,7 +25,8 @@ MAKE_JOBS_SAFE= yes
OPTIONS= ADDAUTH_PATCH "Bypass checks for SMTP AUTH connections" off \
REJECTTEXT_PATCH "Customize SMTP reject message" off \
LDAP "LDAP support" off \
- SENDMAIL_PORT "Build against sendmail port" off
+ SENDMAIL_PORT "Build against sendmail port" off \
+ IPV6 "Apply IPv6 whitelist patch" off
.include <bsd.port.pre.mk>
@@ -42,6 +43,10 @@ EXTRA_PATCHES+= ${FILESDIR}/extra-patch-rejecttext1
NEW_ARGS:= ${NEW_ARGS}R:
.endif
+.if defined(WITH_IPV6)
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-ipv6
+.endif
+
# extra-patch-options is modified in pre-patch
.if ${ORIG_ARGS} != ${NEW_ARGS}
EXTRA_PATCHES+= ${WRKDIR}/extra-patch-options