aboutsummaryrefslogtreecommitdiff
path: root/mail/spambnc/Makefile
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2005-01-17 22:54:57 +0000
committerThierry Thomas <thierry@FreeBSD.org>2005-01-17 22:54:57 +0000
commitd6627758461904bcb91fb35b273379680ae3ad8a (patch)
treeed339b929ec85fd2c2e1050b65d753386733e1d0 /mail/spambnc/Makefile
parent2b801338bfad1fb82213af052673588f59f553ad (diff)
Notes
Diffstat (limited to 'mail/spambnc/Makefile')
-rw-r--r--mail/spambnc/Makefile25
1 files changed, 21 insertions, 4 deletions
diff --git a/mail/spambnc/Makefile b/mail/spambnc/Makefile
index 904046fae6e4..7dd56c3691c4 100644
--- a/mail/spambnc/Makefile
+++ b/mail/spambnc/Makefile
@@ -6,13 +6,13 @@
#
PORTNAME= spambnc
-PORTVERSION= 20041223
+PORTVERSION= 20050115
CATEGORIES= mail
MASTER_SITES= http://www.spambouncer.org/ \
ftp://ftp.spambouncer.org/
-DISTFILES= sb.tar.gz index.shtml
+DISTFILES= sb-new.tar.gz index.shtml
DIST_SUBDIR= spambnc-${PORTVERSION}
-EXTRACT_ONLY= sb.tar.gz
+EXTRACT_ONLY= sb-new.tar.gz
MAINTAINER= thierry@FreeBSD.org
COMMENT= Set of procmail recipies which handle known/suspected spam
@@ -23,14 +23,27 @@ IGNOREFILES= index.shtml
NO_WRKSUBDIR= yes
NO_BUILD= yes
PLIST= ${WRKDIR}/.pkg-plist
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+SUB_DIRS= functions docs data auxiliary
+
+.if !defined(NOPORTDOCS)
+MASTER_SITES+= http://www.spambouncer.org/webdev/configure/:upg
+DISTFILES+= upgrading.shtml:upg
+IGNOREFILES+= upgrading.shtml
+.endif
pre-install:
@${RM} -f ${PLIST}
@(cd ${WRKDIR} && ${FIND} -s . -type f | ${GREP} -v "^\.\/\." | \
${SED} -e 's,.,%%DATADIR%%,1' >> ${PLIST})
+.for dd in ${SUB_DIRS}
+ @${ECHO_CMD} "@dirrm %%DATADIR%%/${dd}" >> ${PLIST}
+.endfor
@${ECHO_CMD} "@dirrm %%DATADIR%%" >> ${PLIST}
.if !defined(NOPORTDOCS)
@${ECHO_CMD} "%%DOCSDIR%%/documentation.html" >> ${PLIST}
+ @${ECHO_CMD} "%%DOCSDIR%%/upgrading.html" >> ${PLIST}
@${ECHO_CMD} "@dirrm %%DOCSDIR%%" >> ${PLIST}
.endif
@@ -41,9 +54,13 @@ do-install:
@${MKDIR} ${DOCSDIR}
@${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/index.shtml \
${DOCSDIR}/documentation.html
+ @${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/upgrading.shtml \
+ ${DOCSDIR}/upgrading.html
.endif
post-install:
- @${SED} -e 's,%%PREFIX%%,${PREFIX},g' ${PKGMESSAGE}
+ @${SED} -e 's,%%DOCSDIR%%,${DOCSDIR},;s,%%DATADIR%%,${DATADIR},' \
+ < ${FILESDIR}/pkg-message.in > ${PKGMESSAGE}
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>