aboutsummaryrefslogtreecommitdiff
path: root/mail/spambnc/Makefile
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2003-12-05 01:42:34 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2003-12-05 01:42:34 +0000
commit159a648417380cf68e915cd03f9e89e6cfaa8b0b (patch)
tree3647132c092946955b54e9dfe47901270f343be6 /mail/spambnc/Makefile
parent06d90d3434c2a100a4d59eb141de0145328feafa (diff)
downloadports-159a648417380cf68e915cd03f9e89e6cfaa8b0b.tar.gz
ports-159a648417380cf68e915cd03f9e89e6cfaa8b0b.zip
Notes
Diffstat (limited to 'mail/spambnc/Makefile')
-rw-r--r--mail/spambnc/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/mail/spambnc/Makefile b/mail/spambnc/Makefile
index 3d706bb32723..dca262578db5 100644
--- a/mail/spambnc/Makefile
+++ b/mail/spambnc/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= spambnc
-PORTVERSION= 20031128
+PORTVERSION= 20031203
CATEGORIES= mail
MASTER_SITES= http://www.spambouncer.org/ \
ftp://ftp.spambouncer.org/
@@ -27,19 +27,19 @@ PLIST= ${WRKDIR}/.pkg-plist
pre-install:
@${RM} -f ${PLIST}
@(cd ${WRKDIR} && ${FIND} -s . -type f | ${GREP} -v "^\.\/\." | \
- ${SED} -e 's,.,share/spambnc,1' >> ${PLIST})
- @${ECHO_CMD} "@dirrm share/spambnc" >> ${PLIST}
+ ${SED} -e 's,.,%%DATADIR%%,1' >> ${PLIST})
+ @${ECHO_CMD} "@dirrm %%DATADIR%%" >> ${PLIST}
.if !defined(NOPORTDOCS)
@${ECHO_CMD} "%%DOCSDIR%%/documentation.html" >> ${PLIST}
@${ECHO_CMD} "@dirrm %%DOCSDIR%%" >> ${PLIST}
.endif
do-install:
- ${MKDIR} ${PREFIX}/share/spambnc/
- cd ${WRKDIR} && ${CP} -Rv * ${PREFIX}/share/spambnc
+ ${MKDIR} ${DATADIR}
+ cd ${WRKDIR} && ${CP} -Rv * ${DATADIR}
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/index.shtml \
+ @${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/index.shtml \
${DOCSDIR}/documentation.html
.endif