aboutsummaryrefslogtreecommitdiff
path: root/mail/spampd
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2005-12-09 09:59:42 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2005-12-09 09:59:42 +0000
commit0b3a0a198ce8e43fe20f173a93f93c4bb789740f (patch)
tree2c09387cefd66591536bf1fb8327d91dc9d9c631 /mail/spampd
parent54fdbc8ef2507e61d64860b2cd8bbe1798865f54 (diff)
downloadports-0b3a0a198ce8e43fe20f173a93f93c4bb789740f.tar.gz
ports-0b3a0a198ce8e43fe20f173a93f93c4bb789740f.zip
Notes
Diffstat (limited to 'mail/spampd')
-rw-r--r--mail/spampd/Makefile11
-rw-r--r--mail/spampd/distinfo5
-rw-r--r--mail/spampd/files/patch-user_dir10
3 files changed, 22 insertions, 4 deletions
diff --git a/mail/spampd/Makefile b/mail/spampd/Makefile
index b70b26e48288..ad050045728a 100644
--- a/mail/spampd/Makefile
+++ b/mail/spampd/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= spampd
-PORTVERSION= 2.20
+PORTVERSION= 2.30
CATEGORIES= mail perl5
MASTER_SITES= http://www.worlddesign.com/Content/rd/mta/spampd/
@@ -22,4 +22,11 @@ do-install:
@${INSTALL_SCRIPT} ${WRKSRC}/spampd ${PREFIX}/sbin
@${INSTALL_SCRIPT} ${FILESDIR}/spampd.sh.sample ${PREFIX}/etc/rc.d
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+# spampd -> p5-Mail-SpamAssassin
+.if ${PERL_LEVEL} < 500601
+IGNORE= needs perl 5.6.1 or higher, install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/mail/spampd/distinfo b/mail/spampd/distinfo
index f3a651f62922..416cd7cbd3f0 100644
--- a/mail/spampd/distinfo
+++ b/mail/spampd/distinfo
@@ -1,2 +1,3 @@
-MD5 (spampd-2.20.tar.gz) = 4efdb66e424bc24f8a7ce3bf6264ce31
-SIZE (spampd-2.20.tar.gz) = 22713
+MD5 (spampd-2.30.tar.gz) = 742c6f2cb75db54e59d044a8ee40445f
+SHA256 (spampd-2.30.tar.gz) = 6885544f4d1b339ebe3ad58068434397280a6526f682e78f7d0246aef6a09979
+SIZE (spampd-2.30.tar.gz) = 25001
diff --git a/mail/spampd/files/patch-user_dir b/mail/spampd/files/patch-user_dir
new file mode 100644
index 000000000000..56fd193c7449
--- /dev/null
+++ b/mail/spampd/files/patch-user_dir
@@ -0,0 +1,10 @@
+--- spampd.orig Thu Dec 8 09:54:07 2005
++++ spampd Thu Dec 8 09:54:07 2005
+@@ -793,6 +793,7 @@
+ my $assassin = Mail::SpamAssassin->new({
+ 'dont_copy_prefs' => 1,
+ 'debug' => $debug,
++ 'user_dir' => (getpwnam($user))[7],
+ 'local_tests_only' => $options{'local-only'} || 0 });
+
+ $options{'auto-whitelist'} and eval {