aboutsummaryrefslogtreecommitdiff
path: root/mail/sqlgrey
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2005-02-21 17:16:50 +0000
committerMathieu Arnold <mat@FreeBSD.org>2005-02-21 17:16:50 +0000
commitfbd40d60872589e9f36dfb3b1364cc8e46f3b4fe (patch)
tree165054d38af97c0b5886514dce32cd38c4d3cd81 /mail/sqlgrey
parentdfc8acd5dfa1dcf69796fb6a84a0669acce44747 (diff)
Notes
Diffstat (limited to 'mail/sqlgrey')
-rw-r--r--mail/sqlgrey/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/mail/sqlgrey/Makefile b/mail/sqlgrey/Makefile
index 4b281262cf0b..4258498cffa7 100644
--- a/mail/sqlgrey/Makefile
+++ b/mail/sqlgrey/Makefile
@@ -38,8 +38,9 @@ SGY_GROUPNAME?= ${SGY_USERNAME}
ETCDIR?= etc/sqlgrey
SUB_FILES= pkg-install
-SUB_LIST= ETCDIR=${ETCDIR} ETCFILES="${ETCFILES}" USER=${SGY_USERNAME} GROUP=${SGY_GROUPNAME}
-PLIST_SUB= ${SUB_LIST} TOUCH=${TOUCH}
+MY_SUB_LIST= ETCDIR=${ETCDIR} ETCFILES="${ETCFILES}" USER=${SGY_USERNAME} GROUP=${SGY_GROUPNAME}
+SUB_LIST= ${MY_SUB_LIST}
+PLIST_SUB= TOUCH=${TOUCH} ${MY_SUB_LIST}
PKGINSTALL= ${WRKDIR}/pkg-install
PKGDEINSTALL= ${PKGINSTALL}
@@ -67,12 +68,12 @@ do-install:
@${INSTALL_DATA} ${WRKSRC}/etc/${i} ${PREFIX}/${ETCDIR}/${i}.dist
@[ "${i}" = "sqlgrey.conf" ] || ${TOUCH} ${PREFIX}/${ETCDIR}/${i}.local
@[ -f ${PREFIX}/${ETCDIR}/${i} ] || ${INSTALL_DATA} ${WRKSRC}/etc/${i} ${PREFIX}/${ETCDIR}/${i}
+.endfor
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif
-.endfor
post-install:
@${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL