aboutsummaryrefslogtreecommitdiff
path: root/mail/squirrelmail-abook_import_export-plugin
diff options
context:
space:
mode:
authorThomas Abthorpe <tabthorpe@FreeBSD.org>2010-02-02 03:15:19 +0000
committerThomas Abthorpe <tabthorpe@FreeBSD.org>2010-02-02 03:15:19 +0000
commitc4e6d777637a39591f7a63d3bf2394fbb1559b72 (patch)
tree2b9337630227049dd1a5a3523f33ded7d211aecd /mail/squirrelmail-abook_import_export-plugin
parentdc5645d8e6b38870aee58febed4bf3eeb4f1cd3e (diff)
Notes
Diffstat (limited to 'mail/squirrelmail-abook_import_export-plugin')
-rw-r--r--mail/squirrelmail-abook_import_export-plugin/Makefile23
-rw-r--r--mail/squirrelmail-abook_import_export-plugin/distinfo3
-rw-r--r--mail/squirrelmail-abook_import_export-plugin/files/pkg-message.in7
-rw-r--r--mail/squirrelmail-abook_import_export-plugin/pkg-descr5
-rw-r--r--mail/squirrelmail-abook_import_export-plugin/pkg-plist17
5 files changed, 55 insertions, 0 deletions
diff --git a/mail/squirrelmail-abook_import_export-plugin/Makefile b/mail/squirrelmail-abook_import_export-plugin/Makefile
new file mode 100644
index 000000000000..d72c9e556175
--- /dev/null
+++ b/mail/squirrelmail-abook_import_export-plugin/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: squirrelmail-abook_import-export-plugin
+# Date created: 2010-01-27
+# Whom: Scott Lambert <lambert@lambertfam.org>
+# Modified from: squirrelmail-check_quota-plugin
+#
+# $FreeBSD$
+#
+
+PORTNAME= abook_import_export
+PORTVERSION= 1.1
+DISTNAME= ${PORTNAME:S/-/_/}-${PORTVERSION}-1.4.4
+DIST_SUBDIR= squirrelmail
+
+MAINTAINER= lambert@lambertfam.org
+COMMENT= Allows for the importing of addressbooks from a CSV (comma separated values) file.
+
+SQUIRREL_PLUGIN_NAME= ${PORTNAME:S/-/_/}
+
+.include <bsd.port.pre.mk>
+
+.include "${PORTSDIR}/mail/squirrelmail/bsd.squirrelmail.mk"
+
+.include <bsd.port.post.mk>
diff --git a/mail/squirrelmail-abook_import_export-plugin/distinfo b/mail/squirrelmail-abook_import_export-plugin/distinfo
new file mode 100644
index 000000000000..a463f2aa4004
--- /dev/null
+++ b/mail/squirrelmail-abook_import_export-plugin/distinfo
@@ -0,0 +1,3 @@
+MD5 (squirrelmail/abook_import_export-1.1-1.4.4.tar.gz) = 29708739d856ad4d1a18bd6e840316a4
+SHA256 (squirrelmail/abook_import_export-1.1-1.4.4.tar.gz) = 59f2c795170f2155076d5c5e730415c3148e469f775bb0cde617652b6d1bfe26
+SIZE (squirrelmail/abook_import_export-1.1-1.4.4.tar.gz) = 23988
diff --git a/mail/squirrelmail-abook_import_export-plugin/files/pkg-message.in b/mail/squirrelmail-abook_import_export-plugin/files/pkg-message.in
new file mode 100644
index 000000000000..f973030e458b
--- /dev/null
+++ b/mail/squirrelmail-abook_import_export-plugin/files/pkg-message.in
@@ -0,0 +1,7 @@
+================================================================
+You may want to copy the file
+%%PREFIX%%/%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/config_default.php
+to
+%%PREFIX%%/%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/config.php
+and edit the configuration to meet your needs.
+================================================================
diff --git a/mail/squirrelmail-abook_import_export-plugin/pkg-descr b/mail/squirrelmail-abook_import_export-plugin/pkg-descr
new file mode 100644
index 000000000000..ec1e4f03c287
--- /dev/null
+++ b/mail/squirrelmail-abook_import_export-plugin/pkg-descr
@@ -0,0 +1,5 @@
+Allows for the importing of addressbooks from a CSV (comma separated
+values) file. This will be located at the bottom of the "Addresses"
+section.
+
+WWW: http://www.squirrelmail.org/plugin_view.php?id=29
diff --git a/mail/squirrelmail-abook_import_export-plugin/pkg-plist b/mail/squirrelmail-abook_import_export-plugin/pkg-plist
new file mode 100644
index 000000000000..70058032e033
--- /dev/null
+++ b/mail/squirrelmail-abook_import_export-plugin/pkg-plist
@@ -0,0 +1,17 @@
+@unexec if [ -f %D/%%SQUIRRELDIR%%/config/config.php ]; then %D/%%SQUIRRELDIR%%/config/conf.pl --remove-plugin %%SQUIRREL_PLUGIN_NAME%%; fi
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/CHANGELOG
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/COPYING
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/INSTALL
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/README
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/ReleaseNotes.txt
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/abook_import_export.pot
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/address_book_export.php
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/address_book_import.php
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/config_default.php
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/functions.php
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/index.php
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/setup.php
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/version
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/xgetpot
+@dirrm %%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%
+@exec if [ -f %D/%%SQUIRRELDIR%%/config/config.php ]; then %D/%%SQUIRRELDIR%%/config/conf.pl --install-plugin %%SQUIRREL_PLUGIN_NAME%%; fi