aboutsummaryrefslogtreecommitdiff
path: root/mail/squirrelmail-login_auth-plugin/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-04-15 16:44:01 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-04-15 16:44:01 +0000
commit35f06fcd24af52d953cded5f5934c12d46bb7926 (patch)
tree30d5691bbf690c78abb7d342f5ffad68d06665b1 /mail/squirrelmail-login_auth-plugin/Makefile
parent3f26c432685806af221acb3e07de287f1bdd9d2b (diff)
downloadports-35f06fcd24af52d953cded5f5934c12d46bb7926.tar.gz
ports-35f06fcd24af52d953cded5f5934c12d46bb7926.zip
Notes
Diffstat (limited to 'mail/squirrelmail-login_auth-plugin/Makefile')
-rw-r--r--mail/squirrelmail-login_auth-plugin/Makefile72
1 files changed, 72 insertions, 0 deletions
diff --git a/mail/squirrelmail-login_auth-plugin/Makefile b/mail/squirrelmail-login_auth-plugin/Makefile
new file mode 100644
index 000000000000..77b71ebe4c3c
--- /dev/null
+++ b/mail/squirrelmail-login_auth-plugin/Makefile
@@ -0,0 +1,72 @@
+# New ports collection makefile for: squirrelmail-wetteronline-plugin
+# Date created: 14 April 2006
+# Whom: Stefan Bethke <stb@lassitu.de>
+#
+# $FreeBSD$
+
+PORTNAME= squirrelmail-${SQUIRREL_PLUGIN_NAME}-plugin
+PORTVERSION= 2.0
+CATEGORIES= mail www
+MASTER_SITES= http://www.squirrelmail.org/plugins/ \
+ http://alkoholix.tallence.de/www.squirrelmail.org/plugins/
+DISTNAME= ${SQUIRREL_PLUGIN_NAME}-${PORTVERSION}-1.4.0
+DIST_SUBDIR= squirrelmail
+
+MAINTAINER= stb@lassitu.de
+COMMENT= Automatically log in user based on HTTP authentication
+
+RUN_DEPENDS= ${SQUIRRELDIR}/index.php:${PORTSDIR}/mail/squirrelmail
+
+SQUIRREL_PLUGIN_NAME= login_auth
+
+.ifdef SQUIRRELDIR
+PLIST_SUB+= SQUIRRELDIR=${SQUIRRELDIR}
+SUB_LIST+= "SQUIRRELDIR=${SQUIRRELDIR}"
+.else
+. ifndef WITHOUT_WWWDIR
+SQUIRRELDIR= ${PREFIX}/www/squirrelmail
+PLIST_SUB+= SQUIRRELDIR=www/squirrelmail
+SUB_LIST+= "SQUIRRELDIR=www/squirrelmail"
+. else
+SQUIRRELDIR= ${PREFIX}/squirrelmail
+PLIST_SUB+= SQUIRRELDIR=squirrelmail
+SUB_LIST+= "SQUIRRELDIR=squirrelmail"
+. endif
+.endif
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+USE_PERL5_BUILD= yes
+USE_PHP= yes
+WANT_PHP_WEB= yes
+
+pre-everything::
+ @${ECHO} ""
+.ifndef WITHOUT_ACTIVATE
+ @${ECHO} "Activating plug-in in SquirrelMail after installation."
+ @${ECHO} "If you don't want to automatically activate the plug-in set"
+ @${ECHO} "WITHOUT_ACTIVATE=yes"
+.else
+ @${ECHO} "NOT Activating plug-in in SquirrelMail after installation."
+ @${ECHO} "If you want to automatically activate the plug-in unset"
+ @${ECHO} "WITHOUT_ACTIVATE"
+.endif
+ @${ECHO} ""
+
+do-install:
+ ${CP} -rp ${WRKSRC}/${SQUIRREL_PLUGIN_NAME} ${SQUIRRELDIR}/plugins
+ ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${SQUIRRELDIR}/plugins/${SQUIRREL_PLUGIN_NAME}
+
+post-install:
+.ifndef WITHOUT_ACTIVATE
+.if exists( ${SQUIRRELDIR}/config/config.php )
+ @${ECHO} "Activating plug-in in SquirrelMail"
+ ${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}
+.endif
+.else
+ @${ECHO} "To activate the plug-in in SquirrelMail use"
+ @${ECHO} "${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}"
+.endif
+ @${ECHO} ""
+
+.include <bsd.port.mk>