aboutsummaryrefslogtreecommitdiff
path: root/mail/squirrelmail-login_auth-plugin
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2012-11-10 01:37:24 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2012-11-10 01:37:24 +0000
commit14f5b9b330ef0eb94af8a844fc910d5589592ec6 (patch)
tree45fdb1d9af176a1041803788fbf5c9c2a0db4cbd /mail/squirrelmail-login_auth-plugin
parent90461f79f59a492dde6eba53a6d8c35ebed79c04 (diff)
downloadports-14f5b9b330ef0eb94af8a844fc910d5589592ec6.tar.gz
ports-14f5b9b330ef0eb94af8a844fc910d5589592ec6.zip
Notes
Diffstat (limited to 'mail/squirrelmail-login_auth-plugin')
-rw-r--r--mail/squirrelmail-login_auth-plugin/Makefile62
1 files changed, 6 insertions, 56 deletions
diff --git a/mail/squirrelmail-login_auth-plugin/Makefile b/mail/squirrelmail-login_auth-plugin/Makefile
index f851fd1c21d0..2fa25c0e0725 100644
--- a/mail/squirrelmail-login_auth-plugin/Makefile
+++ b/mail/squirrelmail-login_auth-plugin/Makefile
@@ -4,70 +4,20 @@
#
# $FreeBSD$
-PORTNAME= squirrelmail-${SQUIRREL_PLUGIN_NAME}-plugin
+PORTNAME= login_auth
PORTVERSION= 2.0
PORTREVISION= 1
-CATEGORIES= mail www
MASTER_SITES= http://www.squirrelmail.org/plugins/ \
http://alkoholix.tallence.de/www.squirrelmail.org/plugins/
-DISTNAME= ${SQUIRREL_PLUGIN_NAME}-${PORTVERSION}-1.4.0
+DISTNAME= ${PORTNAME}-${PORTVERSION}-1.4.0
DIST_SUBDIR= squirrelmail
MAINTAINER= stb@lassitu.de
COMMENT= Automatically log in user based on HTTP authentication
-RUN_DEPENDS= ${SQUIRRELDIR}/index.php:${PORTSDIR}/mail/squirrelmail
+SQUIRREL_PLUGIN_NAME= ${PORTNAME}
-SQUIRREL_PLUGIN_NAME= login_auth
-.ifdef SQUIRRELDIR
-PLIST_SUB+= SQUIRRELDIR=${SQUIRRELDIR}
-SUB_LIST+= "SQUIRRELDIR=${SQUIRRELDIR}"
-.else
-. ifndef WITHOUT_WWWDIR
-SQUIRRELDIR= ${PREFIX}/www/squirrelmail
-PLIST_SUB+= SQUIRRELDIR=www/squirrelmail
-SUB_LIST+= "SQUIRRELDIR=www/squirrelmail"
-. else
-SQUIRRELDIR= ${PREFIX}/squirrelmail
-PLIST_SUB+= SQUIRRELDIR=squirrelmail
-SUB_LIST+= "SQUIRRELDIR=squirrelmail"
-. endif
-.endif
-
-NO_BUILD= yes
-NO_WRKSUBDIR= yes
-USE_PERL5_BUILD= yes
-USE_PHP= yes
-WANT_PHP_WEB= yes
-
-pre-everything::
- @${ECHO} ""
-.ifndef WITHOUT_ACTIVATE
- @${ECHO} "Activating plug-in in SquirrelMail after installation."
- @${ECHO} "If you don't want to automatically activate the plug-in set"
- @${ECHO} "WITHOUT_ACTIVATE=yes"
-.else
- @${ECHO} "NOT Activating plug-in in SquirrelMail after installation."
- @${ECHO} "If you want to automatically activate the plug-in unset"
- @${ECHO} "WITHOUT_ACTIVATE"
-.endif
- @${ECHO} ""
-
-do-install:
- ${CP} -rp ${WRKSRC}/${SQUIRREL_PLUGIN_NAME} ${SQUIRRELDIR}/plugins
- ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${SQUIRRELDIR}/plugins/${SQUIRREL_PLUGIN_NAME}
-
-post-install:
-.ifndef WITHOUT_ACTIVATE
-.if exists( ${SQUIRRELDIR}/config/config.php )
- @${ECHO} "Activating plug-in in SquirrelMail"
- ${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}
-.endif
-.else
- @${ECHO} "To activate the plug-in in SquirrelMail use"
- @${ECHO} "${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}"
-.endif
- @${ECHO} ""
-
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/mail/squirrelmail/bsd.squirrelmail.mk"
+.include <bsd.port.post.mk>