aboutsummaryrefslogtreecommitdiff
path: root/mail/squirrelmail-login_notes-plugin
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-03-20 20:54:53 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-03-20 20:54:53 +0000
commit6b9036fb24b772f057a0653634fecf0ab2cd59c5 (patch)
treecf809c866716578745f703d10a219879de3cdea0 /mail/squirrelmail-login_notes-plugin
parentca1122805a296a57894a82753caba070878af89b (diff)
downloadports-6b9036fb24b772f057a0653634fecf0ab2cd59c5.tar.gz
ports-6b9036fb24b772f057a0653634fecf0ab2cd59c5.zip
Notes
Diffstat (limited to 'mail/squirrelmail-login_notes-plugin')
-rw-r--r--mail/squirrelmail-login_notes-plugin/Makefile75
-rw-r--r--mail/squirrelmail-login_notes-plugin/distinfo3
-rw-r--r--mail/squirrelmail-login_notes-plugin/files/pkg-message.in5
-rw-r--r--mail/squirrelmail-login_notes-plugin/pkg-descr5
-rw-r--r--mail/squirrelmail-login_notes-plugin/pkg-plist10
5 files changed, 98 insertions, 0 deletions
diff --git a/mail/squirrelmail-login_notes-plugin/Makefile b/mail/squirrelmail-login_notes-plugin/Makefile
new file mode 100644
index 000000000000..507065925d79
--- /dev/null
+++ b/mail/squirrelmail-login_notes-plugin/Makefile
@@ -0,0 +1,75 @@
+# New ports collection makefile for: squirrelmail-login_notes-plugin
+# Date created: 10 Feb 2006
+# Whom: Gerrit Beine <gerrit.beine@gmx.de>
+#
+# $FreeBSD$
+
+PORTNAME= squirrelmail-${SQUIRREL_PLUGIN_NAME}-plugin
+PORTVERSION= 1.1
+CATEGORIES= mail www
+MASTER_SITES= http://www.squirrelmail.org/plugins/
+DISTNAME= ${SQUIRREL_PLUGIN_NAME}-${PORTVERSION}-1.4.0
+DIST_SUBDIR= squirrelmail
+
+MAINTAINER= gerrit.beine@gmx.de
+COMMENT= View quota and current usage
+
+RUN_DEPENDS= ${SQUIRRELDIR}/index.php:${PORTSDIR}/mail/squirrelmail \
+ ${SQUIRRELDIR}/plugins/compatibility:${PORTSDIR}/mail/squirrelmail-compatibility-plugin
+
+SQUIRREL_PLUGIN_NAME= login_notes
+
+.ifdef SQUIRRELDIR
+PLIST_SUB+= SQUIRRELDIR=${SQUIRRELDIR}
+SUB_LIST+= "SQUIRRELDIR=${SQUIRRELDIR}"
+.else
+. ifndef WITHOUT_WWWDIR
+SQUIRRELDIR= ${PREFIX}/www/squirrelmail
+PLIST_SUB+= SQUIRRELDIR=www/squirrelmail
+SUB_LIST+= "SQUIRRELDIR=www/squirrelmail"
+. else
+SQUIRRELDIR= ${PREFIX}/squirrelmail
+PLIST_SUB+= SQUIRRELDIR=squirrelmail
+SUB_LIST+= "SQUIRRELDIR=squirrelmail"
+. endif
+.endif
+
+SUB_FILES= pkg-message
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+USE_PERL5_BUILD= yes
+USE_PHP= yes
+WANT_PHP_WEB= yes
+
+pre-everything::
+ @${ECHO} ""
+.ifndef WITHOUT_ACTIVATE
+ @${ECHO} "Activating plug-in in SquirrelMail after installation."
+ @${ECHO} "If you don't want to automatically activate the plug-in set"
+ @${ECHO} "WITHOUT_ACTIVATE=yes"
+.else
+ @${ECHO} "NOT Activating plug-in in SquirrelMail after installation."
+ @${ECHO} "If you want to automatically activate the plug-in unset"
+ @${ECHO} "WITHOUT_ACTIVATE"
+.endif
+ @${ECHO} ""
+
+do-install:
+ ${CP} -rp ${WRKSRC}/${SQUIRREL_PLUGIN_NAME} ${SQUIRRELDIR}/plugins
+ ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${SQUIRRELDIR}/plugins/${SQUIRREL_PLUGIN_NAME}
+
+post-install:
+.ifndef WITHOUT_ACTIVATE
+.if exists( ${SQUIRRELDIR}/config/config.php )
+ @${ECHO} "Activating plug-in in SquirrelMail"
+ ${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}
+.endif
+.else
+ @${ECHO} "To activate the plug-in in SquirrelMail use"
+ @${ECHO} "${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}"
+.endif
+ @${ECHO} ""
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/mail/squirrelmail-login_notes-plugin/distinfo b/mail/squirrelmail-login_notes-plugin/distinfo
new file mode 100644
index 000000000000..3cc5df0795e0
--- /dev/null
+++ b/mail/squirrelmail-login_notes-plugin/distinfo
@@ -0,0 +1,3 @@
+MD5 (squirrelmail/login_notes-1.1-1.4.0.tar.gz) = b6fe516931123230d3fb960803338a20
+SHA256 (squirrelmail/login_notes-1.1-1.4.0.tar.gz) = d53e8593e52e2053bde50f89356ed80ac3a31a7fff9761c5281cb52ad2fccef1
+SIZE (squirrelmail/login_notes-1.1-1.4.0.tar.gz) = 8200
diff --git a/mail/squirrelmail-login_notes-plugin/files/pkg-message.in b/mail/squirrelmail-login_notes-plugin/files/pkg-message.in
new file mode 100644
index 000000000000..c8e521e65bec
--- /dev/null
+++ b/mail/squirrelmail-login_notes-plugin/files/pkg-message.in
@@ -0,0 +1,5 @@
+For the port to work properly you must copy the file
+%%PREFIX%%/%%SQUIRRELDIR%%/plugins/login_notes/config.php.sample
+to
+%%PREFIX%%/%%SQUIRRELDIR%%/plugins/login_notes/config.php
+and edit the configuration to meet your needs.
diff --git a/mail/squirrelmail-login_notes-plugin/pkg-descr b/mail/squirrelmail-login_notes-plugin/pkg-descr
new file mode 100644
index 000000000000..025fb447e71c
--- /dev/null
+++ b/mail/squirrelmail-login_notes-plugin/pkg-descr
@@ -0,0 +1,5 @@
+This plugin allows you to place text and/or images on the top and/or bottom
+of the login screen. It also serves as a good introduction to how to write
+a simple SquirrelMail plugin.
+
+WWW: http://www.squirrelmail.org
diff --git a/mail/squirrelmail-login_notes-plugin/pkg-plist b/mail/squirrelmail-login_notes-plugin/pkg-plist
new file mode 100644
index 000000000000..ad0fd06dcad8
--- /dev/null
+++ b/mail/squirrelmail-login_notes-plugin/pkg-plist
@@ -0,0 +1,10 @@
+@unexec if [ -f %D/%%SQUIRRELDIR%%/config/config.php ]; then %D/%%SQUIRRELDIR%%/config/conf.pl --remove-plugin login_notes; fi
+%%SQUIRRELDIR%%/plugins/login_notes/COPYING
+%%SQUIRRELDIR%%/plugins/login_notes/INSTALL
+%%SQUIRRELDIR%%/plugins/login_notes/README
+%%SQUIRRELDIR%%/plugins/login_notes/config.php.sample
+%%SQUIRRELDIR%%/plugins/login_notes/functions.php
+%%SQUIRRELDIR%%/plugins/login_notes/index.php
+%%SQUIRRELDIR%%/plugins/login_notes/setup.php
+@dirrm %%SQUIRRELDIR%%/plugins/login_notes/
+@exec if [ -f %D/%%SQUIRRELDIR%%/config/config.php ]; then %D/%%SQUIRRELDIR%%/config/conf.pl --install-plugin login_notes; fi