aboutsummaryrefslogtreecommitdiff
path: root/mail/squirrelmail-notes-plugin
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2013-12-08 16:53:57 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2013-12-08 16:53:57 +0000
commitc61905043e9ff73d46dbeb97a6d9703de99d4600 (patch)
treea10c7c003855b79bd2d28f4f3d9dbed60cc28f4f /mail/squirrelmail-notes-plugin
parentd18a180211dda12cd188400e0543bc92af46cf65 (diff)
Notes
Diffstat (limited to 'mail/squirrelmail-notes-plugin')
-rw-r--r--mail/squirrelmail-notes-plugin/Makefile78
-rw-r--r--mail/squirrelmail-notes-plugin/files/pkg-message.in4
2 files changed, 15 insertions, 67 deletions
diff --git a/mail/squirrelmail-notes-plugin/Makefile b/mail/squirrelmail-notes-plugin/Makefile
index 75928f720132..8a83bd989e7b 100644
--- a/mail/squirrelmail-notes-plugin/Makefile
+++ b/mail/squirrelmail-notes-plugin/Makefile
@@ -1,77 +1,25 @@
# Created by: Gerrit Beine <gerrit.beine@gmx.de>
# $FreeBSD$
-PORTNAME= squirrelmail-${SQUIRREL_PLUGIN_NAME}-plugin
-PORTVERSION= 1.2
+PORTNAME= notes
+PORTVERSION= 1.2
PORTREVISION= 1
CATEGORIES= mail www
-MASTER_SITES= http://www.squirrelmail.org/plugins/
-DISTNAME= ${SQUIRREL_PLUGIN_NAME}.${PORTVERSION}-1.4.0
-DIST_SUBDIR= squirrelmail
+MASTER_SITES= http://www.squirrelmail.org/plugins/
+PKGNAMEPREFIX= squirrelmail-
+PKGNAMESUFFIX= -plugin
+DISTNAME= ${PORTNAME}.${PORTVERSION}-1.4.0
+DIST_SUBDIR= squirrelmail
MAINTAINER= ports@FreeBSD.org
COMMENT= Allows you to create notes
-RUN_DEPENDS= ${SQUIRRELDIR}/index.php:${PORTSDIR}/mail/squirrelmail \
- ${SQUIRRELDIR}/plugins/compatibility:${PORTSDIR}/mail/squirrelmail-compatibility-plugin
-
-SQUIRREL_PLUGIN_NAME= notes
-
-.ifdef SQUIRRELDIR
-PLIST_SUB+= SQUIRRELDIR=${SQUIRRELDIR}
-SUB_LIST+= "SQUIRRELDIR=${SQUIRRELDIR}"
-.else
-. ifndef WITHOUT_WWWDIR
-SQUIRRELDIR= ${PREFIX}/www/squirrelmail
-PLIST_SUB+= SQUIRRELDIR=www/squirrelmail
-SUB_LIST+= "SQUIRRELDIR=www/squirrelmail"
-. else
-SQUIRRELDIR= ${PREFIX}/squirrelmail
-PLIST_SUB+= SQUIRRELDIR=squirrelmail
-SUB_LIST+= "SQUIRRELDIR=squirrelmail"
-. endif
-.endif
-
-SUB_FILES= pkg-message
-
-USES= perl5
-NO_BUILD= yes
-NO_WRKSUBDIR= yes
-USE_PERL5= build
-USE_PHP= yes
-WANT_PHP_WEB= yes
-IGNORE_WITH_PHP= 5 # known incompatibilities with php-5.4, use 5.3 for now
-DEFAULT_PHP_VER= 53
+USES= perl5
+USE_PERL5= install
+USE_SM_COMPAT= yes
NO_STAGE= yes
-pre-everything::
- @${ECHO} ""
-.ifndef WITHOUT_ACTIVATE
- @${ECHO} "Activating plug-in in SquirrelMail after installation."
- @${ECHO} "If you don't want to automatically activate the plug-in set"
- @${ECHO} "WITHOUT_ACTIVATE=yes"
-.else
- @${ECHO} "NOT Activating plug-in in SquirrelMail after installation."
- @${ECHO} "If you want to automatically activate the plug-in unset"
- @${ECHO} "WITHOUT_ACTIVATE"
-.endif
- @${ECHO} ""
-
-do-install:
- ${CP} -rp ${WRKSRC}/${SQUIRREL_PLUGIN_NAME} ${SQUIRRELDIR}/plugins
- ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${SQUIRRELDIR}/plugins/${SQUIRREL_PLUGIN_NAME}
-
-post-install:
-.ifndef WITHOUT_ACTIVATE
-.if exists( ${SQUIRRELDIR}/config/config.php )
- @${ECHO} "Activating plug-in in SquirrelMail"
- ${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}
-.endif
-.else
- @${ECHO} "To activate the plug-in in SquirrelMail use"
- @${ECHO} "${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}"
-.endif
- @${ECHO} ""
- @${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.include "${.CURDIR}/../squirrelmail/bsd.squirrelmail.mk"
+.include <bsd.port.post.mk>
diff --git a/mail/squirrelmail-notes-plugin/files/pkg-message.in b/mail/squirrelmail-notes-plugin/files/pkg-message.in
index bb53d88b1042..651dbb4c1c81 100644
--- a/mail/squirrelmail-notes-plugin/files/pkg-message.in
+++ b/mail/squirrelmail-notes-plugin/files/pkg-message.in
@@ -1,5 +1,5 @@
For the port to work properly you must copy the file
-%%PREFIX%%/%%SQUIRRELDIR%%/plugins/notes/config.php.sample
+%%SQUIRRELDIR%%/plugins/notes/config.php.sample
to
-%%PREFIX%%/%%SQUIRRELDIR%%/plugins/notes/config.php
+%%SQUIRRELDIR%%/plugins/notes/config.php
and edit the configuration to meet your needs.