aboutsummaryrefslogtreecommitdiff
path: root/mail/squirrelmail-notify-plugin
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-03-20 20:49:15 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-03-20 20:49:15 +0000
commitdd5aeb37609b0219663225c01bb21e3f0d8090cc (patch)
treeddc4b0e493419c02cd4dfe6c0c2fbcee7d1ff8e2 /mail/squirrelmail-notify-plugin
parentb678a81e598d69d32a6dd6a6c396170c9996e5bb (diff)
downloadports-dd5aeb37609b0219663225c01bb21e3f0d8090cc.tar.gz
ports-dd5aeb37609b0219663225c01bb21e3f0d8090cc.zip
Notes
Diffstat (limited to 'mail/squirrelmail-notify-plugin')
-rw-r--r--mail/squirrelmail-notify-plugin/Makefile72
-rw-r--r--mail/squirrelmail-notify-plugin/distinfo3
-rw-r--r--mail/squirrelmail-notify-plugin/pkg-descr6
-rw-r--r--mail/squirrelmail-notify-plugin/pkg-plist10
4 files changed, 91 insertions, 0 deletions
diff --git a/mail/squirrelmail-notify-plugin/Makefile b/mail/squirrelmail-notify-plugin/Makefile
new file mode 100644
index 000000000000..52dd482552d8
--- /dev/null
+++ b/mail/squirrelmail-notify-plugin/Makefile
@@ -0,0 +1,72 @@
+# New ports collection makefile for: squirrelmail-notify-plugin
+# Date created: 10 Feb 2006
+# Whom: Gerrit Beine <gerrit.beine@gmx.de>
+#
+# $FreeBSD$
+
+PORTNAME= squirrelmail-${SQUIRREL_PLUGIN_NAME}-plugin
+PORTVERSION= 1.3
+CATEGORIES= mail www
+MASTER_SITES= http://www.squirrelmail.org/plugins/
+DISTNAME= ${SQUIRREL_PLUGIN_NAME}_${PORTVERSION:S/./_/g}
+DIST_SUBDIR= squirrelmail
+
+MAINTAINER= gerrit.beine@gmx.de
+COMMENT= Notify when new mail arrives
+
+RUN_DEPENDS= ${SQUIRRELDIR}/index.php:${PORTSDIR}/mail/squirrelmail \
+ ${SQUIRRELDIR}/plugins/compatibility:${PORTSDIR}/mail/squirrelmail-compatibility-plugin
+
+SQUIRREL_PLUGIN_NAME= notify
+
+.ifdef SQUIRRELDIR
+PLIST_SUB+= SQUIRRELDIR=${SQUIRRELDIR}
+SUB_LIST+= "SQUIRRELDIR=${SQUIRRELDIR}"
+.else
+. ifndef WITHOUT_WWWDIR
+SQUIRRELDIR= ${PREFIX}/www/squirrelmail
+PLIST_SUB+= SQUIRRELDIR=www/squirrelmail
+SUB_LIST+= "SQUIRRELDIR=www/squirrelmail"
+. else
+SQUIRRELDIR= ${PREFIX}/squirrelmail
+PLIST_SUB+= SQUIRRELDIR=squirrelmail
+SUB_LIST+= "SQUIRRELDIR=squirrelmail"
+. endif
+.endif
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+USE_PERL5_BUILD= yes
+USE_PHP= yes
+WANT_PHP_WEB= yes
+
+pre-everything::
+ @${ECHO} ""
+.ifndef WITHOUT_ACTIVATE
+ @${ECHO} "Activating plug-in in SquirrelMail after installation."
+ @${ECHO} "If you don't want to automatically activate the plug-in set"
+ @${ECHO} "WITHOUT_ACTIVATE=yes"
+.else
+ @${ECHO} "NOT Activating plug-in in SquirrelMail after installation."
+ @${ECHO} "If you want to automatically activate the plug-in unset"
+ @${ECHO} "WITHOUT_ACTIVATE"
+.endif
+ @${ECHO} ""
+
+do-install:
+ ${CP} -rp ${WRKSRC}/${SQUIRREL_PLUGIN_NAME} ${SQUIRRELDIR}/plugins
+ ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${SQUIRRELDIR}/plugins/${SQUIRREL_PLUGIN_NAME}
+
+post-install:
+.ifndef WITHOUT_ACTIVATE
+.if exists( ${SQUIRRELDIR}/config/config.php )
+ @${ECHO} "Activating plug-in in SquirrelMail"
+ ${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}
+.endif
+.else
+ @${ECHO} "To activate the plug-in in SquirrelMail use"
+ @${ECHO} "${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}"
+.endif
+ @${ECHO} ""
+
+.include <bsd.port.mk>
diff --git a/mail/squirrelmail-notify-plugin/distinfo b/mail/squirrelmail-notify-plugin/distinfo
new file mode 100644
index 000000000000..dbbea82b6621
--- /dev/null
+++ b/mail/squirrelmail-notify-plugin/distinfo
@@ -0,0 +1,3 @@
+MD5 (squirrelmail/notify_1_3.tar.gz) = 7008be9c855162079927e39926823b7e
+SHA256 (squirrelmail/notify_1_3.tar.gz) = 7bc0f2e19843934d6f34347c81a1fef54db0d3e7127dc86e5161a25e3a415210
+SIZE (squirrelmail/notify_1_3.tar.gz) = 16959
diff --git a/mail/squirrelmail-notify-plugin/pkg-descr b/mail/squirrelmail-notify-plugin/pkg-descr
new file mode 100644
index 000000000000..05e3d9844956
--- /dev/null
+++ b/mail/squirrelmail-notify-plugin/pkg-descr
@@ -0,0 +1,6 @@
+A small browser window is displayed to show the number of unread message
+in a users inbox. The page is refreshed at user defined intervals, and will
+restore itself from minimized if there are unread messages,
+optionally playing a sound file. Requires Javascript on the browser.
+
+WWW: http://www.squirrelmail.org
diff --git a/mail/squirrelmail-notify-plugin/pkg-plist b/mail/squirrelmail-notify-plugin/pkg-plist
new file mode 100644
index 000000000000..80be528ddf9a
--- /dev/null
+++ b/mail/squirrelmail-notify-plugin/pkg-plist
@@ -0,0 +1,10 @@
+@unexec if [ -f %D/%%SQUIRRELDIR%%/config/config.php ]; then %D/%%SQUIRRELDIR%%/config/conf.pl --remove-plugin notify; fi
+%%SQUIRRELDIR%%/plugins/notify/copying
+%%SQUIRRELDIR%%/plugins/notify/readme
+%%SQUIRRELDIR%%/plugins/notify/notify.wav
+%%SQUIRRELDIR%%/plugins/notify/focus.php
+%%SQUIRRELDIR%%/plugins/notify/index.php
+%%SQUIRRELDIR%%/plugins/notify/notify.php
+%%SQUIRRELDIR%%/plugins/notify/setup.php
+@dirrm %%SQUIRRELDIR%%/plugins/notify/
+@exec if [ -f %D/%%SQUIRRELDIR%%/config/config.php ]; then %D/%%SQUIRRELDIR%%/config/conf.pl --install-plugin notify; fi