aboutsummaryrefslogtreecommitdiff
path: root/mail/squirrelmail-plugins/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-05-03 12:42:57 +0000
committerMathieu Arnold <mat@FreeBSD.org>2018-05-03 12:42:57 +0000
commit6114ed0e2a7abc30120c447262847ec897b4634f (patch)
treecb36268371cd75a9ce3231aee0344c05869d6ce1 /mail/squirrelmail-plugins/Makefile
parent83f87c281899fd55afe8b42ffe9d30a38e7e9247 (diff)
downloadports-6114ed0e2a7abc30120c447262847ec897b4634f.tar.gz
ports-6114ed0e2a7abc30120c447262847ec897b4634f.zip
Notes
Diffstat (limited to 'mail/squirrelmail-plugins/Makefile')
-rw-r--r--mail/squirrelmail-plugins/Makefile47
1 files changed, 24 insertions, 23 deletions
diff --git a/mail/squirrelmail-plugins/Makefile b/mail/squirrelmail-plugins/Makefile
index e28701181687..b911ef5fcc13 100644
--- a/mail/squirrelmail-plugins/Makefile
+++ b/mail/squirrelmail-plugins/Makefile
@@ -5,6 +5,7 @@ PORTNAME= squirrelmail-plugins
PORTVERSION= 1.0
PORTREVISION= 2
CATEGORIES= mail www
+PKGNAMESUFFIX= ${PHP_PKGNAMESUFFIX}
MAINTAINER= ports@FreeBSD.org
COMMENT= "meta-port" to install SquirrelMail plugins
@@ -16,71 +17,71 @@ OPTIONS_DEFINE= BUTTONS CALENDAR LDAPPW LGAUTH LGNOTES MAILFT MLOGIN \
SQLPW TIMEOUT TMDA VLOGIN WEBSEARCH WETTER
BUTTONS_DESC= Custom (spam/ham/etc.) buttons
-BUTTONS_RUN_DEPENDS= squirrelmail-spam-buttons-plugin>0:mail/squirrelmail-spam-buttons-plugin
+BUTTONS_RUN_DEPENDS= squirrelmail-spam-buttons-plugin${PHP_PKGNAMESUFFIX}>0:mail/squirrelmail-spam-buttons-plugin@${PHP_FLAVOR}
CALENDAR_DESC= Shared Calendars plugin
-CALENDAR_RUN_DEPENDS= squirrelmail-shared_calendars-plugin>0:mail/squirrelmail-shared_calendars-plugin
+CALENDAR_RUN_DEPENDS= squirrelmail-shared_calendars-plugin${PHP_PKGNAMESUFFIX}>0:mail/squirrelmail-shared_calendars-plugin@${PHP_FLAVOR}
LDAPPW_DESC= Change LDAP passwords plugin
-LDAPPW_RUN_DEPENDS= squirrelmail-change_ldappass-plugin>0:mail/squirrelmail-change_ldappass-plugin
+LDAPPW_RUN_DEPENDS= squirrelmail-change_ldappass-plugin${PHP_PKGNAMESUFFIX}>0:mail/squirrelmail-change_ldappass-plugin@${PHP_FLAVOR}
LGAUTH_DESC= HTTP-auth based login plugin
-LGAUTH_RUN_DEPENDS= squirrelmail-login_auth-plugin>0:mail/squirrelmail-login_auth-plugin
+LGAUTH_RUN_DEPENDS= squirrelmail-login_auth-plugin${PHP_PKGNAMESUFFIX}>0:mail/squirrelmail-login_auth-plugin@${PHP_FLAVOR}
LGNOTES_DESC= Notes on login screen plugin
-LGNOTES_RUN_DEPENDS= squirrelmail-login_notes-plugin>0:mail/squirrelmail-login_notes-plugin
+LGNOTES_RUN_DEPENDS= squirrelmail-login_notes-plugin${PHP_PKGNAMESUFFIX}>0:mail/squirrelmail-login_notes-plugin@${PHP_FLAVOR}
MAILFT_DESC= E-mail footer plugin
-MAILFT_RUN_DEPENDS= squirrelmail-email_footer-plugin>0:mail/squirrelmail-email_footer-plugin
+MAILFT_RUN_DEPENDS= squirrelmail-email_footer-plugin${PHP_PKGNAMESUFFIX}>0:mail/squirrelmail-email_footer-plugin@${PHP_FLAVOR}
MLOGIN_DESC= Multilogin plugin
-MLOGIN_RUN_DEPENDS= squirrelmail-multilogin-plugin>0:mail/squirrelmail-multilogin-plugin
+MLOGIN_RUN_DEPENDS= squirrelmail-multilogin-plugin${PHP_PKGNAMESUFFIX}>0:mail/squirrelmail-multilogin-plugin@${PHP_FLAVOR}
NOTES_DESC= Notes plugin
-NOTES_RUN_DEPENDS= squirrelmail-notes-plugin>0:mail/squirrelmail-notes-plugin
+NOTES_RUN_DEPENDS= squirrelmail-notes-plugin${PHP_PKGNAMESUFFIX}>0:mail/squirrelmail-notes-plugin@${PHP_FLAVOR}
NOTIFY_DESC= New mail notify plugin
-NOTIFY_RUN_DEPENDS= squirrelmail-notify-plugin>0:mail/squirrelmail-notify-plugin
+NOTIFY_RUN_DEPENDS= squirrelmail-notify-plugin${PHP_PKGNAMESUFFIX}>0:mail/squirrelmail-notify-plugin@${PHP_FLAVOR}
PUPDATE_DESC= Plugin update check plugin
-PUPDATE_RUN_DEPENDS= squirrelmail-pupdate-plugin>0:mail/squirrelmail-pupdate-plugin
+PUPDATE_RUN_DEPENDS= squirrelmail-pupdate-plugin${PHP_PKGNAMESUFFIX}>0:mail/squirrelmail-pupdate-plugin@${PHP_FLAVOR}
PW4GET_DESC= Password forget plugin
-PW4GET_RUN_DEPENDS= squirrelmail-password_forget-plugin>0:mail/squirrelmail-password_forget-plugin
+PW4GET_RUN_DEPENDS= squirrelmail-password_forget-plugin${PHP_PKGNAMESUFFIX}>0:mail/squirrelmail-password_forget-plugin@${PHP_FLAVOR}
QMADMIN_DESC= Qmailadmin login plugin
-QMADMIN_RUN_DEPENDS= squirrelmail-qmailadmin_login-plugin>0:mail/squirrelmail-qmailadmin_login-plugin
+QMADMIN_RUN_DEPENDS= squirrelmail-qmailadmin_login-plugin${PHP_PKGNAMESUFFIX}>0:mail/squirrelmail-qmailadmin_login-plugin@${PHP_FLAVOR}
QUOTA_DESC= Quota usage plugin
-QUOTA_RUN_DEPENDS= squirrelmail-quota_usage-plugin>0:mail/squirrelmail-quota_usage-plugin
+QUOTA_RUN_DEPENDS= squirrelmail-quota_usage-plugin${PHP_PKGNAMESUFFIX}>0:mail/squirrelmail-quota_usage-plugin@${PHP_FLAVOR}
SASQL_DESC= SpamAssassin SQL plugin
-SASQL_RUN_DEPENDS= squirrelmail-sasql-plugin>0:mail/squirrelmail-sasql-plugin
+SASQL_RUN_DEPENDS= squirrelmail-sasql-plugin${PHP_PKGNAMESUFFIX}>0:mail/squirrelmail-sasql-plugin@${PHP_FLAVOR}
SIEVE_DESC= Sieve Mail Filters plugin
-SIEVE_RUN_DEPENDS= squirrelmail-avelsieve-plugin>0:mail/squirrelmail-avelsieve-plugin
+SIEVE_RUN_DEPENDS= squirrelmail-avelsieve-plugin${PHP_PKGNAMESUFFIX}>0:mail/squirrelmail-avelsieve-plugin@${PHP_FLAVOR}
SLOGIN_DESC= SSL login plugin
-SLOGIN_RUN_DEPENDS= squirrelmail-secure_login-plugin>0:mail/squirrelmail-secure_login-plugin
+SLOGIN_RUN_DEPENDS= squirrelmail-secure_login-plugin${PHP_PKGNAMESUFFIX}>0:mail/squirrelmail-secure_login-plugin@${PHP_FLAVOR}
SQLPW_DESC= Change *SQL passwords plugin
-SQLPW_RUN_DEPENDS= squirrelmail-change-sqlpass-plugin>0:mail/squirrelmail-change_sqlpass-plugin
+SQLPW_RUN_DEPENDS= squirrelmail-change-sqlpass-plugin${PHP_PKGNAMESUFFIX}>0:mail/squirrelmail-change_sqlpass-plugin@${PHP_FLAVOR}
TIMEOUT_DESC= User session timeout plugin
-TIMEOUT_RUN_DEPENDS= squirrelmail-timeout_user-plugin>0:mail/squirrelmail-timeout_user-plugin
+TIMEOUT_RUN_DEPENDS= squirrelmail-timeout_user-plugin${PHP_PKGNAMESUFFIX}>0:mail/squirrelmail-timeout_user-plugin@${PHP_FLAVOR}
TMDA_DESC= TMDA plugin
-TMDA_RUN_DEPENDS= squirrelmail-tmda-plugin>0:mail/squirrelmail-tmda-plugin
+TMDA_RUN_DEPENDS= squirrelmail-tmda-plugin${PHP_PKGNAMESUFFIX}>0:mail/squirrelmail-tmda-plugin@${PHP_FLAVOR}
VLOGIN_DESC= Multi-site-hosting capabilities plugin
-VLOGIN_RUN_DEPENDS= squirrelmail-vlogin-plugin>0:mail/squirrelmail-vlogin-plugin
+VLOGIN_RUN_DEPENDS= squirrelmail-vlogin-plugin${PHP_PKGNAMESUFFIX}>0:mail/squirrelmail-vlogin-plugin@${PHP_FLAVOR}
WEBSEARCH_DESC= Web search engines plugin
-WEBSEARCH_RUN_DEPENDS= squirrelmail-web_search-plugin>0:mail/squirrelmail-websearch-plugin
+WEBSEARCH_RUN_DEPENDS= squirrelmail-web_search-plugin${PHP_PKGNAMESUFFIX}>0:mail/squirrelmail-websearch-plugin@${PHP_FLAVOR}
WETTER_DESC= Weather in Germany plugin
-WETTER_RUN_DEPENDS= squirrelmail-wetteronline-plugin>0:mail/squirrelmail-wetteronline-plugin
+WETTER_RUN_DEPENDS= squirrelmail-wetteronline-plugin${PHP_PKGNAMESUFFIX}>0:mail/squirrelmail-wetteronline-plugin@${PHP_FLAVOR}
-USES= metaport
+USES= metaport php:flavors
.include <bsd.port.mk>