aboutsummaryrefslogtreecommitdiff
path: root/mail/squirrelmail-plugins
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2013-12-08 16:01:01 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2013-12-08 16:01:01 +0000
commit59bc05b7534113e6e7fb9aa44231a6fc29d8f989 (patch)
tree10ed21ebc4e1f1a5418fc952a1c1012bebf35c44 /mail/squirrelmail-plugins
parent5a02a799f31a7990d36e7c40ec27a908979db260 (diff)
downloadports-59bc05b7534113e6e7fb9aa44231a6fc29d8f989.tar.gz
ports-59bc05b7534113e6e7fb9aa44231a6fc29d8f989.zip
Notes
Diffstat (limited to 'mail/squirrelmail-plugins')
-rw-r--r--mail/squirrelmail-plugins/Makefile168
1 files changed, 52 insertions, 116 deletions
diff --git a/mail/squirrelmail-plugins/Makefile b/mail/squirrelmail-plugins/Makefile
index a3fb50b1c545..b02bdfa84bb7 100644
--- a/mail/squirrelmail-plugins/Makefile
+++ b/mail/squirrelmail-plugins/Makefile
@@ -2,10 +2,10 @@
# $FreeBSD$
PORTNAME= squirrelmail-plugins
-PORTVERSION= 1.0
-PORTREVISION= 1
+PORTVERSION= 1.0
+PORTREVISION= 2
CATEGORIES= mail www
-MASTER_SITES= # none
+MASTER_SITES= # none
DISTFILES= # none
MAINTAINER= ports@FreeBSD.org
@@ -14,143 +14,79 @@ COMMENT= A "meta-port" to install SquirrelMail plugins
NO_BUILD= yes
NO_MTREE= yes
-.ifdef SQUIRRELDIR
-PLIST_SUB+= SQUIRRELDIR=${SQUIRRELDIR}
-SUB_LIST+= "SQUIRRELDIR=${SQUIRRELDIR}"
-.else
-.ifndef WITHOUT_WWWDIR
-SQUIRRELDIR= ${PREFIX}/www/squirrelmail
-PLIST_SUB+= SQUIRRELDIR=www/squirrelmail
-SUB_LIST+= "SQUIRRELDIR=www/squirrelmail"
-.else
-SQUIRRELDIR= ${PREFIX}/squirrelmail
-PLIST_SUB+= SQUIRRELDIR=squirrelmail
-SUB_LIST+= "SQUIRRELDIR=squirrelmail"
-.endif
-.endif
-
-OPTIONS_DEFINE= SIEVE CALENDR LDAPPW SQLPW MAILFT LGAUTH LGNOTES \
- MLOGIN NOTES NOTIFY PW4GET PUPDATE QMADMIN QUOTA \
- SASQL BUTTONS SLOGIN TIMEOUT TMDA VLOGIN WEBSRCH \
- WETTER
-SIEVE_DESC= Sieve Mail Filters plugin
-CALENDR_DESC= Shared Calendars plugin
-LDAPPW_DESC= Change LDAP passwords plugin
-SQLPW_DESC= Change *SQL passwords plugin
-MAILFT_DESC= E-mail footer plugin
-LGAUTH_DESC= HTTP-auth based login plugin
-LGNOTES_DESC= Notes on login screen plugin
-MLOGIN_DESC= Multilogin plugin
-NOTES_DESC= Notes plugin
-NOTIFY_DESC= New mail notify plugin
-PW4GET_DESC= Password forget plugin
-PUPDATE_DESC= Plugin update check plugin
-QMADMIN_DESC= Qmailadmin login plugin
-QUOTA_DESC= Quota usage plugin
-SASQL_DESC= SpamAssassin SQL plugin
-BUTTONS_DESC= Custom (spam/ham/etc.) buttons
-SLOGIN_DESC= SSL login plugin
-TIMEOUT_DESC= User session timeout plugin
-TMDA_DESC= TMDA plugin
-VLOGIN_DESC= Multi-site-hosting capabilities plugin
-WEBSRCH_DESC= Web search engines plugin
-WETTER_DESC= Weather in Germany plugin
+SQUIRRELDIR?= ${PREFIX}/www/squirrelmail
-.include <bsd.port.pre.mk>
+OPTIONS_DEFINE= BUTTONS CALENDAR LDAPPW LGAUTH LGNOTES MAILFT MLOGIN \
+ NOTES NOTIFY PUPDATE PW4GET QMADMIN QUOTA SASQL SIEVE SLOGIN \
+ SQLPW TIMEOUT TMDA VLOGIN WEBSEARCH WETTER
-.if ${PORT_OPTIONS:MSIEVE}
-RUN_DEPENDS+= ${SQUIRRELDIR}/plugins/avelsieve:${PORTSDIR}/mail/squirrelmail-avelsieve-plugin
-.endif
+BUTTONS_DESC= Custom (spam/ham/etc.) buttons
+BUTTONS_RUN_DEPENDS= ${SQUIRRELDIR}/plugins/spam_buttons:${PORTSDIR}/mail/squirrelmail-spam-buttons-plugin
-.if ${PORT_OPTIONS:MCALENDR}
-RUN_DEPENDS+= ${SQUIRRELDIR}/plugins/calendar:${PORTSDIR}/mail/squirrelmail-shared_calendars-plugin
-.endif
+CALENDAR_DESC= Shared Calendars plugin
+CALENDAR_RUN_DEPENDS= ${SQUIRRELDIR}/plugins/calendar:${PORTSDIR}/mail/squirrelmail-shared_calendars-plugin
-.if ${PORT_OPTIONS:MLDAPPW}
-RUN_DEPENDS+= ${SQUIRRELDIR}/plugins/change_ldappass:${PORTSDIR}/mail/squirrelmail-change_ldappass-plugin
-.endif
+LDAPPW_DESC= Change LDAP passwords plugin
+LDAPPW_RUN_DEPENDS= ${SQUIRRELDIR}/plugins/change_ldappass:${PORTSDIR}/mail/squirrelmail-change_ldappass-plugin
-.if ${PORT_OPTIONS:MSQLPW}
-RUN_DEPENDS+= ${SQUIRRELDIR}/plugins/change_sqlpass:${PORTSDIR}/mail/squirrelmail-change_sqlpass-plugin
-.endif
+LGAUTH_DESC= HTTP-auth based login plugin
+LGAUTH_RUN_DEPENDS= ${SQUIRRELDIR}/plugins/login_auth:${PORTSDIR}/mail/squirrelmail-login_auth-plugin
-.if ${PORT_OPTIONS:MMAILFT}
-RUN_DEPENDS+= ${SQUIRRELDIR}/plugins/email_footer:${PORTSDIR}/mail/squirrelmail-email_footer-plugin
-.endif
+LGNOTES_DESC= Notes on login screen plugin
+LGNOTES_RUN_DEPENDS= ${SQUIRRELDIR}/plugins/login_notes:${PORTSDIR}/mail/squirrelmail-login_notes-plugin
-.if ${PORT_OPTIONS:MLGAUTH}
-RUN_DEPENDS+= ${SQUIRRELDIR}/plugins/login_auth:${PORTSDIR}/mail/squirrelmail-login_auth-plugin
-.endif
+MAILFT_DESC= E-mail footer plugin
+MAILFT_RUN_DEPENDS= ${SQUIRRELDIR}/plugins/email_footer:${PORTSDIR}/mail/squirrelmail-email_footer-plugin
-.if ${PORT_OPTIONS:MLGNOTES}
-RUN_DEPENDS+= ${SQUIRRELDIR}/plugins/login_notes:${PORTSDIR}/mail/squirrelmail-login_notes-plugin
-.endif
+MLOGIN_DESC= Multilogin plugin
+MLOGIN_RUN_DEPENDS= ${SQUIRRELDIR}/plugins/multilogin:${PORTSDIR}/mail/squirrelmail-multilogin-plugin
-.if ${PORT_OPTIONS:MMLOGIN}
-RUN_DEPENDS+= ${SQUIRRELDIR}/plugins/multilogin:${PORTSDIR}/mail/squirrelmail-multilogin-plugin
-.endif
-# requires compatibility1 plugin - breaks other plugins
-#.if ${PORT_OPTIONS:MNEWUSER}
-#RUN_DEPENDS+= ${SQUIRRELDIR}/plugins/newuser_wiz:${PORTSDIR}/mail/squirrelmail-newuser_wiz-plugin
-#.endif
+NOTES_DESC= Notes plugin
+NOTES_RUN_DEPENDS= ${SQUIRRELDIR}/plugins/notes:${PORTSDIR}/mail/squirrelmail-notes-plugin
-.if ${PORT_OPTIONS:MNOTES}
-RUN_DEPENDS+= ${SQUIRRELDIR}/plugins/notes:${PORTSDIR}/mail/squirrelmail-notes-plugin
-.endif
+NOTIFY_DESC= New mail notify plugin
+NOTIFY_RUN_DEPENDS= ${SQUIRRELDIR}/plugins/notify:${PORTSDIR}/mail/squirrelmail-notify-plugin
-.if ${PORT_OPTIONS:MNOTIFY}
-RUN_DEPENDS+= ${SQUIRRELDIR}/plugins/notify:${PORTSDIR}/mail/squirrelmail-notify-plugin
-.endif
+PUPDATE_DESC= Plugin update check plugin
+PUPDATE_RUN_DEPENDS= ${SQUIRRELDIR}/plugins/pupdate:${PORTSDIR}/mail/squirrelmail-pupdate-plugin
-.if ${PORT_OPTIONS:MPW4GET}
-RUN_DEPENDS+= ${SQUIRRELDIR}/plugins/password_forget:${PORTSDIR}/mail/squirrelmail-password_forget-plugin
-.endif
+PW4GET_DESC= Password forget plugin
+PW4GET_RUN_DEPENDS= ${SQUIRRELDIR}/plugins/password_forget:${PORTSDIR}/mail/squirrelmail-password_forget-plugin
-.if ${PORT_OPTIONS:MPUPDATE}
-RUN_DEPENDS+= ${SQUIRRELDIR}/plugins/pupdate:${PORTSDIR}/mail/squirrelmail-pupdate-plugin
-.endif
+QMADMIN_DESC= Qmailadmin login plugin
+QMADMIN_RUN_DEPENDS= ${SQUIRRELDIR}/plugins/qmailadmin_login:${PORTSDIR}/mail/squirrelmail-qmailadmin_login-plugin
-.if ${PORT_OPTIONS:MQMADMIN}
-RUN_DEPENDS+= ${SQUIRRELDIR}/plugins/qmailadmin_login:${PORTSDIR}/mail/squirrelmail-qmailadmin_login-plugin
-.endif
+QUOTA_DESC= Quota usage plugin
+QUOTA_RUN_DEPENDS= ${SQUIRRELDIR}/plugins/quota_usage:${PORTSDIR}/mail/squirrelmail-quota_usage-plugin
-.if ${PORT_OPTIONS:MQUOTA}
-RUN_DEPENDS+= ${SQUIRRELDIR}/plugins/quota_usage:${PORTSDIR}/mail/squirrelmail-quota_usage-plugin
-.endif
+SASQL_DESC= SpamAssassin SQL plugin
+SASQL_RUN_DEPENDS= ${SQUIRRELDIR}/plugins/sasql:${PORTSDIR}/mail/squirrelmail-sasql-plugin
-.if ${PORT_OPTIONS:MSASQL}
-RUN_DEPENDS+= ${SQUIRRELDIR}/plugins/sasql:${PORTSDIR}/mail/squirrelmail-sasql-plugin
-.endif
+SIEVE_DESC= Sieve Mail Filters plugin
+SIEVE_RUN_DEPENDS= ${SQUIRRELDIR}/plugins/avelsieve:${PORTSDIR}/mail/squirrelmail-avelsieve-plugin
-.if ${PORT_OPTIONS:MBUTTONS}
-RUN_DEPENDS+= ${SQUIRRELDIR}/plugins/spam_buttons:${PORTSDIR}/mail/squirrelmail-spam-buttons-plugin
-.endif
+SLOGIN_DESC= SSL login plugin
+SLOGIN_RUN_DEPENDS= ${SQUIRRELDIR}/plugins/secure_login:${PORTSDIR}/mail/squirrelmail-secure_login-plugin
-.if ${PORT_OPTIONS:MSLOGIN}
-RUN_DEPENDS+= ${SQUIRRELDIR}/plugins/secure_login:${PORTSDIR}/mail/squirrelmail-secure_login-plugin
-.endif
+SQLPW_DESC= Change *SQL passwords plugin
+SQLPW_RUN_DEPENDS= ${SQUIRRELDIR}/plugins/change_sqlpass:${PORTSDIR}/mail/squirrelmail-change_sqlpass-plugin
-.if ${PORT_OPTIONS:MTIMEOUT}
-RUN_DEPENDS+= ${SQUIRRELDIR}/plugins/timeout_user:${PORTSDIR}/mail/squirrelmail-timeout_user-plugin
-.endif
+TIMEOUT_DESC= User session timeout plugin
+TIMEOUT_RUN_DEPENDS= ${SQUIRRELDIR}/plugins/timeout_user:${PORTSDIR}/mail/squirrelmail-timeout_user-plugin
-.if ${PORT_OPTIONS:MTMDA}
-RUN_DEPENDS+= ${SQUIRRELDIR}/plugins/tmdatools:${PORTSDIR}/mail/squirrelmail-tmda-plugin
-.endif
+TMDA_DESC= TMDA plugin
+TMDA_RUN_DEPENDS= ${SQUIRRELDIR}/plugins/tmdatools:${PORTSDIR}/mail/squirrelmail-tmda-plugin
-.if ${PORT_OPTIONS:MVLOGIN}
-RUN_DEPENDS+= ${SQUIRRELDIR}/plugins/vlogin:${PORTSDIR}/mail/squirrelmail-vlogin-plugin
-.endif
+VLOGIN_DESC= Multi-site-hosting capabilities plugin
+VLOGIN_RUN_DEPENDS= ${SQUIRRELDIR}/plugins/vlogin:${PORTSDIR}/mail/squirrelmail-vlogin-plugin
-.if ${PORT_OPTIONS:MWEBSRCH}
-RUN_DEPENDS+= ${SQUIRRELDIR}/plugins/web_search:${PORTSDIR}/mail/squirrelmail-websearch-plugin
-.endif
+WEBSEARCH_DESC= Web search engines plugin
+WEBSEARCH_RUN_DEPENDS= ${SQUIRRELDIR}/plugins/web_search:${PORTSDIR}/mail/squirrelmail-websearch-plugin
-.if ${PORT_OPTIONS:MWETTER}
-RUN_DEPENDS+= ${SQUIRRELDIR}/plugins/wetteronline:${PORTSDIR}/mail/squirrelmail-wetteronline-plugin
-.endif
+WETTER_DESC= Weather in Germany plugin
+WETTER_RUN_DEPENDS= ${SQUIRRELDIR}/plugins/wetteronline:${PORTSDIR}/mail/squirrelmail-wetteronline-plugin
do-install: build
@${DO_NADA}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>