aboutsummaryrefslogtreecommitdiff
path: root/mail/squirrelmail-plugins
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-06-13 05:55:02 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-06-13 05:55:02 +0000
commit7da39d11c2a4d3613e19a4dc6a562337ba1bfacd (patch)
tree06c1fcce4e4bd9e8bdce472e8eca4f4a467896ca /mail/squirrelmail-plugins
parentc2894a8bc4d59836f188e71d0024673d696c7ec8 (diff)
downloadports-7da39d11c2a4d3613e19a4dc6a562337ba1bfacd.tar.gz
ports-7da39d11c2a4d3613e19a4dc6a562337ba1bfacd.zip
Notes
Diffstat (limited to 'mail/squirrelmail-plugins')
-rw-r--r--mail/squirrelmail-plugins/Makefile95
1 files changed, 49 insertions, 46 deletions
diff --git a/mail/squirrelmail-plugins/Makefile b/mail/squirrelmail-plugins/Makefile
index da581b96cff3..9ab084d052f2 100644
--- a/mail/squirrelmail-plugins/Makefile
+++ b/mail/squirrelmail-plugins/Makefile
@@ -31,121 +31,124 @@ SUB_LIST+= "SQUIRRELDIR=squirrelmail"
.endif
.endif
-OPTIONS= SIEVE "Sieve Mail Filters plugin" off \
- CALENDR "Shared Calendars plugin" off \
- LDAPPW "Change LDAP passwords plugin" off \
- SQLPW "Change *SQL passwords plugin" off \
- MAILFT "E-mail footer plugin" off \
- LGAUTH "HTTP-auth based login plugin" off \
- LGNOTES "Notes on login screen plugin" off \
- MLOGIN "Multilogin plugin" off \
- NOTES "Notes plugin" off \
- NOTIFY "New mail notify plugin" off \
- PW4GET "Password forget plugin" off \
- PUPDATE "Plugin update check plugin" off \
- QMADMIN "Qmailadmin login plugin" off \
- QUOTA "Quota usage plugin" off \
- SASQL "SpamAssassin SQL plugin" off \
- BUTTONS "Custom (spam/ham/etc.) buttons" off \
- SLOGIN "SSL login plugin" off \
- TIMEOUT "User session timeout plugin" off \
- TMDA "TMDA plugin" off \
- VLOGIN "Multi-site-hosting capabilities plugin" off \
- WEBSRCH "Web search engines plugin" off \
- WETTER "Weather in Germany plugin" off
-# NEWUSER "New user wizard plugin" off
+OPTIONS_DEFINE= SIEVE CALENDR LDAPPW SQLPW MAILFT LGAUTH LGNOTES \
+ MLOGIN NOTES NOTIFY PW4GET PUPDATE QMADMIN QUOTA \
+ SASQL BUTTONS SLOGIN TIMEOUT TMDA VLOGIN WEBSRCH \
+ WETTER
+SIEVE_DESC= Sieve Mail Filters plugin
+CALENDR_DESC= Shared Calendars plugin
+LDAPPW_DESC= Change LDAP passwords plugin
+SQLPW_DESC= Change *SQL passwords plugin
+MAILFT_DESC= E-mail footer plugin
+LGAUTH_DESC= HTTP-auth based login plugin
+LGNOTES_DESC= Notes on login screen plugin
+MLOGIN_DESC= Multilogin plugin
+NOTES_DESC= Notes plugin
+NOTIFY_DESC= New mail notify plugin
+PW4GET_DESC= Password forget plugin
+PUPDATE_DESC= Plugin update check plugin
+QMADMIN_DESC= Qmailadmin login plugin
+QUOTA_DESC= Quota usage plugin
+SASQL_DESC= SpamAssassin SQL plugin
+BUTTONS_DESC= Custom (spam/ham/etc.) buttons
+SLOGIN_DESC= SSL login plugin
+TIMEOUT_DESC= User session timeout plugin
+TMDA_DESC= TMDA plugin
+VLOGIN_DESC= Multi-site-hosting capabilities plugin
+WEBSRCH_DESC= Web search engines plugin
+WETTER_DESC= Weather in Germany plugin
.include <bsd.port.pre.mk>
-.if !defined(WITHOUT_SIEVE) || defined(WITH_SIEVE)
+.if ${PORT_OPTIONS:MSIEVE}
RUN_DEPENDS+= ${SQUIRRELDIR}/plugins/avelsieve:${PORTSDIR}/mail/squirrelmail-avelsieve-plugin
.endif
-.if !defined(WITHOUT_CALENDR) || defined(WITH_CALENDR)
+.if ${PORT_OPTIONS:MCALENDR}
RUN_DEPENDS+= ${SQUIRRELDIR}/plugins/calendar:${PORTSDIR}/mail/squirrelmail-shared_calendars-plugin
.endif
-.if !defined(WITHOUT_LDAPPW) || defined(WITH_LDAPPW)
+.if ${PORT_OPTIONS:MLDAPPW}
RUN_DEPENDS+= ${SQUIRRELDIR}/plugins/change_ldappass:${PORTSDIR}/mail/squirrelmail-change_ldappass-plugin
.endif
-.if !defined(WITHOUT_SQLPW) || defined(WITH_SQLPW)
+.if ${PORT_OPTIONS:MSQLPW}
RUN_DEPENDS+= ${SQUIRRELDIR}/plugins/change_sqlpass:${PORTSDIR}/mail/squirrelmail-change_sqlpass-plugin
.endif
-.if !defined(WITHOUT_MAILFT) || defined(WITH_MAILFT)
+.if ${PORT_OPTIONS:MMAILFT}
RUN_DEPENDS+= ${SQUIRRELDIR}/plugins/email_footer:${PORTSDIR}/mail/squirrelmail-email_footer-plugin
.endif
-.if !defined(WITHOUT_LGAUTH) || defined(WITH_LGAUTH)
+.if ${PORT_OPTIONS:MLGAUTH}
RUN_DEPENDS+= ${SQUIRRELDIR}/plugins/login_auth:${PORTSDIR}/mail/squirrelmail-login_auth-plugin
.endif
-.if !defined(WITHOUT_LGNOTES) || defined(WITH_LGNOTES)
+.if ${PORT_OPTIONS:MLGNOTES}
RUN_DEPENDS+= ${SQUIRRELDIR}/plugins/login_notes:${PORTSDIR}/mail/squirrelmail-login_notes-plugin
.endif
-.if !defined(WITHOUT_MLOGIN) || defined(WITH_MLOGIN)
+.if ${PORT_OPTIONS:MMLOGIN}
RUN_DEPENDS+= ${SQUIRRELDIR}/plugins/multilogin:${PORTSDIR}/mail/squirrelmail-multilogin-plugin
.endif
# requires compatibility1 plugin - breaks other plugins
-#.if !defined(WITHOUT_NEWUSER) || defined(WITH_NEWUSER)
+#.if ${PORT_OPTIONS:MNEWUSER}
#RUN_DEPENDS+= ${SQUIRRELDIR}/plugins/newuser_wiz:${PORTSDIR}/mail/squirrelmail-newuser_wiz-plugin
#.endif
-.if !defined(WITHOUT_NOTES) || defined(WITH_NOTES)
+.if ${PORT_OPTIONS:MNOTES}
RUN_DEPENDS+= ${SQUIRRELDIR}/plugins/notes:${PORTSDIR}/mail/squirrelmail-notes-plugin
.endif
-.if !defined(WITHOUT_NOTIFY) || defined(WITH_NOTIFY)
+.if ${PORT_OPTIONS:MNOTIFY}
RUN_DEPENDS+= ${SQUIRRELDIR}/plugins/notify:${PORTSDIR}/mail/squirrelmail-notify-plugin
.endif
-.if !defined(WITHOUT_PW4GET) || defined(WITH_PW4GET)
+.if ${PORT_OPTIONS:MPW4GET}
RUN_DEPENDS+= ${SQUIRRELDIR}/plugins/password_forget:${PORTSDIR}/mail/squirrelmail-password_forget-plugin
.endif
-.if !defined(WITHOUT_PUPDATE) || defined(WITH_PUPDATE)
+.if ${PORT_OPTIONS:MPUPDATE}
RUN_DEPENDS+= ${SQUIRRELDIR}/plugins/pupdate:${PORTSDIR}/mail/squirrelmail-pupdate-plugin
.endif
-.if !defined(WITHOUT_QMADMIN) || defined(WITH_QMADMIN)
+.if ${PORT_OPTIONS:MQMADMIN}
RUN_DEPENDS+= ${SQUIRRELDIR}/plugins/qmailadmin_login:${PORTSDIR}/mail/squirrelmail-qmailadmin_login-plugin
.endif
-.if !defined(WITHOUT_QUOTA) || defined(WITH_QUOTA)
+.if ${PORT_OPTIONS:MQUOTA}
RUN_DEPENDS+= ${SQUIRRELDIR}/plugins/quota_usage:${PORTSDIR}/mail/squirrelmail-quota_usage-plugin
.endif
-.if !defined(WITHOUT_SASQL) || defined(WITH_SASQL)
+.if ${PORT_OPTIONS:MSASQL}
RUN_DEPENDS+= ${SQUIRRELDIR}/plugins/sasql:${PORTSDIR}/mail/squirrelmail-sasql-plugin
.endif
-.if !defined(WITHOUT_BUTTONS) || defined(WITH_BUTTONS)
+.if ${PORT_OPTIONS:MBUTTONS}
RUN_DEPENDS+= ${SQUIRRELDIR}/plugins/spam_buttons:${PORTSDIR}/mail/squirrelmail-spam-buttons-plugin
.endif
-.if !defined(WITHOUT_SLOGIN) || defined(WITH_SLOGIN)
+.if ${PORT_OPTIONS:MSLOGIN}
RUN_DEPENDS+= ${SQUIRRELDIR}/plugins/secure_login:${PORTSDIR}/mail/squirrelmail-secure_login-plugin
.endif
-.if !defined(WITHOUT_TIMEOUT) || defined(WITH_TIMEOUT)
+.if ${PORT_OPTIONS:MTIMEOUT}
RUN_DEPENDS+= ${SQUIRRELDIR}/plugins/timeout_user:${PORTSDIR}/mail/squirrelmail-timeout_user-plugin
.endif
-.if !defined(WITHOUT_TMDA) || defined(WITH_TMDA)
+.if ${PORT_OPTIONS:MTMDA}
RUN_DEPENDS+= ${SQUIRRELDIR}/plugins/tmdatools:${PORTSDIR}/mail/squirrelmail-tmda-plugin
.endif
-.if !defined(WITHOUT_VLOGIN) || defined(WITH_VLOGIN)
+.if ${PORT_OPTIONS:MVLOGIN}
RUN_DEPENDS+= ${SQUIRRELDIR}/plugins/vlogin:${PORTSDIR}/mail/squirrelmail-vlogin-plugin
.endif
-.if !defined(WITHOUT_WEBSRCH) || defined(WITH_WEBSRCH)
+.if ${PORT_OPTIONS:MWEBSRCH}
RUN_DEPENDS+= ${SQUIRRELDIR}/plugins/web_search:${PORTSDIR}/mail/squirrelmail-websearch-plugin
.endif
-.if !defined(WITHOUT_WETTER) || defined(WITH_WETTER)
+.if ${PORT_OPTIONS:MWETTER}
RUN_DEPENDS+= ${SQUIRRELDIR}/plugins/wetteronline:${PORTSDIR}/mail/squirrelmail-wetteronline-plugin
.endif