aboutsummaryrefslogtreecommitdiff
path: root/mail/squirrelmail-timeout_user-plugin
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2006-07-11 14:56:17 +0000
committerRenato Botelho <garga@FreeBSD.org>2006-07-11 14:56:17 +0000
commit7ed90ed42a33181706c43c075964472b586a5930 (patch)
treed8da733c4696ef5a21e827d3ea370bec9624654e /mail/squirrelmail-timeout_user-plugin
parentfb773d98ad9e1e7beb8b380a457df5fa29ae4f69 (diff)
downloadports-7ed90ed42a33181706c43c075964472b586a5930.tar.gz
ports-7ed90ed42a33181706c43c075964472b586a5930.zip
Notes
Diffstat (limited to 'mail/squirrelmail-timeout_user-plugin')
-rw-r--r--mail/squirrelmail-timeout_user-plugin/Makefile73
-rw-r--r--mail/squirrelmail-timeout_user-plugin/distinfo3
-rw-r--r--mail/squirrelmail-timeout_user-plugin/pkg-descr6
-rw-r--r--mail/squirrelmail-timeout_user-plugin/pkg-plist10
4 files changed, 92 insertions, 0 deletions
diff --git a/mail/squirrelmail-timeout_user-plugin/Makefile b/mail/squirrelmail-timeout_user-plugin/Makefile
new file mode 100644
index 000000000000..a74efda501b6
--- /dev/null
+++ b/mail/squirrelmail-timeout_user-plugin/Makefile
@@ -0,0 +1,73 @@
+# New ports collection makefile for: squirrelmail-timeout_user-plugin
+# Date created: 2006-07-07
+# Whom: Thomas Abthorpe <thomas@goodking.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= squirrelmail-${SQUIRREL_PLUGIN_NAME}-plugin
+PORTVERSION= 1.1.1
+CATEGORIES= mail www
+MASTER_SITES= http://www.squirrelmail.org/plugins/
+DISTNAME= ${SQUIRREL_PLUGIN_NAME}-${PORTVERSION}-0.5
+DIST_SUBDIR= squirrelmail
+
+MAINTAINER= thomas@goodking.ca
+COMMENT= Automatically logs a user out if they're idle for a set amount of time
+
+RUN_DEPENDS= ${SQUIRRELDIR}/index.php:${PORTSDIR}/mail/squirrelmail \
+ ${SQUIRRELDIR}/plugins/compatibility:${PORTSDIR}/mail/squirrelmail-compatibility-plugin
+
+SQUIRREL_PLUGIN_NAME= timeout_user
+
+.ifdef SQUIRRELDIR
+PLIST_SUB+= SQUIRRELDIR=${SQUIRRELDIR}
+SUB_LIST+= "SQUIRRELDIR=${SQUIRRELDIR}"
+.else
+.ifndef WITHOUT_WWWDIR
+SQUIRRELDIR= ${PREFIX}/www/squirrelmail
+PLIST_SUB+= SQUIRRELDIR=www/squirrelmail
+SUB_LIST+= "SQUIRRELDIR=www/squirrelmail"
+.else
+SQUIRRELDIR= ${PREFIX}/squirrelmail
+PLIST_SUB+= SQUIRRELDIR=squirrelmail
+SUB_LIST+= "SQUIRRELDIR=squirrelmail"
+.endif
+.endif
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+USE_PERL5_BUILD= yes
+USE_PHP= yes
+WANT_PHP_WEB= yes
+
+pre-everything::
+ @${ECHO} ""
+.ifndef WITHOUT_ACTIVATE
+ @${ECHO} "Activating plug-in in SquirrelMail after installation."
+ @${ECHO} "If you don't want to automatically activate the plug-in set"
+ @${ECHO} "WITHOUT_ACTIVATE=yes"
+.else
+ @${ECHO} "NOT Activating plug-in in SquirrelMail after installation."
+ @${ECHO} "If you want to automatically activate the plug-in unset"
+ @${ECHO} "WITHOUT_ACTIVATE"
+.endif
+ @${ECHO} ""
+
+do-install:
+ ${CP} -rp ${WRKSRC}/${SQUIRREL_PLUGIN_NAME} ${SQUIRRELDIR}/plugins
+ ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${SQUIRRELDIR}/plugins/${SQUIRREL_PLUGIN_NAME}
+
+post-install:
+.ifndef WITHOUT_ACTIVATE
+.if exists( ${SQUIRRELDIR}/config/config.php )
+ @${ECHO} "Activating plug-in in SquirrelMail"
+ ${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}
+.endif
+.else
+ @${ECHO} "To activate the plug-in in SquirrelMail use"
+ @${ECHO} "${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}"
+.endif
+ @${ECHO} ""
+
+.include <bsd.port.mk>
diff --git a/mail/squirrelmail-timeout_user-plugin/distinfo b/mail/squirrelmail-timeout_user-plugin/distinfo
new file mode 100644
index 000000000000..a3f92a5143b6
--- /dev/null
+++ b/mail/squirrelmail-timeout_user-plugin/distinfo
@@ -0,0 +1,3 @@
+MD5 (squirrelmail/timeout_user-1.1.1-0.5.tar.gz) = 43bf06a6f07da5354e87701681c5eba7
+SHA256 (squirrelmail/timeout_user-1.1.1-0.5.tar.gz) = 086486fbcad56bdd52067c6b95ac73fdfa8bfd47c467af0ceabeb4bd04142bc8
+SIZE (squirrelmail/timeout_user-1.1.1-0.5.tar.gz) = 4101
diff --git a/mail/squirrelmail-timeout_user-plugin/pkg-descr b/mail/squirrelmail-timeout_user-plugin/pkg-descr
new file mode 100644
index 000000000000..87d8ea138e86
--- /dev/null
+++ b/mail/squirrelmail-timeout_user-plugin/pkg-descr
@@ -0,0 +1,6 @@
+This automatically logs a user out if they're idle for a set amount
+of time. We define 'idle' as having not refreshed the right-hand
+frame. The administrator can set a standard time for all users or
+allow users to set their own timeout values.
+
+WWW: http://www.squirrelmail.org/plugin_view.php?id=38
diff --git a/mail/squirrelmail-timeout_user-plugin/pkg-plist b/mail/squirrelmail-timeout_user-plugin/pkg-plist
new file mode 100644
index 000000000000..5276d714db25
--- /dev/null
+++ b/mail/squirrelmail-timeout_user-plugin/pkg-plist
@@ -0,0 +1,10 @@
+@unexec if [ -f %D/%%SQUIRRELDIR%%/config/config.php ]; then %D/%%SQUIRRELDIR%%/config/conf.pl --remove-plugin pupdate; fi
+%%SQUIRRELDIR%%/plugins/timeout_user/version
+%%SQUIRRELDIR%%/plugins/timeout_user/README
+%%SQUIRRELDIR%%/plugins/timeout_user/index.php
+%%SQUIRRELDIR%%/plugins/timeout_user/setup.php
+%%SQUIRRELDIR%%/plugins/timeout_user/INSTALL
+%%SQUIRRELDIR%%/plugins/timeout_user/functions.php
+%%SQUIRRELDIR%%/plugins/timeout_user/config.php
+@dirrm %%SQUIRRELDIR%%/plugins/timeout_user
+@exec if [ -f %D/%%SQUIRRELDIR%%/config/config.php ]; then %D/%%SQUIRRELDIR%%/config/conf.pl --install-plugin pupdate; fi