aboutsummaryrefslogtreecommitdiff
path: root/mail/squirrelmail-unsafe_image_rules-plugin
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2008-02-17 15:18:52 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2008-02-17 15:18:52 +0000
commitf1d93f4c6d849e3dded7e35ca028c26cad81be7e (patch)
treed948a760ed205c459dd94f0ec643d9c898f40f3a /mail/squirrelmail-unsafe_image_rules-plugin
parent00f15347d37be7952cf50382fe644d4bf937fdac (diff)
downloadports-f1d93f4c6d849e3dded7e35ca028c26cad81be7e.tar.gz
ports-f1d93f4c6d849e3dded7e35ca028c26cad81be7e.zip
Notes
Diffstat (limited to 'mail/squirrelmail-unsafe_image_rules-plugin')
-rw-r--r--mail/squirrelmail-unsafe_image_rules-plugin/Makefile82
-rw-r--r--mail/squirrelmail-unsafe_image_rules-plugin/distinfo3
-rw-r--r--mail/squirrelmail-unsafe_image_rules-plugin/files/pkg-message.in7
-rw-r--r--mail/squirrelmail-unsafe_image_rules-plugin/pkg-descr20
-rw-r--r--mail/squirrelmail-unsafe_image_rules-plugin/pkg-plist14
5 files changed, 126 insertions, 0 deletions
diff --git a/mail/squirrelmail-unsafe_image_rules-plugin/Makefile b/mail/squirrelmail-unsafe_image_rules-plugin/Makefile
new file mode 100644
index 000000000000..7191f7563416
--- /dev/null
+++ b/mail/squirrelmail-unsafe_image_rules-plugin/Makefile
@@ -0,0 +1,82 @@
+# New ports collection makefile for: squirrelmail-unsafe_image_rules-plugin
+# Date created: 2008-02-16
+# Whom: Ion-Mihai "IOnut" Tetcu <itetcu@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= unsafe_image_rules
+PORTVERSION= 0.8
+CATEGORIES= mail www
+MASTER_SITES= http://www.squirrelmail.org/plugins/
+PKGNAMEPREFIX= squirrelmail-
+PKGNAMESUFFIX= -plugin
+DISTNAME= ${PORTNAME:S/-/_/}.${PORTVERSION}-1.4
+DIST_SUBDIR= squirrelmail
+
+MAINTAINER= itetcu@FreeBSD.org
+COMMENT= Determines what unsafe (web) images will be shown
+
+RUN_DEPENDS= ${SQUIRRELDIR}/index.php:${PORTSDIR}/mail/squirrelmail \
+ ${SQUIRRELDIR}/plugins/compatibility:${PORTSDIR}/mail/squirrelmail-compatibility-plugin
+
+SQUIRREL_PLUGIN_NAME= ${PORTNAME:S/-/_/}
+
+.ifdef SQUIRRELDIR
+PLIST_SUB+= SQUIRRELDIR=${SQUIRRELDIR}
+SUB_LIST+= SQUIRRELDIR=${SQUIRRELDIR}
+.else
+.ifndef WITHOUT_WWWDIR
+SQUIRRELDIR= ${PREFIX}/www/squirrelmail
+PLIST_SUB+= SQUIRRELDIR=www/squirrelmail
+SUB_LIST+= SQUIRRELDIR=www/squirrelmail
+.else
+SQUIRRELDIR= ${PREFIX}/squirrelmail
+PLIST_SUB+= SQUIRRELDIR=squirrelmail
+SUB_LIST+= SQUIRRELDIR=squirrelmail
+.endif
+.endif
+PLIST_SUB+= SQUIRREL_PLUGIN_NAME=${SQUIRREL_PLUGIN_NAME}
+
+SUB_FILES+= pkg-message
+SUB_LIST+= SQUIRREL_PLUGIN_NAME=${SQUIRREL_PLUGIN_NAME}
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+USE_PERL5_BUILD= yes
+USE_PHP= yes
+WANT_PHP_WEB= yes
+
+.include <bsd.port.pre.mk>
+
+pre-everything::
+ @${ECHO} ""
+.ifndef WITHOUT_ACTIVATE
+ @${ECHO} "Activating plug-in in SquirrelMail after installation."
+ @${ECHO} "If you don't want to automatically activate the plug-in set"
+ @${ECHO} "WITHOUT_ACTIVATE=yes"
+.else
+ @${ECHO} "NOT Activating plug-in in SquirrelMail after installation."
+ @${ECHO} "If you want to automatically activate the plug-in unset"
+ @${ECHO} "WITHOUT_ACTIVATE"
+.endif
+ @${ECHO} ""
+
+do-install:
+ ${CP} -R ${WRKSRC}/${SQUIRREL_PLUGIN_NAME} ${SQUIRRELDIR}/plugins
+ ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${SQUIRRELDIR}/plugins/${SQUIRREL_PLUGIN_NAME}
+
+post-install:
+.ifndef WITHOUT_ACTIVATE
+.if exists( ${SQUIRRELDIR}/config/config.php )
+ @${ECHO} "Activating plug-in in SquirrelMail"
+ ${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}
+.endif
+.else
+ @${ECHO} "To activate the plug-in in SquirrelMail use"
+ @${ECHO} "${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}"
+.endif
+ @${ECHO} ""
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/mail/squirrelmail-unsafe_image_rules-plugin/distinfo b/mail/squirrelmail-unsafe_image_rules-plugin/distinfo
new file mode 100644
index 000000000000..1a2304bd6e6f
--- /dev/null
+++ b/mail/squirrelmail-unsafe_image_rules-plugin/distinfo
@@ -0,0 +1,3 @@
+MD5 (squirrelmail/unsafe_image_rules.0.8-1.4.tar.gz) = 50b798aeeaa4a0464e9e9d88838dee76
+SHA256 (squirrelmail/unsafe_image_rules.0.8-1.4.tar.gz) = ab5d87afd784eb002a1248e632b293523a82bb42639028b5633f09cc619a87f4
+SIZE (squirrelmail/unsafe_image_rules.0.8-1.4.tar.gz) = 11894
diff --git a/mail/squirrelmail-unsafe_image_rules-plugin/files/pkg-message.in b/mail/squirrelmail-unsafe_image_rules-plugin/files/pkg-message.in
new file mode 100644
index 000000000000..902c57f01aa9
--- /dev/null
+++ b/mail/squirrelmail-unsafe_image_rules-plugin/files/pkg-message.in
@@ -0,0 +1,7 @@
+================================================================
+For the port to work properly you must copy the file
+%%PREFIX%%/%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/config.php.sample
+to
+%%PREFIX%%/%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/config.php
+and edit the configuration to meet your needs.
+================================================================
diff --git a/mail/squirrelmail-unsafe_image_rules-plugin/pkg-descr b/mail/squirrelmail-unsafe_image_rules-plugin/pkg-descr
new file mode 100644
index 000000000000..adaf3a166c1e
--- /dev/null
+++ b/mail/squirrelmail-unsafe_image_rules-plugin/pkg-descr
@@ -0,0 +1,20 @@
+A user may now build a list of rules that will be used to determine if unsafe
+images (that are linked to remote sites) will be shown in HTML messages. If a
+message matches any of the rules and contains images that would normally be
+initially hidden, then they are now shown by default.
+
+The user may choose to always show unsafe images, for all message. This is
+obviously not recommended by the core SquirrelMail Project Team - or they
+wouldn't have built this functionality to begin with ( See the following:
+http://www.squirrelmail.org/wiki/UnsafeImages ).
+
+A new section is added to the options page titled, 'Unsafe Image Rules'. Within
+this page the user may define a number of rules to determine when messages are
+from a trusted source.
+
+These options are very similar to the core message filters plugin. A message
+field (To, From, CC, Subject) can be matched either against a regular
+expression, or simply searched to see if the given string is within the field.
+If a match is found then unsafe images are always shown for this source.
+
+WWW: http://www.squirrelmail.org/plugin_view.php?id=98
diff --git a/mail/squirrelmail-unsafe_image_rules-plugin/pkg-plist b/mail/squirrelmail-unsafe_image_rules-plugin/pkg-plist
new file mode 100644
index 000000000000..3d50f10aa9a8
--- /dev/null
+++ b/mail/squirrelmail-unsafe_image_rules-plugin/pkg-plist
@@ -0,0 +1,14 @@
+@unexec if [ -f %D/%%SQUIRRELDIR%%/config/config.php ]; then %D/%%SQUIRRELDIR%%/config/conf.pl --remove-plugin %%SQUIRREL_PLUGIN_NAME%%; fi
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/INSTALL
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/README
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/add.php
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/config.php.sample
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/functions.php
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/index.php
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/options.php
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/setup.php
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/unsafe_image_rules.pot
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/version
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/xgetpot
+@dirrm %%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%
+@exec if [ -f %D/%%SQUIRRELDIR%%/config/config.php ]; then %D/%%SQUIRRELDIR%%/config/conf.pl --install-plugin %%SQUIRREL_PLUGIN_NAME%%; fi