aboutsummaryrefslogtreecommitdiff
path: root/mail/squirrelmail-user_special_mailboxes-plugin
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2008-02-18 11:33:17 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2008-02-18 11:33:17 +0000
commit3d4d715ad0655cc2dc4533728407c30a8a86c800 (patch)
treeb89280587f550ab183ea15d49ac3486a2f5fd4af /mail/squirrelmail-user_special_mailboxes-plugin
parent73846bb0f35301771e01f6ca26c11e544d94e398 (diff)
downloadports-3d4d715ad0655cc2dc4533728407c30a8a86c800.tar.gz
ports-3d4d715ad0655cc2dc4533728407c30a8a86c800.zip
Notes
Diffstat (limited to 'mail/squirrelmail-user_special_mailboxes-plugin')
-rw-r--r--mail/squirrelmail-user_special_mailboxes-plugin/Makefile78
-rw-r--r--mail/squirrelmail-user_special_mailboxes-plugin/distinfo3
-rw-r--r--mail/squirrelmail-user_special_mailboxes-plugin/pkg-descr6
-rw-r--r--mail/squirrelmail-user_special_mailboxes-plugin/pkg-plist8
4 files changed, 95 insertions, 0 deletions
diff --git a/mail/squirrelmail-user_special_mailboxes-plugin/Makefile b/mail/squirrelmail-user_special_mailboxes-plugin/Makefile
new file mode 100644
index 000000000000..9c3625b005e2
--- /dev/null
+++ b/mail/squirrelmail-user_special_mailboxes-plugin/Makefile
@@ -0,0 +1,78 @@
+# New ports collection makefile for: squirrelmail-user_special_mailboxes-plugin
+# Date created: 2008-02-16
+# Whom: Ion-Mihai "IOnut" Tetcu <itetcu@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= user_special_mailboxes
+PORTVERSION= 0.1
+CATEGORIES= mail www
+MASTER_SITES= http://www.squirrelmail.org/plugins/
+PKGNAMEPREFIX= squirrelmail-
+PKGNAMESUFFIX= -plugin
+DISTNAME= ${PORTNAME:S/-/_/}.${PORTVERSION}-1.4
+DIST_SUBDIR= squirrelmail
+
+MAINTAINER= itetcu@FreeBSD.org
+COMMENT= Lets define folders to be displayed at the top of the folders list
+
+RUN_DEPENDS= ${SQUIRRELDIR}/index.php:${PORTSDIR}/mail/squirrelmail \
+ ${SQUIRRELDIR}/plugins/compatibility:${PORTSDIR}/mail/squirrelmail-compatibility-plugin
+
+SQUIRREL_PLUGIN_NAME= ${PORTNAME:S/-/_/}
+
+.ifdef SQUIRRELDIR
+PLIST_SUB+= SQUIRRELDIR=${SQUIRRELDIR}
+SUB_LIST+= SQUIRRELDIR=${SQUIRRELDIR}
+.else
+.ifndef WITHOUT_WWWDIR
+SQUIRRELDIR= ${PREFIX}/www/squirrelmail
+PLIST_SUB+= SQUIRRELDIR=www/squirrelmail
+SUB_LIST+= SQUIRRELDIR=www/squirrelmail
+.else
+SQUIRRELDIR= ${PREFIX}/squirrelmail
+PLIST_SUB+= SQUIRRELDIR=squirrelmail
+SUB_LIST+= SQUIRRELDIR=squirrelmail
+.endif
+.endif
+PLIST_SUB+= SQUIRREL_PLUGIN_NAME=${SQUIRREL_PLUGIN_NAME}
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+USE_PERL5_BUILD= yes
+USE_PHP= yes
+WANT_PHP_WEB= yes
+
+.include <bsd.port.pre.mk>
+
+pre-everything::
+ @${ECHO} ""
+.ifndef WITHOUT_ACTIVATE
+ @${ECHO} "Activating plug-in in SquirrelMail after installation."
+ @${ECHO} "If you don't want to automatically activate the plug-in set"
+ @${ECHO} "WITHOUT_ACTIVATE=yes"
+.else
+ @${ECHO} "NOT Activating plug-in in SquirrelMail after installation."
+ @${ECHO} "If you want to automatically activate the plug-in unset"
+ @${ECHO} "WITHOUT_ACTIVATE"
+.endif
+ @${ECHO} ""
+
+do-install:
+ ${CP} -R ${WRKSRC}/${SQUIRREL_PLUGIN_NAME} ${SQUIRRELDIR}/plugins
+ ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${SQUIRRELDIR}/plugins/${SQUIRREL_PLUGIN_NAME}
+
+post-install:
+.ifndef WITHOUT_ACTIVATE
+.if exists( ${SQUIRRELDIR}/config/config.php )
+ @${ECHO} "Activating plug-in in SquirrelMail"
+ ${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}
+.endif
+.else
+ @${ECHO} "To activate the plug-in in SquirrelMail use"
+ @${ECHO} "${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}"
+.endif
+ @${ECHO} ""
+
+.include <bsd.port.post.mk>
diff --git a/mail/squirrelmail-user_special_mailboxes-plugin/distinfo b/mail/squirrelmail-user_special_mailboxes-plugin/distinfo
new file mode 100644
index 000000000000..82c42ad83e0d
--- /dev/null
+++ b/mail/squirrelmail-user_special_mailboxes-plugin/distinfo
@@ -0,0 +1,3 @@
+MD5 (squirrelmail/user_special_mailboxes.0.1-1.4.tar.gz) = 52ef69baafdf35f0da09a011e4e1138e
+SHA256 (squirrelmail/user_special_mailboxes.0.1-1.4.tar.gz) = eb7606e77de7f96761770d8234f28bee60f121db63b5886a10f8a27d0527b16c
+SIZE (squirrelmail/user_special_mailboxes.0.1-1.4.tar.gz) = 2899
diff --git a/mail/squirrelmail-user_special_mailboxes-plugin/pkg-descr b/mail/squirrelmail-user_special_mailboxes-plugin/pkg-descr
new file mode 100644
index 000000000000..432dda71c71d
--- /dev/null
+++ b/mail/squirrelmail-user_special_mailboxes-plugin/pkg-descr
@@ -0,0 +1,6 @@
+Allows users to specify a list of additional folders they would like to be
+treated as special, that is that these folders will be shown at the top of the
+folders lists, and in different colour on the left frame (if you have the
+option turned on).
+
+WWW: http://www.squirrelmail.org/plugin_view.php?id=183
diff --git a/mail/squirrelmail-user_special_mailboxes-plugin/pkg-plist b/mail/squirrelmail-user_special_mailboxes-plugin/pkg-plist
new file mode 100644
index 000000000000..da04ae43324f
--- /dev/null
+++ b/mail/squirrelmail-user_special_mailboxes-plugin/pkg-plist
@@ -0,0 +1,8 @@
+@unexec if [ -f %D/%%SQUIRRELDIR%%/config/config.php ]; then %D/%%SQUIRRELDIR%%/config/conf.pl --remove-plugin %%SQUIRREL_PLUGIN_NAME%%; fi
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/INSTALL
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/README
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/set_mailboxes.php
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/setup.php
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/version
+@dirrm %%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%
+@exec if [ -f %D/%%SQUIRRELDIR%%/config/config.php ]; then %D/%%SQUIRRELDIR%%/config/conf.pl --install-plugin %%SQUIRREL_PLUGIN_NAME%%; fi