aboutsummaryrefslogtreecommitdiff
path: root/mail/squirrelmail-vlogin-plugin
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-08-28 15:16:49 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-08-28 15:16:49 +0000
commite1630922bd6f640a126bbc8c26a939c6d9c16b7d (patch)
tree1876a62bdee7c4ff50f3b47d8cc690c1fc6727f5 /mail/squirrelmail-vlogin-plugin
parentf1dff729a78ed759f3c6ca98a7377562b75d264c (diff)
downloadports-e1630922bd6f640a126bbc8c26a939c6d9c16b7d.tar.gz
ports-e1630922bd6f640a126bbc8c26a939c6d9c16b7d.zip
Move plugin installation into the plist, rather than post-install, so
that it will work when installed from binary pkg. Bump PORTREVISION on all plugins for this.
Notes
Notes: svn path=/head/; revision=366415
Diffstat (limited to 'mail/squirrelmail-vlogin-plugin')
-rw-r--r--mail/squirrelmail-vlogin-plugin/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/mail/squirrelmail-vlogin-plugin/Makefile b/mail/squirrelmail-vlogin-plugin/Makefile
index 55dc09ac40b2..2966e48bc661 100644
--- a/mail/squirrelmail-vlogin-plugin/Makefile
+++ b/mail/squirrelmail-vlogin-plugin/Makefile
@@ -3,7 +3,7 @@
PORTNAME= vlogin
PORTVERSION= 3.10.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail www
DISTNAME= ${PORTNAME}-${PORTVERSION}-1.2.7
@@ -19,12 +19,12 @@ OPTIONS_DEFINE= DOCS
# We need to rearrange, install and cleanup documentation pre-install
# because bsd.squirrelmail.mk installs everything under ${WRKSRC}/${PORTNAME}.
pre-install::
- cd ${WRKSRC}/${PORTNAME}/docs \
- && ${RM} .htaccess index.php \
- && ${MKDIR} ${STAGEDIR}${DOCSDIR} \
- && ${COPYTREE_SHARE} \* ${STAGEDIR}${DOCSDIR} \
- && cd ${WRKSRC}/${PORTNAME} \
- && ${RM} -rf README docs
+ ${RM} ${WRKSRC}/${PORTNAME}/docs/.htaccess
+ ${RM} ${WRKSRC}/${PORTNAME}/docs/index.php
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC}/${PORTNAME}/docs && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR})
+ ${RM} -rf ${WRKSRC}/${PORTNAME}/README
+ ${RM} -rf ${WRKSRC}/${PORTNAME}/docs
.include "${.CURDIR}/../squirrelmail/bsd.squirrelmail.mk"
.include <bsd.port.mk>