aboutsummaryrefslogtreecommitdiff
path: root/mail/squirrelmail-websearch-plugin/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-08-10 19:48:06 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-08-10 19:48:06 +0000
commite7f286d693d153ac96f2e6f4475bc6019f32ebf8 (patch)
tree3ace3041217f216a4000fd9da41f4e165470238f /mail/squirrelmail-websearch-plugin/Makefile
parentc242443a3866a61f0c98d0d9bdc2e7f0daa82f18 (diff)
Notes
Diffstat (limited to 'mail/squirrelmail-websearch-plugin/Makefile')
-rw-r--r--mail/squirrelmail-websearch-plugin/Makefile75
1 files changed, 75 insertions, 0 deletions
diff --git a/mail/squirrelmail-websearch-plugin/Makefile b/mail/squirrelmail-websearch-plugin/Makefile
new file mode 100644
index 000000000000..80c0954a2e84
--- /dev/null
+++ b/mail/squirrelmail-websearch-plugin/Makefile
@@ -0,0 +1,75 @@
+# New ports collection makefile for: squirrelmail-websearch-plugin
+# Date created: 10 August
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= squirrelmail-${SQUIRREL_PLUGIN_NAME}-plugin
+PORTVERSION= 0.1.6
+CATEGORIES= mail www
+MASTER_SITES= http://www.squirrelmail.org/plugins/
+DISTNAME= ${SQUIRREL_PLUGIN_NAME}-${PORTVERSION}
+DIST_SUBDIR= squirrelmail
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= Plugin for Websearch
+
+RUN_DEPENDS= ${SQUIRRELDIR}/index.php:${PORTSDIR}/mail/squirrelmail \
+ ${SQUIRRELDIR}/plugins/compatibility:${PORTSDIR}/mail/squirrelmail-compatibility-plugin
+
+SQUIRREL_PLUGIN_NAME= web_search
+
+SUB_FILES= pkg-message
+
+.ifdef SQUIRRELDIR
+PLIST_SUB+= SQUIRRELDIR=${SQUIRRELDIR}
+SUB_LIST+= "SQUIRRELDIR=${SQUIRRELDIR}"
+.else
+. ifndef WITHOUT_WWWDIR
+SQUIRRELDIR= ${PREFIX}/www/squirrelmail
+PLIST_SUB+= SQUIRRELDIR=www/squirrelmail
+SUB_LIST+= "SQUIRRELDIR=www/squirrelmail"
+. else
+SQUIRRELDIR= ${PREFIX}/squirrelmail
+PLIST_SUB+= SQUIRRELDIR=squirrelmail
+SUB_LIST+= "SQUIRRELDIR=squirrelmail"
+. endif
+.endif
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+USE_PERL5_BUILD= yes
+USE_PHP= yes
+WANT_PHP_WEB= yes
+
+pre-everything::
+ @${ECHO} ""
+.ifndef WITHOUT_ACTIVATE
+ @${ECHO} "Activating plug-in in SquirrelMail after installation."
+ @${ECHO} "If you don't want to automatically activate the plug-in set"
+ @${ECHO} "WITHOUT_ACTIVATE=yes"
+.else
+ @${ECHO} "NOT Activating plug-in in SquirrelMail after installation."
+ @${ECHO} "If you want to automatically activate the plug-in unset"
+ @${ECHO} "WITHOUT_ACTIVATE"
+.endif
+ @${ECHO} ""
+
+do-install:
+ ${CP} -rp ${WRKSRC}/${SQUIRREL_PLUGIN_NAME} ${SQUIRRELDIR}/plugins
+ ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${SQUIRRELDIR}/plugins/${SQUIRREL_PLUGIN_NAME}
+
+post-install:
+.ifndef WITHOUT_ACTIVATE
+.if exists( ${SQUIRRELDIR}/config/config.php )
+ @${ECHO} "Activating plug-in in SquirrelMail"
+ ${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}
+.endif
+.else
+ @${ECHO} "To activate the plug-in in SquirrelMail use"
+ @${ECHO} "${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}"
+.endif
+ @${ECHO} ""
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>