aboutsummaryrefslogtreecommitdiff
path: root/mail/squirrelmail
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-07-22 02:00:11 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-07-22 02:00:11 +0000
commit6489506adec80b9f2336a9ad67feaa9546185efd (patch)
treeee7114e53d8c0dafcd2f2c0522c1d11acd37fdec /mail/squirrelmail
parentfd4e15a19f127c287ebcaca6afc4b1f6b5ebd139 (diff)
downloadports-6489506adec80b9f2336a9ad67feaa9546185efd.tar.gz
ports-6489506adec80b9f2336a9ad67feaa9546185efd.zip
Notes
Diffstat (limited to 'mail/squirrelmail')
-rw-r--r--mail/squirrelmail/Makefile13
1 files changed, 12 insertions, 1 deletions
diff --git a/mail/squirrelmail/Makefile b/mail/squirrelmail/Makefile
index 0fd1987e94c8..a2199b209ec3 100644
--- a/mail/squirrelmail/Makefile
+++ b/mail/squirrelmail/Makefile
@@ -16,11 +16,19 @@ COMMENT?= A webmail system which accesses mail over IMAP
CONFLICTS?= ja-squirrelmail-1.*
-USE_PHP= yes
+USE_PHP= session mhash gettext mbstring
WANT_PHP_WEB= yes
USE_BZIP2= yes
+.ifdef WITH_DATABASE
+WANT_PHP_PEAR= yes
+.endif
+
+.ifdef WITH_LDAP
+USE_PHP= ${USE_PHP} ldap
+.endif
+
.ifndef WITHOUT_WWWDIR
SQUIRRELDIR?= ${PREFIX}/www/squirrelmail
.else
@@ -43,6 +51,9 @@ pre-everything::
@${ECHO_CMD} "To use the old location ${PREFIX}/squirrelmail define"
@${ECHO_CMD} "WITHOUT_WWWDIR when patching or installing"
@${ECHO_CMD}
+ @${ECHO_CMD} "Use WITH_LDAP to ensure PHP LDAP support is installed"
+ @${ECHO_CMD} "Use WITH_DATABASE to ensure PEAR framework for database support is installed"
+ @${ECHO_CMD}
.if !target(slaveport-post-patch)
slaveport-post-patch: