aboutsummaryrefslogtreecommitdiff
path: root/mail/squirreloutlook/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-01-08 23:03:14 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-01-08 23:03:14 +0000
commit6b5a7815a16433fd3a90314d53b3b7804adacce5 (patch)
tree4cc208513a828af8539cedc0515cfc0c4353368d /mail/squirreloutlook/Makefile
parentf0a889f6c8d960f7d0d5e8ac84b28f730afc557d (diff)
SquirrelOutlook is a standards-based webmail package written in PHP4. It
includes built-in pure PHP support for the IMAP and SMTP protocols, and all pages render in pure HTML 4.0 (with no Javascript) for maximum compatibility across browsers. It has very few requirements and is very easy to configure and install. SquirrelOutlook has a all the functionality you would want from an email client, including strong MIME support, address books, and folder manipulation WWW: http://sourceforge.net/projects/squirreloutlook/ - Dennis Cabooter freebsd@rootxs.org PR: ports/107303 Submitted by: Simon Dick <simond at irrelevant.org>
Notes
Notes: svn path=/head/; revision=181815
Diffstat (limited to 'mail/squirreloutlook/Makefile')
-rw-r--r--mail/squirreloutlook/Makefile103
1 files changed, 103 insertions, 0 deletions
diff --git a/mail/squirreloutlook/Makefile b/mail/squirreloutlook/Makefile
new file mode 100644
index 000000000000..9ba1127c7ca7
--- /dev/null
+++ b/mail/squirreloutlook/Makefile
@@ -0,0 +1,103 @@
+# New ports collection makefile for: squirrelmailoutlook
+# Date created: 28 December 2006
+# Whom: Simon Dick <simond@irrelevant.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= squirreloutlook
+PORTVERSION= 1.0.3
+CATEGORIES= mail www
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME} \
+ squirrelmail
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
+ all_locales-1.5.1-20060409${EXTRACT_SUFX}
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= freebsd@rootxs.org
+COMMENT= A webmail system which accesses mail over IMAP
+
+USE_PHP= session mhash gettext mbstring pcre openssl xml
+WANT_PHP_WEB= yes
+USE_GETTEXT= yes
+
+.ifdef WITH_DATABASE
+RUN_DEPENDS+= ${PREFIX}/share/pear/DB.php:${PORTSDIR}/databases/pear-DB
+.endif
+
+.ifdef WITH_LDAP
+USE_PHP+= ldap
+.endif
+
+SQUIRRELDIR= ${PREFIX}/www/${PORTNAME}
+
+PLIST_SUB= PORTVERSION=${PORTVERSION} \
+ SQUIRRELDIR="${SQUIRRELDIR:S,^${PREFIX}/,,}"
+
+SUB_FILES= pkg-message pkg-install pkg-deinstall
+SUB_LIST= SQUIRRELDIR=${SQUIRRELDIR}
+
+PORTDOCS= *
+
+pre-everything::
+ @${ECHO_CMD} "Use WITH_LDAP to ensure PHP LDAP support is installed"
+ @${ECHO_CMD} "Use WITH_DATABASE to ensure PEAR framework for database support is installed"
+ @${ECHO_CMD} " (note that this does not install the database specific PEAR support, e.g. MySQL)"
+ @${ECHO_CMD}
+
+post-patch:
+.ifndef PATCH_DEBUG
+ @${RM} -f ${WRKSRC}/config/config_default.php.orig ${WRKSRC}/functions/global.php.orig
+.endif
+ @${REINPLACE_CMD} -e 's|ispell|${LOCALBASE}/bin/ispell|g' \
+ ${WRKSRC}/plugins/squirrelspell/sqspell_config.php
+ @${RM} ${WRKSRC}/plugins/squirrelspell/sqspell_config.php.bak
+
+# Rearrange the documentation
+do-build:
+.for file in AUTHORS ChangeLog COPYING INSTALL README UPGRADE
+ @${MV} ${WRKSRC}/${file} ${WRKSRC}/doc/
+.endfor
+ @${MV} ${WRKSRC}/ReleaseNotes ${WRKSRC}/doc/ReleaseNotes-${PORTVERSION}.txt
+ @${MV} ${WRKSRC}/themes/README.themes ${WRKSRC}/doc/
+ @cd ${WRKSRC} ; for f in `find plugins -name "README*" -or \
+ -name INSTALL -or -name CHANGES -or -name HISTORY`; \
+ do \
+ ${MKDIR} doc/`dirname $$f` ; \
+ ${MV} $$f doc/`dirname $$f` ; \
+ done; \
+ ${MV} doc/plugins/squirrelspell/doc/README doc/plugins/squirrelspell ; \
+ ${RM} -rf doc/plugins/squirrelspell/doc ; \
+ ${MV} plugins/squirrelspell/doc/* doc/plugins/squirrelspell ; \
+ ${RM} -f doc/plugins/squirrelspell/index.php ; \
+ ${RM} -rf plugins/squirrelspell/doc
+ @${ECHO} "left_refresh=300" >> ${WRKSRC}/data/default_pref
+ @${CP} -r ${WRKSRC}/../locale ${WRKSRC}
+ @${CP} -r ${WRKSRC}/../images ${WRKSRC}
+ @${CP} -r ${WRKSRC}/../help ${WRKSRC}
+
+pre-install:
+ @${ECHO} "Your umask should be lax while installing this. Like, 022 or something."
+ @${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
+
+do-install:
+ ${MKDIR} ${PREFIX}/etc/periodic/daily
+ ${INSTALL_SCRIPT} ${FILESDIR}/111.clean-squirrelmail ${PREFIX}/etc/periodic/daily
+ ${MKDIR} ${SQUIRRELDIR}
+ @${CP} -pv ${WRKSRC}/index.php ${SQUIRRELDIR}
+ @${CP} -pv ${WRKSRC}/configure ${SQUIRRELDIR}
+.for DIR in class config data functions help images include locale plugins po src themes
+ @${CP} -rpv ${WRKSRC}/${DIR} ${SQUIRRELDIR}
+.endfor
+ ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${SQUIRRELDIR}/data
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ @${CP} -Rv ${WRKSRC}/doc/* ${DOCSDIR}
+.endif
+
+post-install:
+ @${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>